]> git.pld-linux.org Git - packages/net-snmp.git/blobdiff - net-snmp.spec
Provide hrMIB data via librpm for rpm 4.16
[packages/net-snmp.git] / net-snmp.spec
index e5519e5b5284727fdd59a9ec0f83721234523935..0a5841863cfdee5bda07f5e0a4ce989f0d510bc1 100644 (file)
@@ -1,26 +1,22 @@
 # TODO
-# - package or remove:
-#   %{_datadir}/snmp/snmp_perl.pl
 # - make noarch -n mibs-net-snmp package (need separate .spec then)
 # - FHS: #define NETSNMP_AGENTX_SOCKET "/var/agentx/master"
-# - php-snmp (and likely other bindings) use only %{_libdir}/libnetsnmp.so.*, move other libs back to main (daemon) package?
 #
 # Conditional build:
-%bcond_without autodeps        # don't BR packages only for deps resolving
-%bcond_without rpm             # don't include RPM support
-%bcond_without kerberos5       # don't include kerberos support
-%bcond_without lm_sensors      # don't include sensors support
-%bcond_without perl            # don't include Perl modules and utils
-%bcond_without python          # don't include Python modules
-%bcond_without static_libs     # don't build static library
-
-%ifnarch %{ix86} %{x8664}
+%bcond_without rpm             # RPM support
+%bcond_with    rpm5            # Use RPM5 provided /var/cache/hrmib for hrSWInstalledTable data
+%bcond_without kerberos5       # Kerberos support
+%bcond_without lm_sensors      # LM sensors support
+%bcond_without perl            # Perl modules and utils
+%bcond_without python          # Python (3.x) modules
+%bcond_without python2         # Python 2.x modules
+%bcond_without static_libs     # static library
+
+%ifnarch %{ix86} %{x8664} x32
 %undefine      with_lm_sensors
 %endif
 
-%define        so_version      20
-
-%include       /usr/lib/rpm/macros.perl
+%define                so_version      40
 Summary:       A collection of SNMP protocol tools
 Summary(es.UTF-8):     Agente SNMP de la UCD
 Summary(pl.UTF-8):     Kolekcja narzędzi do obsługi protokołu SNMP
@@ -28,12 +24,12 @@ Summary(pt_BR.UTF-8):       Agente SNMP da UCD
 Summary(ru.UTF-8):     Набор утилит для протокола SNMP от UC-Davis
 Summary(uk.UTF-8):     Набір утиліт для протоколу SNMP від UC-Davis
 Name:          net-snmp
-Version:       5.5
-Release:       1
+Version:       5.9
+Release:       4
 License:       BSD-like
 Group:         Networking/Daemons
-Source0:       http://dl.sourceforge.net/net-snmp/%{name}-%{version}.tar.gz
-# Source0-md5: 5b2551e7bd024fbbee84dca22a5f13a1
+Source0:       http://downloads.sourceforge.net/net-snmp/%{name}-%{version}.tar.gz
+# Source0-md5: 382da80138897f294299badf9c62c699
 Source1:       %{name}d.init
 Source2:       %{name}d.conf
 Source3:       %{name}d.sysconfig
@@ -42,56 +38,69 @@ Source5:    %{name}trapd.conf
 Source6:       %{name}trapd.sysconfig
 Source7:       ucd-ipchains.tar.gz
 # Source7-md5: 29949f1008f1a04d6efefd5b3ea607da
+Source9:       snmpd.logrotate
 Patch0:                %{name}-acfix.patch
 Patch1:                %{name}-rpm-implicit-libs.patch
 Patch2:                %{name}-config-noflags.patch
 Patch3:                %{name}-manpage.patch
 Patch4:                %{name}-link.patch
-Patch5:                %{name}-llinterfaces.patch
 Patch6:                %{name}-kernel_headers.patch
 Patch7:                %{name}-rpmpath.patch
-Patch8:                %{name}-snmpksm.patch
-Patch9:                %{name}-python.patch
-Patch10:       %{name}-lvalue.patch
-Patch11:       %{name}-defaultconfig.patch
-Patch12:       %{name}-use-rpm-hrmib.patch
-Patch13:       net-snmp-5.5-missing-bcast.patch
-Patch14:       %{name}-lm_sensors_3.patch
-Patch15:       net-snmp-5.5-tcp-pid.patch
-Patch17:       %{name}-TCP_STATS_CACHE_TIMEOUT.patch
-Patch19:       %{name}-loadave-writable.patch
+Patch8:                %{name}-python.patch
+Patch9:                %{name}-lvalue.patch
+Patch10:       %{name}-defaultconfig.patch
+Patch11:       %{name}-use-rpm-hrmib.patch
+Patch12:       %{name}-TCP_STATS_CACHE_TIMEOUT.patch
+Patch13:       %{name}-logging.patch
+Patch14:       %{name}-Remove-U64-typedef.patch
+Patch15:       1314610.patch
 URL:           http://www.net-snmp.org/
-BuildRequires: autoconf >= 2.61-3
+BuildRequires: autoconf >= 2.63
 BuildRequires: automake
 BuildRequires: elfutils-devel
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-BuildRequires: libnl-devel >= 1:1.1
+BuildRequires: libnl-devel >= 1:3.2
+BuildRequires: libpcap-devel
+BuildRequires: libssh2-devel
 BuildRequires: libtool >= 1.4
 BuildRequires: libwrap-devel
 %{?with_lm_sensors:BuildRequires:      lm_sensors-devel >= 3.0.1}
+BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7d
-%{?with_autodeps:BuildRequires:        perl-Term-ReadKey}
+BuildRequires: pciutils-devel
+BuildRequires: pcre-devel
 BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: pkgconfig >= 1:0.9.0
 %if %{with python}
-BuildRequires: python-devel
-BuildRequires: python-modules
+%if %{with python2}
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: python-modules >= 1:2.5
 BuildRequires: python-setuptools
+%endif
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-setuptools
 BuildRequires: rpm-pythonprov
 %endif
 %if %{with rpm}
 BuildRequires: rpm
 BuildRequires: rpm-perlprov >= 3.0.3-16
+%if %{without rpm5}
+BuildRequires: rpm-devel
+%endif
 %endif
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.527
 Requires(post,preun):  /sbin/chkconfig
+Requires:      %{name}-agent-libs = %{version}-%{release}
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      /usr/bin/setsid
 Requires:      mibs-%{name} = %{version}-%{release}
-Requires:      rc-scripts >= 0.2.0
+Requires:      rc-scripts >= 0.4.3.0
 Provides:      snmpd
 Obsoletes:     cmu-snmp
 Obsoletes:     snmpd
 Obsoletes:     ucd-snmp
+Conflicts:     pciutils < 3.1.7-5
 Conflicts:     rpm < 4.4.9-43.11
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -159,21 +168,36 @@ NET SNMP libraries.
 %description libs -l pl.UTF-8
 Biblioteki SNMP.
 
+%package agent-libs
+Summary:       The NET-SNMP runtime agent libraries
+Summary(pl.UTF-8):     Biblioteki uruchomieniowe agenta NET-SNMP
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description agent-libs
+The net-snmp-agent-libs package contains the runtime agent libraries
+for shared binaries and applications.
+
+%description agent-libs -l pl.UTF-8
+Ten pakiet zawiera biblioteki uruchomieniowe agenta SNMP.
+
 %package devel
 Summary:       The development environment for the net-snmp project
 Summary(es.UTF-8):     Archivos de inclusión y bibliotecas para desarrollo en el SNMP de la UCD
 Summary(pl.UTF-8):     Pliki dla programistów używających bibliotek net-snmp
 Summary(pt_BR.UTF-8):  Arquivos de inclusão e bibliotecas para desenvolvimento no SNMP da UCD
-Summary(ru.UTF-8):     Среда разработки для проекта UCD-SNMP
-Summary(uk.UTF-8):     Середовище розробки для проекту UCD-SNMP
+Summary(ru.UTF-8):     Среда разработки для проекта NET-SNMP
+Summary(uk.UTF-8):     Середовище розробки для проекту NET-SNMP
 Group:         Development/Libraries
+Requires:      %{name}-agent-libs = %{version}-%{release}
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      elfutils-devel
 %{?with_kerberos5:Requires:    heimdal-devel}
-Requires:      libnl-devel >= 1:1.1
+Requires:      libnl-devel >= 1:3.2
 Requires:      libwrap-devel
 %{?with_lm_sensors:Requires:   lm_sensors-devel >= 3.0.1}
 Requires:      openssl-devel >= 0.9.7c
+Requires:      pciutils-devel
 Obsoletes:     ucd-snmp-devel
 
 %description devel
@@ -223,21 +247,21 @@ Statyczne biblioteki net-snmp.
 Bibliotecas estáticas para desenvolvimento com net-snmp.
 
 %package compat-devel
-Summary:       The development environment for the UCD-SNMP project
+Summary:       The development environment for the NET-SNMP project
 Summary(es.UTF-8):     Archivos de inclusión y bibliotecas para desarrollo en el SNMP de la UCD
-Summary(pl.UTF-8):     Pliki dla programistów używających bibliotek UCD-SNMP
+Summary(pl.UTF-8):     Pliki dla programistów używających bibliotek NET-SNMP
 Summary(pt_BR.UTF-8):  Arquivos de inclusão e bibliotecas para desenvolvimento no SNMP da UCD
-Summary(ru.UTF-8):     Среда разработки для проекта UCD-SNMP
-Summary(uk.UTF-8):     Середовище розробки для проекту UCD-SNMP
+Summary(ru.UTF-8):     Среда разработки для проекта NET-SNMP
+Summary(uk.UTF-8):     Середовище розробки для проекту NET-SNMP
 Group:         Development/Libraries
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
 Requires:      openssl-devel >= 0.9.7d
 Obsoletes:     cmu-snmp-devel
 Obsoletes:     ucd-snmp-devel
 
 %description compat-devel
 The ucd-snmp-devel package contains the development libraries and
-header files for use with the UCD-SNMP project's network management
+header files for use with the NET-SNMP project's network management
 tools.
 
 %description compat-devel -l es.UTF-8
@@ -256,27 +280,27 @@ para uso no gerenciamento de redes.
 
 %description compat-devel -l ru.UTF-8
 Пакет ucd-snmp-devel содержит библиотеки разработчика и хедера для
-использования с утилитами управления сетью проекта UCD-SNMP.
+использования с утилитами управления сетью проекта NET-SNMP.
 
 %description compat-devel -l uk.UTF-8
 Пакет ucd-snmp-devel містить бібліотеки програміста та хедери для
-використання з утилітами керування мережею проекту UCD-SNMP.
+використання з утилітами керування мережею проекту NET-SNMP.
 
 %package compat-static
-Summary:       Static UCD-SNMP libraries
-Summary(pl.UTF-8):     Statyczne biblioteki UCD-SNMP
+Summary:       Static NET-SNMP libraries
+Summary(pl.UTF-8):     Statyczne biblioteki NET-SNMP
 Summary(pt_BR.UTF-8):  Bibliotecas estáticas para desenvolvimento com ucd-snmp
-Summary(ru.UTF-8):     Статические библиотеки для проекта UCD-SNMP
-Summary(uk.UTF-8):     Статичні бібліотеки для проекту UCD-SNMP
+Summary(ru.UTF-8):     Статические библиотеки для проекта NET-SNMP
+Summary(uk.UTF-8):     Статичні бібліотеки для проекту NET-SNMP
 Group:         Development/Libraries
 Requires:      %{name}-compat-devel = %{version}-%{release}
 Obsoletes:     ucd-snmp-static
 
 %description compat-static
-Static UCD-SNMP libraries.
+Static NET-SNMP libraries.
 
 %description compat-static -l pl.UTF-8
-Statyczne biblioteki UCD-SNMP.
+Statyczne biblioteki NET-SNMP.
 
 %description compat-static -l pt_BR.UTF-8
 Bibliotecas estáticas para desenvolvimento com ucd-snmp.
@@ -288,6 +312,7 @@ Group:              Applications/System
 Requires:      mibs-dirs
 Obsoletes:     net-snmp-mibs
 Conflicts:     ucd-snmp-libs
+BuildArch:     noarch
 
 %description -n mibs-net-snmp
 Net-SNMP provided MIBs (Management Information Base).
@@ -320,6 +345,7 @@ Summary(ru.UTF-8):  Утилиты управления сетью по SNMP из
 Summary(uk.UTF-8):     Утиліти керування мережею по SNMP з проекту NET-SNMP
 Group:         Applications/System
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-agent-libs = %{version}-%{release}
 Suggests:      mibs-%{name} = %{version}-%{release}
 Obsoletes:     cmu-snmp-utils
 Obsoletes:     ucd-snmp-utils
@@ -352,6 +378,7 @@ como: snmpwalk, snmptest e outros.
 Summary:       SNMP and NetSNMP::* Perl modules
 Summary(pl.UTF-8):     Moduły Perla SNMP oraz NetSNMP::*
 Group:         Development/Languages/Perl
+Requires:      %{name}-agent-libs = %{version}-%{release}
 Requires:      %{name}-libs = %{version}-%{release}
 Conflicts:     ucd-snmp-utils-perl
 
@@ -406,8 +433,8 @@ MIB browser in Tk.
 Przeglądarka MIB-ów w Tk.
 
 %package -n python-netsnmp
-Summary:       Python netsnmp extension module
-Summary(pl.UTF-8):     Moduł rozszerzenia netsnmp dla Pythona
+Summary:       Python netsnmp extension module
+Summary(pl.UTF-8):     Moduł rozszerzenia netsnmp dla Pythona 2
 Group:         Libraries/Python
 Requires:      %{name}-libs = %{version}-%{release}
 
@@ -419,32 +446,47 @@ tri-lingual SNMP (SNMPv3, SNMPv2c, SNMPv1) client API.
 Moduł rozszerzenia netsnmp dla Pythona udostępnia pełne API klienckie
 SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
 
+%package -n python3-netsnmp
+Summary:       Python 3 netsnmp extension module
+Summary(pl.UTF-8):     Moduł rozszerzenia netsnmp dla Pythona 3
+Group:         Libraries/Python
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description -n python3-netsnmp
+The 'netsnmp' Python extension module provides a full featured,
+tri-lingual SNMP (SNMPv3, SNMPv2c, SNMPv1) client API.
+
+%description -n python3-netsnmp -l pl.UTF-8
+Moduł rozszerzenia netsnmp dla Pythona udostępnia pełne API klienckie
+SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
+
 %prep
 %setup -q -a7
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%if %{with rpm5}
 %patch11 -p1
+%endif
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
-%patch17 -p1
-%patch19 -p1
+
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' \
+      perl/SNMP/examples/pingmib.pl
 
 %build
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
-cp -f /usr/share/automake/config.sub .
 
 MIBS="\
 host agentx smux \
@@ -459,85 +501,100 @@ misc/ipfwacc \
 MIBS="$MIBS ucd-snmp/lmsensorsMib"
 %endif
 
+# ksm must be first in --with-security-modules
+# usm is always enabled
 %configure \
-       --disable-debugging \
+       ac_cv_path_DPKG_QUERY_PATH= \
        --enable-as-needed \
-       %{!?with_static_libs:--disable-static} \
-       --with-cflags="%{rpmcflags} -I/usr/include/et" \
+       %{__disable static_libs static} \
+       --with-cflags="%{rpmcflags} %{rpmcppflags} -I/usr/include/et" \
        --with-ldflags="%{rpmldflags}" \
        --with-defaults \
        --with-default-snmp-version=3 \
-       %{?with_kerberos5:--with-krb5=%{_prefix}} \
-       %{!?with_kerberos5:--without-krb5} \
-       --with-openssl=%{_prefix} \
-       --with-libwrap=%{_prefix} \
-       --with-logfile="%{logfile}" \
-       --with-zlib=%{_prefix} \
-       --with-bzip2=%{_prefix} \
-       --with%{!?with_perl:out}-perl-modules \
-       --with%{!?with_python:out}-python-modules \
+       %{__with_without kerberos5 krb5} \
+       --with-openssl \
+       --with-libwrap \
+       --with-logfile=%{logfile} \
+       --with-zlib\
+       --with-bzip2 \
+       --with-nl \
+       %{__with_without perl perl-modules} \
+       %{__with_without python python-modules} \
        --enable-local-smux \
-       --with-mibdirs='$HOME/.snmp/mibs:/usr/share/mibs:%{_datadir}/snmp/mibs' \
+       --with-mibdirs='$HOME/.snmp/mibs:/usr/share/mibs' \
        --with-mib-modules="$MIBS" \
-       %{?with_kerberos5:--with-security-modules="ksm"} \
+       --with-security-modules="%{?with_kerberos5:ksm }tsm" \
        --with-sys-contact="root@localhost" \
        --with-sys-location="Unknown" \
-       --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback" \
+       --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback Alias DTLSUDP TLSTCP SSH" \
        --with-persistent-directory="/var/lib/net-snmp" \
        --enable-ucd-snmp-compatibility \
        --enable-ipv6 \
-       --with%{!?with_rpm:out}-rpm
+       %{!?debug:--disable-debugging} \
+       %{__with_without rpm}
 
 %{__make} -j1
 
-cd perl
+TOPDIR="$(pwd)"
 
-%{__perl} Makefile.PL \
+cd perl
+%{__perl} -I. Makefile.PL \
+       -NET-SNMP-CONFIG="${TOPDIR}/net-snmp-config" \
        -NET-SNMP-IN-SOURCE=true \
        INSTALLDIRS=vendor \
-       OPTIMIZE="%{rpmcflags}" \
+       OPTIMIZE="%{rpmcflags} %{rpmcppflags}" \
        </dev/null
 
 # avoid rpaths generated by MakeMaker
-perl -pi -e 's@LD_RUN_PATH="\$\(LD_RUN_PATH\)" @@' */Makefile */*/Makefile
+%{__perl} -pi -e 's@LD_RUN_PATH="\$\(LD_RUN_PATH\)" @@' */Makefile */*/Makefile
 
 %{__make} \
-       LDFLAGS="%{rpmldflags}"
+       LDFLAGS="%{rpmldflags} -L${TOPDIR}/snmplib/.libs/ -L${TOPDIR}/agent/.libs/"
+cd ..
+
+%if %{with python2}
+cd python
+%py_build \
+       --basedir=$TOPDIR
+cd ..
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,snmp},/var/log,/var/lib/net-snmp,%{_libdir}/snmp/dlmod}
+install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,logrotate.d,sysconfig,snmp},/var/log,/var/lib/net-snmp,%{_libdir}/snmp/dlmod}
 
 %{__make} -j1 install \
        mibdir=%{_datadir}/mibs \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
 :> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.local.conf
 :> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmp.conf
 :> $RPM_BUILD_ROOT%{logfile}
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmpd
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/snmpd
+install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmpd
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
+cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/snmpd
+
+install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmptrapd
+cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmptrapd.conf
+cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/snmptrapd
 
-install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmptrapd
-install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmptrapd.conf
-install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/snmptrapd
+cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/logrotate.d/snmpd
 
 cd perl
 %{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
-install SNMP/examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
+install -p SNMP/examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
 cd ..
 
 # IP-Filter (non-Linux)
-rm -f $RPM_BUILD_ROOT%{_bindir}/ipf-mod.pl
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/ipf-mod.pl
 
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle/MakefileSubs.pm
 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
-rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle/Makefile.subs.pl
 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Bundle/NetSNMP/.packlist
 
 %if %{with static_libs}
@@ -554,10 +611,19 @@ for a in $RPM_BUILD_ROOT%{_libdir}/libnet*.a; do
        fi
 done
 %else
-rm -f $RPM_BUILD_ROOT%{_libdir}/libsnmp.a
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsnmp.a
 %endif
 
 %if %{with python}
+%{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/netsnmp/tests
+%endif
+
+%if %{with python2}
+cd python
+%py_install \
+       --basedir=$TOPDIR
+cd ..
+
 %{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/tests
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/*.py
 %endif
@@ -580,6 +646,9 @@ fi
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
+%post  agent-libs -p /sbin/ldconfig
+%postun        agent-libs -p /sbin/ldconfig
+
 %triggerpostun -- ucd-snmp
 /sbin/chkconfig --add snmpd
 
@@ -600,22 +669,21 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README local
-%doc ChangeLog EXAMPLE.conf.def EXAMPLE.conf
-%doc FAQ NEWS PORTING README.snmpv3 TODO AGENT.txt
+%doc AGENT.txt CHANGES COPYING ChangeLog EXAMPLE.conf{,.def} FAQ NEWS README{,.agent-mibs,.agentx,.snmpv3,.sql,.thread} TODO local
 
 %attr(754,root,root) /etc/rc.d/init.d/snmpd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/snmpd
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/snmpd
 
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmpd.conf
 %attr(640,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmpd.local.conf
 
 %attr(755,root,root) %{_sbindir}/snmpd
 %attr(755,root,root) %{_bindir}/net-snmp-create-v3-user
-
+%attr(755,root,root) %{_bindir}/sshtosnmp
 %dir %{_libdir}/snmp
 %dir %{_libdir}/snmp/dlmod
-
+%attr(755,root,root) %{_datadir}/snmp/snmp_perl.pl
 %{_mandir}/man1/net-snmp-create-v3-user.1*
 %{_mandir}/man5/snmpd.conf.5*
 %{_mandir}/man5/snmpd.examples.5*
@@ -629,17 +697,20 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libnetsnmp.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libnetsnmp.so.%{so_version}
 %dir %{_sysconfdir}/snmp
 %dir %{_datadir}/snmp
-%attr(755,root,root) %{_libdir}/libnetsnmp.so.*.*
-%attr(755,root,root) %{_libdir}/libnetsnmpagent.so.*.*
-%attr(755,root,root) %{_libdir}/libnetsnmphelpers.so.*.*
-%attr(755,root,root) %{_libdir}/libnetsnmpmibs.so.*.*
-%attr(755,root,root) %{_libdir}/libnetsnmptrapd.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libnetsnmp.so.%{so_version}
+
+%files agent-libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libnetsnmpagent.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libnetsnmpagent.so.%{so_version}
+%attr(755,root,root) %{_libdir}/libnetsnmphelpers.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libnetsnmphelpers.so.%{so_version}
+%attr(755,root,root) %{_libdir}/libnetsnmpmibs.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libnetsnmpmibs.so.%{so_version}
+%attr(755,root,root) %{_libdir}/libnetsnmptrapd.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libnetsnmptrapd.so.%{so_version}
 
 %files devel
@@ -658,6 +729,8 @@ fi
 %{_libdir}/libnetsnmpmibs.la
 %{_libdir}/libnetsnmptrapd.la
 %{_includedir}/net-snmp
+%{_pkgconfigdir}/netsnmp.pc
+%{_pkgconfigdir}/netsnmp-agent.pc
 %{_datadir}/snmp/mib2c*
 %{_mandir}/man1/mib2c.1*
 %{_mandir}/man1/mib2c-update.1*
@@ -668,7 +741,11 @@ fi
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libnet*.a
+%{_libdir}/libnetsnmp.a
+%{_libdir}/libnetsnmpagent.a
+%{_libdir}/libnetsnmphelpers.a
+%{_libdir}/libnetsnmpmibs.a
+%{_libdir}/libnetsnmptrapd.a
 %endif
 
 %files compat-devel
@@ -701,6 +778,7 @@ fi
 
 %files utils
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/agentxtrap
 %attr(755,root,root) %{_bindir}/encode_keychange
 %attr(755,root,root) %{_bindir}/snmpbulkget
 %attr(755,root,root) %{_bindir}/snmpbulkwalk
@@ -710,15 +788,21 @@ fi
 %attr(755,root,root) %{_bindir}/snmpgetnext
 %attr(755,root,root) %{_bindir}/snmpinform
 %attr(755,root,root) %{_bindir}/snmpnetstat
+%attr(755,root,root) %{_bindir}/snmppcap
+%attr(755,root,root) %{_bindir}/snmpping
+%attr(755,root,root) %{_bindir}/snmpps
 %attr(755,root,root) %{_bindir}/snmpset
 %attr(755,root,root) %{_bindir}/snmpstatus
 %attr(755,root,root) %{_bindir}/snmptable
 %attr(755,root,root) %{_bindir}/snmptest
+%attr(755,root,root) %{_bindir}/snmptls
+%attr(755,root,root) %{_bindir}/snmptop
 %attr(755,root,root) %{_bindir}/snmptranslate
 %attr(755,root,root) %{_bindir}/snmptrap
 %attr(755,root,root) %{_bindir}/snmpusm
 %attr(755,root,root) %{_bindir}/snmpvacm
 %attr(755,root,root) %{_bindir}/snmpwalk
+%{_mandir}/man1/agentxtrap.1*
 %{_mandir}/man1/encode_keychange.1*
 %{_mandir}/man1/snmpbulkget.1*
 %{_mandir}/man1/snmpbulkwalk.1*
@@ -729,10 +813,12 @@ fi
 %{_mandir}/man1/snmpgetnext.1*
 %{_mandir}/man1/snmpinform.1*
 %{_mandir}/man1/snmpnetstat.1*
+%{_mandir}/man1/snmpps.1*
 %{_mandir}/man1/snmpset.1*
 %{_mandir}/man1/snmpstatus.1*
 %{_mandir}/man1/snmptable.1*
 %{_mandir}/man1/snmptest.1*
+%{_mandir}/man1/snmptop.1*
 %{_mandir}/man1/snmptranslate.1*
 %{_mandir}/man1/snmptrap.1*
 %{_mandir}/man1/snmpusm.1*
@@ -751,16 +837,13 @@ fi
 %{perl_vendorarch}/NetSNMP
 %dir %{perl_vendorarch}/auto/SNMP
 %{perl_vendorarch}/auto/SNMP/autosplit.ix
-%{perl_vendorarch}/auto/SNMP/SNMP.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/SNMP/SNMP.so
 %dir %{perl_vendorarch}/auto/NetSNMP
 %dir %{perl_vendorarch}/auto/NetSNMP/*
 %{perl_vendorarch}/auto/NetSNMP/*/autosplit.ix
-%{perl_vendorarch}/auto/NetSNMP/*/*.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/NetSNMP/*/*.so
 %dir %{perl_vendorarch}/auto/NetSNMP/agent/default_store
 %{perl_vendorarch}/auto/NetSNMP/agent/default_store/autosplit.ix
-%{perl_vendorarch}/auto/NetSNMP/agent/default_store/default_store.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/NetSNMP/agent/default_store/default_store.so
 %{_mandir}/man3/NetSNMP::*.3*
 %{_mandir}/man3/SNMP.3*
@@ -768,10 +851,14 @@ fi
 
 %files utils-perl
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/checkbandwidth
 %attr(755,root,root) %{_bindir}/fixproc
+%attr(755,root,root) %{_bindir}/net-snmp-cert
+%attr(755,root,root) %{_bindir}/snmp-bridge-mib
 %attr(755,root,root) %{_bindir}/snmpcheck
 %attr(755,root,root) %{_bindir}/traptoemail
 %{_mandir}/man1/fixproc.1*
+%{_mandir}/man1/snmp-bridge-mib.1*
 %{_mandir}/man1/traptoemail.1*
 %endif
 
@@ -788,11 +875,21 @@ fi
 %{_mandir}/man1/tkmib.1*
 %endif
 
-%if %{with python}
+%if %{with python2}
 %files -n python-netsnmp
 %defattr(644,root,root,755)
 %dir %{py_sitedir}/netsnmp
-%attr(755,root,root) %{py_sitedir}/netsnmp/*.so
+%attr(755,root,root) %{py_sitedir}/netsnmp/client_intf.so
 %{py_sitedir}/netsnmp/*.py[co]
 %{py_sitedir}/netsnmp_python-*.egg-info
 %endif
+
+%if %{with python}
+%files -n python3-netsnmp
+%defattr(644,root,root,755)
+%dir %{py3_sitedir}/netsnmp
+%attr(755,root,root) %{py3_sitedir}/netsnmp/client_intf.cpython-*.so
+%{py3_sitedir}/netsnmp/*.py
+%{py3_sitedir}/netsnmp/__pycache__
+%{py3_sitedir}/netsnmp_python-*.egg-info
+%endif
This page took 0.078502 seconds and 4 git commands to generate.