]> git.pld-linux.org Git - packages/mutt.git/blobdiff - mutt.spec
- -missing_includes.patch added (builds with gcc4 now)
[packages/mutt.git] / mutt.spec
index 8f2adc6a9b9042e6132077fad0abbb3b0c387ebb..ad46220b6eea525d9ff26f4078796b544eb80ac5 100644 (file)
--- a/mutt.spec
+++ b/mutt.spec
@@ -1,10 +1,11 @@
 #
 # Conditional build:
-%bcond_with slang              # use slang library instead of ncurses
-%bcond_with nntp               # use VVV's NNTP patch
-%bcond_with esmtp              # use esmtp patch
-%bcond_without sasl            # don't use sasl
-%bcond_without home_etc                # don't use home_etc
+%bcond_with    slang           # use slang library instead of ncurses
+%bcond_with    nntp            # use VVV's NNTP patch
+%bcond_with    esmtp           # use esmtp patch
+%bcond_with    folder_column   # build with folder_column patch
+%bcond_without sasl            # don't use sasl
+%bcond_without home_etc        # don't use home_etc
 #
 Summary:       The Mutt Mail User Agent
 Summary(de):   Der Mutt Mail-User-Agent
@@ -18,7 +19,7 @@ Summary(tr):  Mutt elektronik posta program
 Summary(uk):   ðÏÛÔÏ×Á Ë̦¤ÎÔÓØËÁ ÐÒÏÇÒÁÍÁ Mutt
 Name:          mutt
 Version:       1.4.2.1
-Release:       4
+Release:       10
 Epoch:         6
 License:       GPL
 Group:         Applications/Mail
@@ -27,6 +28,7 @@ Source0:      ftp://ftp.mutt.org/mutt/%{name}-%{version}i.tar.gz
 Source1:       %{name}.desktop
 Source2:       %{name}.png
 Source3:       %{name}.1.pl
+Patch0:                %{name}-paths.patch
 Patch1:                %{name}-forcedotlock.patch
 Patch2:                %{name}-muttbug-tmp.patch
 Patch3:                %{name}-rr.compressed.patch
@@ -49,24 +51,28 @@ Patch19:    %{name}-nntp.patch
 Patch20:       %{name}-esmtp.patch
 Patch21:       %{name}-home_etc.patch
 Patch22:       %{name}-kill_warnings.patch
+Patch23:       %{name}-Muttrc_mbox_path.patch
+Patch24:       %{name}-po.patch
+Patch25:       %{name}-missing_includes.patch
 URL:           http://www.mutt.org/
+%{!?with_slang:BuildRequires:  ncurses-devel >= 5.4-0.7}
 BuildRequires: autoconf
 BuildRequires: automake
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel >= 2.1.0}
-%{?with_home_etc:BuildRequires:        home-etc-devel >= 1.0.8}
 BuildRequires: gettext-devel
-%{!?with_slang:BuildRequires:  ncurses-devel >= 5.0}
-BuildRequires: openssl-devel >= 0.9.7c
-BuildRequires: sgml-tools
+BuildRequires: groff
+%{?with_home_etc:BuildRequires:        home-etc-devel >= 1.0.8}
+%{?with_esmtp:BuildRequires:   libesmtp-devel}
+BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: sgml-tools >= 1.0.9-20
 BuildRequires: sgml-tools-dtd
 %{?with_slang:BuildRequires:   slang-devel}
-%{?with_esmtp:BuildRequires:   libesmtp-devel}
+%{?with_home_etc:Requires:     home-etc >= 1.0.8}
 Requires:      iconv
 Requires:      mailcap
-%{?with_home_etc:Requires:     home-etc >= 1.0.8}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                specflags_ia32  "-fomit-frame-pointer"
+%define                specflags_ia32  -fomit-frame-pointer
 
 %description
 Mutt is a small but very poweful full-screen Unix mail client.
@@ -127,6 +133,7 @@ Mutt - 
 
 %prep
 %setup -q -n %{name}-%(echo %{version} | sed 's/i$//')
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -138,7 +145,8 @@ Mutt - 
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
+# breaks display if arrow_cursor is set
+%{?with_folder_column:%patch12 -p1}
 # disabled - changes default behaviour
 ##%patch13 -p0
 %patch14 -p1
@@ -150,6 +158,9 @@ Mutt - 
 %{?with_esmtp:%patch20 -p1}
 %{?with_home_etc:%patch21 -p1}
 %patch22 -p1
+%patch23 -p1
+%patch24 -p1
+%patch25 -p1
 
 # force regeneration (manual.sgml is modified by some patches)
 rm -f doc/{manual*.html,manual.txt}
@@ -160,7 +171,7 @@ rm -f doc/{manual*.html,manual.txt}
 %{__autoheader}
 %{__automake}
 %configure \
-       %{!?debug:--disable-debug} %{?debug:--enable-debug} \
+       --%{?debug:en}%{!?debug:dis}able-debug \
        %{!?with_slang:--with-curses} \
        %{?with_slang:--with-slang} \
        --enable-compressed \
@@ -172,12 +183,12 @@ rm -f doc/{manual*.html,manual.txt}
        --enable-pop \
        %{?with_nntp:--enable-nntp} \
        --with-regex \
-       %{?with_sasl:--with-sasl} %{!?with_sasl:--without-sasl} \
-       %{?with_home_etc:--with-home-etc} %{!?with_home_etc:--without-home-etc} \
+       --with%{!?with_sasl:out}-sasl \
+       --with%{!?with_home_etc:out}-home-etc \
        %{?with_esmtp:--enable-libesmtp --with-libesmtp=/usr} \
        --with-ssl \
        --disable-warnings \
-       --with-docdir=%{_docdir}/%{name}-%{version} \
+       --with-docdir=%{_docdir}/%{name} \
        --with-homespool=Maildir \
        --with-mailpath=/var/mail \
        --with-sharedir=%{_datadir} \
@@ -192,7 +203,7 @@ rm -f doc/{manual*.html,manual.txt}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1,%{_datadir}/%{name}}
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -202,12 +213,15 @@ install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1,%{_d
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
-install doc/manual.txt $RPM_BUILD_ROOT%{_datadir}/%{name}
+
+# keep manual.txt.gz, the rest is installed as %doc
+rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/[!m]*
+gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}/manual.txt
 
 # conflict with qmail
 rm -f $RPM_BUILD_ROOT%{_mandir}/man5/mbox.5*
 
-rm -f $RPM_BUILD_ROOT/etc/mime.types
+rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
 
 %find_lang %{name}
 
@@ -217,14 +231,14 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc contrib/{*rc*,*cap*} ChangeLog README TODO NEWS README.SECURITY README.SSL README.xface %{?with_esmtp:Muttrc.esmtp}
-%config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/Muttrc
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc
 %attr(755,root,root) %{_bindir}/mutt
 %attr(755,root,root) %{_bindir}/flea
 %attr(755,root,root) %{_bindir}/muttbug
 %attr(755,root,root) %{_bindir}/pgp*
 %attr(2755,root,mail) %{_bindir}/mutt_dotlock
 
-%{_datadir}/%{name}
+%{_docdir}/%{name}
 %{_desktopdir}/*.desktop
 %{_pixmapsdir}/mutt.png
 %{_mandir}/man*/*
This page took 0.57198 seconds and 4 git commands to generate.