]> git.pld-linux.org Git - packages/mutt.git/blobdiff - mutt.spec
- openssl 1.0.0 build fix
[packages/mutt.git] / mutt.spec
index 95d1f9edd2933f45bcf4cab05c165d9ac06b1c47..8b690fa67e9c261efcea1bae588440fd1fd3d19c 100644 (file)
--- a/mutt.spec
+++ b/mutt.spec
@@ -1,8 +1,12 @@
 #
+# TODO:
+# - finish -folder_columns.patch
+#
 # Conditional build:
 %bcond_with    slang           # use slang library instead of ncurses
 %bcond_with    nntp            # use VVV's NNTP patch
 %bcond_with    folder_column   # build with folder_column patch
+%bcond_with    imap_recent     # show IMAP RECENT messages as new (instead of UNSEEN)
 %bcond_without sasl            # don't use sasl
 %bcond_without home_etc        # don't use home_etc
 #
@@ -17,38 +21,42 @@ Summary(ru.UTF-8):  Почтовая клиентская программа Mutt
 Summary(tr.UTF-8):     Mutt elektronik posta programı
 Summary(uk.UTF-8):     Поштова клієнтська програма Mutt
 Name:          mutt
-Version:       1.5.15
-Release:       1
+Version:       1.5.20
+Release:       0.1
 Epoch:         6
-License:       GPL
+License:       GPL v2+
 Group:         Applications/Mail
 Source0:       ftp://ftp.mutt.org/mutt/devel/%{name}-%{version}.tar.gz
-# Source0-md5: b2c1eb45fd958f6589ee52a98f2a3ce1
+# Source0-md5: 027cdd9959203de0c3c64149a7ee351c
 Source1:       %{name}.desktop
 Source2:       %{name}.png
 Source3:       %{name}.1.pl
 Patch0:                %{name}-pl.po-update.patch
 Patch1:                %{name}-forcedotlock.patch
+# http://mutt.org.ua/download/
 Patch2:                %{name}-rr.compressed.patch
 Patch3:                %{name}-bj.status-time.patch
+# http://mutt.org.ua/download/
 Patch4:                %{name}-vvv.quote.patch
 Patch5:                %{name}-null_name.patch
 Patch6:                %{name}-cd.trash_folder.patch
 Patch7:                %{name}-cd.purge_message.patch
 Patch8:                %{name}-cd.signatures_menu.patch
+# http://www.mutt.ca/patches/ (dw.crypt-autoselectkey)
 Patch9:                %{name}-crypt-autoselectkey.patch
-Patch10:       %{name}-pgp_hook.patch
-Patch11:       %{name}-manual.patch
-Patch12:       %{name}-send_charset.patch
-Patch13:       %{name}-xface.patch
-Patch14:       %{name}-Muttrc_mbox_path.patch
-Patch15:       %{name}-po.patch
-Patch16:       %{name}-vvv.nntp.patch
-Patch17:       %{name}-home_etc.patch
-Patch18:       %{name}-Muttrc.patch
-Patch19:       %{name}-muttbug-tmp.patch
-Patch20:       %{name}-folder_columns.patch
-Patch21:       %{name}-nr.tag_prefix_cond.patch
+Patch10:       %{name}-manual.patch
+Patch11:       %{name}-xface.patch
+Patch12:       %{name}-Muttrc_mbox_path.patch
+Patch13:       %{name}-po.patch
+# http://mutt.org.ua/download/
+Patch14:       %{name}-vvv.nntp.patch
+Patch15:       %{name}-home_etc.patch
+Patch16:       %{name}-Muttrc.patch
+Patch17:       %{name}-muttbug-tmp.patch
+Patch18:       %{name}-folder_columns.patch
+Patch19:       %{name}-imap_recent.patch
+Patch20:       %{name}-Muttrc.head.patch
+Patch21:       %{name}-smime.rc.patch
 URL:           http://www.mutt.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -58,7 +66,7 @@ BuildRequires:        docbook-dtd42-xml
 BuildRequires: docbook-style-xsl
 %{?with_home_etc:BuildRequires:        home-etc-devel >= 1.0.8}
 BuildRequires: gettext-devel
-BuildRequires: gpgme-devel >= 1:1.0.0
+BuildRequires: gpgme-devel >= 1:1.1.0
 BuildRequires: libidn-devel
 BuildRequires: lynx
 %{!?with_slang:BuildRequires:  ncurses-devel >= 5.0}
@@ -66,8 +74,8 @@ BuildRequires:        openssl-devel >= 0.9.7d
 %{?with_slang:BuildRequires:   slang-devel}
 BuildRequires: libxslt-progs
 Requires:      iconv
-Requires:      mailcap
 %{?with_home_etc:Requires:     home-etc >= 1.0.8}
+Suggests:      mailcap
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags_ia32   -fomit-frame-pointer 
@@ -145,16 +153,15 @@ Mutt - це невеликий, але потужний повноекранни
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
-%patch15 -p1
-%{?with_nntp:%patch16 -p1}
-%{?with_home_etc:%patch17 -p1}
-%patch18 -p1
-%patch19 -p1
+%{?with_nntp:%patch14 -p1}
+%{?with_home_etc:%patch15 -p1}
+%patch16 -p1
+%patch17 -p1
 # breaks display if arrow_cursor is set
-%{?with_folder_column:%patch20 -p1}
-# disabled - changes default behaviour
-#%patch21 -p0
+%{?with_folder_column:%patch18 -p1}
+%{?with_imap_recent:%patch19 -p1}
+%patch20 -p1
+%patch21 -p1
 
 # force regeneration (manual.sgml is modified by some patches)
 rm -f doc/{manual*.html,manual.txt}
@@ -177,34 +184,48 @@ rm -f doc/{manual*.html,manual.txt}
        --enable-mailtool \
        %{?with_nntp:--enable-nntp} \
        --enable-pop \
-       --with-bdb=/usr --without-gdbm \
+       --enable-smtp \
+       --with-bdb=/usr \
+       --without-gdbm \
        %{!?with_slang:--with-curses} \
        --with-docdir=%{_docdir}/%{name} \
        %{?with_home_etc:--with-home-etc} \
        --with-mailpath=/var/mail \
        --with-mixmaster \
        --with-regex \
-       %{?with_sasl:--with-sasl2} \
+       %{?with_sasl:--with-sasl} \
        %{?with_slang:--with-slang} \
        --with-ssl
 
+%{__make} -j1 -C doc
 %{__make}
-%{__make} manual.txt -C doc
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1}
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        DOTLOCK_GROUP=
 
-%{__patch} -p0 -d $RPM_BUILD_ROOT%{_sysconfdir} < %{PATCH12}
+%{__patch} -p2 -d $RPM_BUILD_ROOT%{_sysconfdir} < %{PATCH17}
+
+install contrib/gpg.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
+install contrib/smime.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
+install contrib/colors.linux $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d/colors.rc
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
 
+cat <<'EOF' >$RPM_BUILD_ROOT%{_bindir}/mutt_source-muttrc.d
+#!/bin/sh -e
+for rc in /etc/Muttrc.d/*.rc; do
+       [ ! -r "$rc" ] || echo "source \"$rc\""
+done
+EOF
+
 # keep manual.txt.gz, the rest is installed as %doc
 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/[!m]*
 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}/manual.txt
@@ -222,8 +243,11 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc contrib/{*rc*,*cap*} ChangeLog README TODO NEWS README.SECURITY README.SSL README.xface
+%dir %{_sysconfdir}/Muttrc.d
 %config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/Muttrc
+%config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/Muttrc.d/*.rc
 %attr(755,root,root) %{_bindir}/mutt
+%attr(755,root,root) %{_bindir}/mutt_source-muttrc.d
 %attr(755,root,root) %{_bindir}/flea
 %attr(755,root,root) %{_bindir}/muttbug
 %attr(755,root,root) %{_bindir}/pgp*
This page took 0.095641 seconds and 4 git commands to generate.