]> git.pld-linux.org Git - packages/mutt.git/blobdiff - mutt-rr.compressed.patch
- fixed applying of send_charset patch (Muttrc is regenerated by
[packages/mutt.git] / mutt-rr.compressed.patch
index 60ab97457876ce2d0ea24cef658c24adf3d51482..b4fedac1952589053e665f5d0071fe2010f96a6a 100644 (file)
@@ -55,7 +55,7 @@ diff -Nur mutt-1.3.27.orig/Makefile.in mutt-1.3.27/Makefile.in
 diff -Nur mutt-1.3.27.orig/Muttrc mutt-1.3.27/Muttrc
 --- mutt-1.3.27.orig/Muttrc    Tue Jan  1 21:18:05 2002
 +++ mutt-1.3.27/Muttrc Fri Feb  1 22:51:32 2002
-@@ -19,6 +19,11 @@
+@@ -19,6 +19,15 @@
  macro index   <f1> "!less /usr/local/doc/mutt/manual.txt\n" "Show Mutt documentation"
  macro pager   <f1> "!less /usr/local/doc/mutt/manual.txt\n" "Show Mutt documentation"
  
@@ -63,6 +63,10 @@ diff -Nur mutt-1.3.27.orig/Muttrc mutt-1.3.27/Muttrc
 +# open-hook \\.gz$ "gzip -cd %f > %t"
 +# close-hook \\.gz$ "gzip -c %t > %f"
 +# append-hook \\.gz$ "gzip -c %t >> %f"
++
++# open-hook \\.bz2$ "bzip2 -cd %f > %t"
++# close-hook \\.bz2$ "bzip2 -c %t > %f"
++# append-hook \\.bz2$ "bzip2 -c %t >> %f"
 +
  # If Mutt is unable to determine your site's domain name correctly, you can
  # set the default here.
@@ -70,7 +74,7 @@ diff -Nur mutt-1.3.27.orig/Muttrc mutt-1.3.27/Muttrc
 diff -Nur mutt-1.3.27.orig/Muttrc.head mutt-1.3.27/Muttrc.head
 --- mutt-1.3.27.orig/Muttrc.head       Tue Jan  1 21:18:02 2002
 +++ mutt-1.3.27/Muttrc.head    Fri Feb  1 22:51:32 2002
-@@ -19,6 +19,11 @@
+@@ -19,6 +19,15 @@
  macro index   <f1> "!less /usr/local/doc/mutt/manual.txt\n" "Show Mutt documentation"
  macro pager   <f1> "!less /usr/local/doc/mutt/manual.txt\n" "Show Mutt documentation"
  
@@ -78,6 +82,10 @@ diff -Nur mutt-1.3.27.orig/Muttrc.head mutt-1.3.27/Muttrc.head
 +# open-hook \\.gz$ "gzip -cd %f > %t"
 +# close-hook \\.gz$ "gzip -c %t > %f"
 +# append-hook \\.gz$ "gzip -c %t >> %f"
++
++# open-hook \\.bz2$ "bzip2 -cd %f > %t"
++# close-hook \\.bz2$ "bzip2 -c %t > %f"
++# append-hook \\.bz2$ "bzip2 -c %t >> %f"
 +
  # If Mutt is unable to determine your site's domain name correctly, you can
  # set the default here.
@@ -85,7 +93,7 @@ diff -Nur mutt-1.3.27.orig/Muttrc.head mutt-1.3.27/Muttrc.head
 diff -Nur mutt-1.3.27.orig/Muttrc.head.in mutt-1.3.27/Muttrc.head.in
 --- mutt-1.3.27.orig/Muttrc.head.in    Mon Mar 20 11:25:49 2000
 +++ mutt-1.3.27/Muttrc.head.in Fri Feb  1 22:51:32 2002
-@@ -19,6 +19,11 @@
+@@ -19,6 +19,15 @@
  macro index   <f1> "!less @docdir@/manual.txt\n" "Show Mutt documentation"
  macro pager   <f1> "!less @docdir@/manual.txt\n" "Show Mutt documentation"
  
@@ -93,6 +101,10 @@ diff -Nur mutt-1.3.27.orig/Muttrc.head.in mutt-1.3.27/Muttrc.head.in
 +# open-hook \\.gz$ "gzip -cd %f > %t"
 +# close-hook \\.gz$ "gzip -c %t > %f"
 +# append-hook \\.gz$ "gzip -c %t >> %f"
++
++# open-hook \\.bz2$ "bzip2 -cd %f > %t"
++# close-hook \\.bz2$ "bzip2 -c %t > %f"
++# append-hook \\.bz2$ "bzip2 -c %t >> %f"
 +
  # If Mutt is unable to determine your site's domain name correctly, you can
  # set the default here.
@@ -694,186 +706,6 @@ diff -Nur mutt-1.3.27.orig/curs_main.c mutt-1.3.27/curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-diff -Nur mutt-1.3.27.orig/doc/manual-4.html mutt-1.3.27/doc/manual-4.html
---- mutt-1.3.27.orig/doc/manual-4.html Tue Jan  1 21:18:11 2002
-+++ mutt-1.3.27/doc/manual-4.html      Fri Feb  1 22:51:32 2002
-@@ -788,7 +788,176 @@
- macro pager \cb |urlview\n
- </PRE>
- </CODE></BLOCKQUOTE>
-+</P>
-+
-+<H2><A NAME="ss4.14">4.14 Compressed folders Support (OPTIONAL)</A>
-+</H2>
-+
-+
-+<P>If Mutt was compiled with compressed folders support (by running the
-+<EM>configure</EM> script with the <EM>--enable-compressed</EM> flag), Mutt
-+can open folders stored in an arbitrary format, provided that the user
-+has a script to convert from/to this format to one of the accepted.</P>
-+<P>The most common use is to open compressed archived folders e.g. with
-+gzip.</P>
-+<P>In addition, the user can provide a script that gets a folder in an
-+accepted format and appends its context to the folder in the
-+user-defined format, which may be faster than converting the entire
-+folder to the accepted format, appending to it and converting back to
-+the user-defined format.</P>
-+<P>There are three hooks defined (
-+<A HREF="#open-hook">open-hook</A>,
-+<A HREF="#close-hook">close-hook</A> and 
-+<A HREF="#append-hook">append-hook</A>) which define commands to uncompress and compress
-+a folder and to append messages to an existing compressed folder 
-+respectively.</P>
-+<P>For example:</P>
- <P>
-+<BLOCKQUOTE><CODE>
-+<PRE>
-+open-hook \\.gz$ "gzip -cd %f &gt; %t" 
-+close-hook \\.gz$ "gzip -c %t &gt; %f"
-+append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
-+</PRE>
-+</CODE></BLOCKQUOTE>
-+</P>
-+<P>You do not have to specify all of the commands. If you omit 
-+<A HREF="#append-hook">append-hook</A>, the folder will be open and
-+closed again each time you will add to it. If you omit 
-+<A HREF="#close-hook">close-hook</A> (or give empty command) , the
-+folder will be open in the  mode. If you specify 
-+<A HREF="#append-hook">append-hook</A> though you'll be able to append
-+to the folder.</P>
-+<P>Note that Mutt will only try to use hooks if the file is not in one of
-+the accepted formats. In particular, if the file is empty, mutt
-+supposes it is not compressed. This is important because it allows the
-+use of programs that do not have well defined extensions. Just use
-+&quot;.&quot; as a regexp. But this may be surprising if your
-+compressing script produces empty files. In this situation, unset 
-+<A HREF="manual-6.html#save_empty">$save_empty</A>, so that the compressed file
-+will be removed if you delete all of the messages.</P>
-+
-+<H3><A NAME="open-hook"></A> Open a compressed mailbox for reading</H3>
-+
-+<P>Usage: <CODE>open-hook</CODE> <EM>regexp</EM> &quot;<EM>command</EM>&quot;</P>
-+<P>The <EM>command</EM> is the command that can be used for opening the
-+folders whose names match <EM>regexp</EM>.</P>
-+<P>The <EM>command</EM> string is the printf-like format string, and it
-+should accept two parameters: %f, which is replaced with the
-+(compressed) folder name, and %t which is replaced with the
-+name of the temporary folder to which to write.</P>
-+<P>%f and %t can be repeated any number of times in the
-+command string, and all of the entries are replaced with the
-+appropriate folder name. In addition, %% is replaced by
-+%, as in printf, and any other %anything is left as is.</P>
-+<P>The <EM>command</EM> should <B>not</B> remove the original compressed file.
-+The <EM>command</EM> should return non-zero exit status if it fails, so
-+mutt knows something's wrong.</P>
-+<P>Example:</P>
-+<P>
-+<BLOCKQUOTE><CODE>
-+<PRE>
-+open-hook \\.gz$ "gzip -cd %f &gt; %t" 
-+</PRE>
-+</CODE></BLOCKQUOTE>
-+</P>
-+<P>If the <EM>command</EM> is empty, this operation is disabled for this file
-+type.</P>
-+
-+<H3><A NAME="close-hook"></A> Write a compressed mailbox</H3>
-+
-+<P>Usage: <CODE>close-hook</CODE> <EM>regexp</EM> &quot;<EM>command</EM>&quot;</P>
-+<P>This is used to close the folder that was open with the 
-+<A HREF="#open-hook">open-hook</A> command after some changes were made to it.</P>
-+<P>The <EM>command</EM> string is the command that can be used for closing the
-+folders whose names match <EM>regexp</EM>. It has the same format as in 
-+the 
-+<A HREF="#open-hook">open-hook</A> command. Temporary folder
-+in this case is the folder previously produced by the 
-+<A HREF="#open-hook">open-hook</A> command.</P>
-+<P>The <EM>command</EM> should <B>not</B> remove the decompressed file. The
-+<EM>command</EM> should return non-zero exit status if it fails, so mutt
-+knows something's wrong.</P>
-+<P>Example:</P>
-+<P>
-+<BLOCKQUOTE><CODE>
-+<PRE>
-+close-hook \\.gz$ "gzip -c %t &gt; %f"
-+</PRE>
-+</CODE></BLOCKQUOTE>
-+</P>
-+<P>If the <EM>command</EM> is empty, this operation is disabled for this file
-+type, and the file can only be open in the read-only mode.</P>
-+<P>
-+<A HREF="#close-hook">close-hook</A> is not called when you exit
-+from the folder if the folder was not changed.</P>
-+
-+<H3><A NAME="append-hook"></A> Append a message to a compressed mailbox</H3>
-+
-+<P>Usage: <CODE>append-hook</CODE> <EM>regexp</EM> &quot;<EM>command</EM>&quot;</P>
-+<P>This command is used for saving to an existing compressed folder.
-+The <EM>command</EM> is the command that can be used for appending to the
-+folders whose names match <EM>regexp</EM>. It has the same format as in 
-+the 
-+<A HREF="#open-hook">open-hook</A> command.
-+The temporary folder in this case contains the messages that are being
-+appended. </P>
-+<P>The <EM>command</EM> should <B>not</B> remove the decompressed file. The
-+<EM>command</EM> should return non-zero exit status if it fails, so mutt
-+knows something's wrong.</P>
-+<P>Example:</P>
-+<P>
-+<BLOCKQUOTE><CODE>
-+<PRE>
-+append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
-+</PRE>
-+</CODE></BLOCKQUOTE>
-+</P>
-+<P>When 
-+<A HREF="#append-hook">append-hook</A> is used, the folder is
-+not opened, which saves time, but this means that we can not find out
-+what the folder type is. Thus the default (
-+<A HREF="manual-6.html#mbox_type">$mbox_type</A>) type is always supposed (i.e.
-+this is the format used for the temporary folder).</P>
-+<P>If the file does not exist when you save to it, 
-+<A HREF="#close-hook">close-hook</A> is called, and not 
-+<A HREF="#append-hook">append-hook</A>. 
-+<A HREF="#append-hook">append-hook</A> is only
-+for appending to existing folders.</P>
-+<P>If the <EM>command</EM> is empty, this operation is disabled for this file
-+type. In this case, the folder will be open and closed again (using
-+<A HREF="#open-hook">open-hook</A> and 
-+<A HREF="#close-hook">close-hook</A>respectively) each time you will add to it.</P>
-+
-+<H3>Encrypted folders</H3>
-+
-+<P>The compressed folders support can also be used to handle encrypted
-+folders. If you want to encrypt a folder with PGP, you may want to use
-+the following hooks:</P>
-+<P>
-+<BLOCKQUOTE><CODE>
-+<PRE>
-+open-hook  \\.pgp$ "pgp -f &lt; %f &gt; %t"
-+close-hook \\.pgp$ "pgp -fe YourPgpUserIdOrKeyId &lt; %t &gt; %f"
-+</PRE>
-+</CODE></BLOCKQUOTE>
-+</P>
-+<P>Please note, that PGP does not support appending to an encrypted
-+folder, so there is no append-hook defined.</P>
-+<P>If you are using GnuPG instead of PGP, you may use the following hooks
-+instead:</P>
-+<P>
-+<BLOCKQUOTE><CODE>
-+<PRE>
-+open-hook  \\.gpg$ "gpg --decrypt &lt; %f &gt; %t"
-+close-hook \\.gpg$ "gpg --encrypt --recipient YourGpgUserIdOrKeyId &lt; %t &gt; %f"
-+</PRE>
-+</CODE></BLOCKQUOTE>
-+</P>
-+<P><B>Note:</B> the folder is temporary stored decrypted in the /tmp
-+directory, where it can be read by your system administrator. So think
-+about the security aspects of this.</P>
-+
- <HR>
- <A HREF="manual-5.html">Next</A>
- <A HREF="manual-3.html">Previous</A>
 diff -Nur mutt-1.3.27.orig/doc/manual-6.html mutt-1.3.27/doc/manual-6.html
 --- mutt-1.3.27.orig/doc/manual-6.html Tue Jan  1 21:18:13 2002
 +++ mutt-1.3.27/doc/manual-6.html      Fri Feb  1 22:51:32 2002
@@ -1893,3 +1725,64 @@ diff -Nur mutt-1.3.27.orig/status.c mutt-1.3.27/status.c
        if (Context && Context->path)
        {
        strfcpy (tmp, Context->path, sizeof (tmp));
+--- mutt-1.3.99/doc/manual-4.html~     Tue May 21 22:14:04 2002
++++ mutt-1.3.99/doc/manual-4.html      Tue May 21 22:15:56 2002
+@@ -815,7 +815,57 @@
+ </CODE></BLOCKQUOTE>
+ </P>
+-<HR>
++<H2><A NAME="ss4.14">4.14 Compressed folders Support (OPTIONAL)</A>
++</H2>
++
++
++<P>If Mutt was compiled with compressed folders support (by running the
++<EM>configure</EM> script with the <EM>--enable-compressed</EM> flag), Mutt
++can open folders stored in an arbitrary format, provided that the user
++has a script to convert from/to this format to one of the accepted.</P>
++<P>The most common use is to open compressed archived folders e.g. with
++gzip.</P>
++<P>In addition, the user can provide a script that gets a folder in an
++accepted format and appends its context to the folder in the
++user-defined format, which may be faster than converting the entire
++folder to the accepted format, appending to it and converting back to
++the user-defined format.</P>
++<P>There are three hooks defined (
++<A HREF="#open-hook">open-hook</A>,
++<A HREF="#close-hook">close-hook</A> and 
++<A HREF="#append-hook">append-hook</A>) which define commands to uncompress and compress
++a folder and to append messages to an existing compressed folder 
++respectively.</P>
++<P>For example:</P>
++<P>
++<BLOCKQUOTE><CODE>
++<PRE>
++open-hook \\.gz$ "gzip -cd %f &gt; %t" 
++close-hook \\.gz$ "gzip -c %t &gt; %f"
++append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
++</PRE>
++</CODE></BLOCKQUOTE>
++</P>
++<P>You do not have to specify all of the commands. If you omit 
++<A HREF="#append-hook">append-hook</A>, the folder will be open and
++closed again each time you will add to it. If you omit 
++<A HREF="#close-hook">close-hook</A> (or give empty command) , the
++folder will be open in the  mode. If you specify 
++<A HREF="#append-hook">append-hook</A> though you'll be able to append
++to the folder.</P>
++<P>Note that Mutt will only try to use hooks if the file is not in one of
++the accepted formats. In particular, if the file is empty, mutt
++supposes it is not compressed. This is important because it allows the
++use of programs that do not have well defined extensions. Just use
++&quot;.&quot; as a regexp. But this may be surprising if your
++compressing script produces empty files. In this situation, unset 
++<A HREF="manual-6.html#save_empty">$save_empty</A>, so that the compressed file
++will be removed if you delete all of the messages.</P>
++
++<H3><A NAME="open-hook"></A> Open a compressed mailbox for reading</H3>
++
++<P>Usage: <CODE>open-hook</CODE> <EM>regexp</EM> &quot;<EM>command</EM>&quot;</P><HR>
++
+ <A HREF="manual-5.html">Next</A>
+ <A HREF="manual-3.html">Previous</A>
+ <A HREF="manual.html#toc4">Contents</A>
This page took 0.081048 seconds and 4 git commands to generate.