]> git.pld-linux.org Git - packages/mutt.git/blobdiff - mutt-rr.compressed.patch
Added autoconf.patch, rel. 10
[packages/mutt.git] / mutt-rr.compressed.patch
index d61e69b47d740688b9f141460a564cfb8f816cef..11ef6b6a16ffb4adcb5033e444a74b5030008a05 100644 (file)
@@ -142,7 +142,7 @@ diff -udprP mutt-1.5.19.orig/compress.c mutt-1.5.19/compress.c
 +  ctx->realpath = ctx->path;
 +
 +  /* Uncompress to /tmp */
-+  mutt_mktemp (tmppath);
++  mutt_mktemp (tmppath, sizeof(tmppath));
 +  ctx->path = safe_malloc (strlen (tmppath) + 1);
 +  strcpy (ctx->path, tmppath);
 +}
@@ -596,32 +596,30 @@ diff -udprP mutt-1.5.19.orig/curs_main.c mutt-1.5.19/curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-diff -udprP mutt-1.5.19.orig/doc/Makefile.am mutt-1.5.19/doc/Makefile.am
---- mutt-1.5.19.orig/doc/Makefile.am   2009-01-05 21:20:53.000000000 +0200
-+++ mutt-1.5.19/doc/Makefile.am        2009-01-06 19:16:04.000000000 +0200
-@@ -31,7 +31,8 @@ EXTRA_DIST = dotlock.man             \
+--- mutt-1.5.20.b/doc/Makefile.am      2009-06-01 04:23:14.000000000 +0200
++++ mutt-1.5.20/doc/Makefile.am        2009-07-14 12:36:06.000000000 +0200
+@@ -31,7 +31,8 @@
  
HTML_DOCFILES = manual.html index.html intro.html gettingstarted.html \
CHUNKED_DOCFILES = index.html intro.html gettingstarted.html \
        configuration.html mimesupport.html advancedusage.html \
--      optionalfeatures.html tuning.html reference.html miscellany.html
-+      optionalfeatures.html tuning.html reference.html miscellany.html \
+-      optionalfeatures.html security.html tuning.html reference.html miscellany.html
++      optionalfeatures.html security.html tuning.html reference.html miscellany.html \
 +      compressed-folders.html
  
BUILT_DISTFILES = stamp-doc-xml stamp-doc-chunked manual.txt $(HTML_DOCFILES)
HTML_DOCFILES = manual.html $(CHUNKED_DOCFILES)
  
-diff -udprP mutt-1.5.19.orig/doc/Makefile.in mutt-1.5.19/doc/Makefile.in
---- mutt-1.5.19.orig/doc/Makefile.in   2009-01-05 21:24:14.000000000 +0200
-+++ mutt-1.5.19/doc/Makefile.in        2009-01-06 19:16:04.000000000 +0200
-@@ -234,7 +234,8 @@ EXTRA_DIST = dotlock.man           \
+--- mutt-1.5.20.b/doc/Makefile.in      2009-06-09 08:50:43.000000000 +0200
++++ mutt-1.5.20/doc/Makefile.in        2009-07-14 12:36:53.000000000 +0200
+@@ -235,7 +235,8 @@
  
HTML_DOCFILES = manual.html index.html intro.html gettingstarted.html \
CHUNKED_DOCFILES = index.html intro.html gettingstarted.html \
        configuration.html mimesupport.html advancedusage.html \
--      optionalfeatures.html tuning.html reference.html miscellany.html
-+      optionalfeatures.html tuning.html reference.html miscellany.html \
+-      optionalfeatures.html security.html tuning.html reference.html miscellany.html
++      optionalfeatures.html security.html tuning.html reference.html miscellany.html \
 +      compressed-folders.html
  
+ HTML_DOCFILES = manual.html $(CHUNKED_DOCFILES)
  BUILT_DISTFILES = stamp-doc-xml stamp-doc-chunked manual.txt $(HTML_DOCFILES)
- srcdir_DOCFILES = PGP-Notes.txt applying-patches.txt  \
 diff -udprP mutt-1.5.19.orig/doc/manual.xml.head mutt-1.5.19/doc/manual.xml.head
 --- mutt-1.5.19.orig/doc/manual.xml.head       2009-01-05 21:20:53.000000000 +0200
 +++ mutt-1.5.19/doc/manual.xml.head    2009-01-06 19:35:41.000000000 +0200
@@ -921,7 +919,7 @@ diff -udprP mutt-1.5.19.orig/doc/manual.xml.head mutt-1.5.19/doc/manual.xml.head
 +
 +<listitem>
 +<cmdsynopsis>
- <command><link linkend="auto-view">auto-view</link></command>
+ <command><link linkend="auto-view">auto_view</link></command>
  <arg choice="plain">
  <replaceable>mimetype</replaceable>
 @@ -7007,6 +7285,18 @@ The following are the commands understoo
@@ -1054,8 +1052,8 @@ diff -udprP mutt-1.5.19.orig/init.h mutt-1.5.19/init.h
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
+   { "group",          parse_group,            M_GROUP },
+   { "ungroup",                parse_ungroup,          M_UNGROUP },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
 diff -udprP mutt-1.5.19.orig/main.c mutt-1.5.19/main.c
 --- mutt-1.5.19.orig/main.c    2009-01-04 01:27:10.000000000 +0200
@@ -1264,9 +1262,9 @@ diff -udprP mutt-1.5.19.orig/mx.h mutt-1.5.19/mx.h
 --- mutt-1.5.19.orig/mx.h      2008-03-19 22:07:06.000000000 +0200
 +++ mutt-1.5.19/mx.h   2009-01-06 19:16:04.000000000 +0200
 @@ -40,6 +40,9 @@ enum
- #ifdef USE_POP
-   , M_POP
- #endif
+   M_MAILDIR,
+   M_IMAP,
+   M_POP
 +#ifdef USE_COMPRESSED
 +  , M_COMPRESSED
 +#endif
This page took 0.081471 seconds and 4 git commands to generate.