]> git.pld-linux.org Git - packages/musescore.git/blame - musescore.spec
- release 1
[packages/musescore.git] / musescore.spec
CommitLineData
623041ca 1#
6065f372 2
2a7d97dd 3%define min_qt_version 5.15.8
6065f372 4
623041ca
JK
5Summary: MuseScore - music notation software
6Summary(pl.UTF-8): MuseScore - oprogramowanie do notacji muzycznej
7Name: musescore
2a7d97dd 8Version: 4.0.2
d8139057 9Release: 1
623041ca
JK
10License: GPL v2
11Group: Applications
d2acd726 12Source0: https://github.com/musescore/MuseScore/archive/v%{version}.tar.gz
2a7d97dd
KM
13# Source0-md5: e1a5b52bd2cede8f6f332f0f6e315b73
14Patch0: no-crashpad.patch
d2acd726
KM
15Patch1: desktop.patch
16Patch2: use-qtmake-qt5.patch
17Patch3: set_as_stable.patch
2a7d97dd 18Patch4: %{name}-4.0.2-return.patch
623041ca 19URL: https://musescore.org/
6065f372
JK
20BuildRequires: Qt5Concurrent-devel >= %{min_qt_version}
21BuildRequires: Qt5Core-devel >= %{min_qt_version}
22BuildRequires: Qt5Designer-devel >= %{min_qt_version}
23BuildRequires: Qt5Gui-devel >= %{min_qt_version}
24BuildRequires: Qt5Help-devel >= %{min_qt_version}
25BuildRequires: Qt5Network-devel >= %{min_qt_version}
2a7d97dd 26BuildRequires: Qt5NetworkAuth-devel >= %{min_qt_version}
6065f372
JK
27BuildRequires: Qt5OpenGL-devel >= %{min_qt_version}
28BuildRequires: Qt5PrintSupport-devel >= %{min_qt_version}
29BuildRequires: Qt5Qml-devel >= %{min_qt_version}
44df59cf 30BuildRequires: Qt5Quick-controls2-devel
6065f372
JK
31BuildRequires: Qt5Quick-devel >= %{min_qt_version}
32BuildRequires: Qt5Sql-devel >= %{min_qt_version}
33BuildRequires: Qt5Svg-devel >= %{min_qt_version}
34BuildRequires: Qt5Test-devel >= %{min_qt_version}
35BuildRequires: Qt5UiTools-devel >= %{min_qt_version}
6065f372
JK
36BuildRequires: Qt5Widgets-devel >= %{min_qt_version}
37BuildRequires: Qt5Xml-devel >= %{min_qt_version}
38BuildRequires: Qt5XmlPatterns-devel >= %{min_qt_version}
623041ca 39BuildRequires: alsa-lib-devel
24e787ac 40BuildRequires: cmake >= 3.3.0
623041ca 41BuildRequires: doxygen
6065f372 42BuildRequires: freetype-devel >= 2.5.2
623041ca
JK
43BuildRequires: jack-audio-connection-kit-devel >= 0.98
44BuildRequires: lame-libs-devel
45BuildRequires: pkgconfig
46BuildRequires: portaudio-devel
47BuildRequires: pulseaudio-devel
48BuildRequires: qt5-assistant
49BuildRequires: qt5-build
50BuildRequires: qt5-linguist
d2acd726 51BuildRequires: qt5-qmake
623041ca 52BuildRequires: texlive-latex
2a7d97dd 53Requires: Qt5Quick-graphicaleffects
44df59cf 54Suggests: %{name}-fonts
623041ca
JK
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57%description
58MuseScore is an open source and free music notation software.
59
60Features:
61- WYSIWYG design, notes are entered on a "virtual notepaper"
62- TrueType font(s) for printing & display allows for high quality
63 scaling to all sizes
64- easy & fast note entry
65- many editing functions
66- MusicXML import/export
67- Midi (SMF) import/export
68- MuseData import
69- Midi input for note entry
70- integrated sequencer and software synthesizer to play the score
71- print or create pdf files
72
44df59cf
KM
73%description -l pl.UTF-8
74MuseScore to otwarte i darmowe oprogramowanie do notacji muzycznej.
75
76Cechy:
77- edytor WYSIWYG, nuty są wprowadzane na "wirtualny papier nutowy"
78- czcionki TrueType do drukowania i wyświetlania umożliwiają wysokiej
79 jakości skalowanie do wszystkich rozmiarów
80- łatwe i szybkie wprowadzanie nut
81- wiele funkcji edycyjnych
82- import/eksport MusicXML
83- import/eksport Midi (SMF).
84- import MuseData
85- wejście Midi do wprowadzania nut
86- zintegrowany sekwencer i syntezator programowy do odtwarzania
87 partytury
88- możliwość tworzenia i drukowania plików pdf
89
2a7d97dd
KM
90%package fonts
91Summary: MuseScore fonts
92Summary(pl.UTF-8): Czcionki MuseScore
93License: GPL-3.0-or-later WITH Font-exception-2.0 AND OFL-1.1
94Group: Fonts
95BuildArch: noarch
96
97%description fonts
98Additional fonts for use by the MuseScore music notation program.
99
44df59cf
KM
100%description fonts -l pl.UTF-8
101Dodatkowe czcionki do użytku w oprogramowaniu do notacji muzycznej
102MuseScore.
103
623041ca 104%prep
d2acd726 105%setup -q -n MuseScore-%{version}
24e787ac 106%patch0 -p1
c1dcfec6 107%patch1 -p1
d2acd726
KM
108%patch2 -p1
109%patch3 -p1
2a7d97dd 110%patch4 -p1
6065f372 111
44df59cf
KM
112# fix EOL encoding
113sed 's/\r$//' fonts/bravura/OFL-FAQ.txt > tmpfile
114touch -r fonts/bravura/OFL-FAQ.txt tmpfile
115mv -f tmpfile fonts/bravura/OFL-FAQ.txt
116
117sed 's/\r$//' thirdparty/rtf2html/README > tmpfile
118touch -r thirdparty/rtf2html/README tmpfile
119mv -f tmpfile thirdparty/rtf2html/README
120
121sed 's/\r$//' thirdparty/rtf2html/README.ru > tmpfile
122touch -r thirdparty/rtf2html/README.ru tmpfile
123mv -f tmpfile thirdparty/rtf2html/README.ru
124
623041ca
JK
125%build
126
127# note: 'build' directory is already there, for something else
128install -d build.release
129cd build.release
130
623041ca 131%cmake \
2a7d97dd
KM
132 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
133 -DMUSESCORE_BUILD_CONFIG=release \
623041ca
JK
134 -DMSCORE_INSTALL_SUFFIX="" \
135 -DMUSESCORE_LABEL="" \
2a7d97dd 136 -DBUILD_UNIT_TESTS=OFF \
623041ca 137 -DCMAKE_SKIP_RPATH="FALSE" \
6065f372
JK
138 -DDOWNLOAD_SOUNDFONT="OFF" \
139 -DUSE_SYSTEM_FREETYPE="ON" \
2a7d97dd 140 -DBUILD_CRASHPAD_CLIENT=OFF \
e86b8801
JK
141%ifarch x32
142 -DBUILD_WEBENGINE="OFF" \
143%endif
623041ca
JK
144 ..
145
146%{__make} lrelease
147%{__make}
148
149%install
150rm -rf $RPM_BUILD_ROOT
151
152cd build.release
153%{__make} install \
154 DESTDIR=$RPM_BUILD_ROOT
155
2a7d97dd
KM
156# don't package kddockwidgets. It should not be installed
157rm $RPM_BUILD_ROOT%{_libdir}/*.a
158rm -r $RPM_BUILD_ROOT%{_includedir}/kddockwidgets
159rm -r $RPM_BUILD_ROOT%{_libdir}/cmake/KDDockWidgets
160
161# Remove opus devel files, they are provided by system
162rm -r $RPM_BUILD_ROOT%{_includedir}/opus
163
164rm $RPM_BUILD_ROOT%{_mandir}/man1/musescore.1.gz
165echo ".so mscore.1" > $RPM_BUILD_ROOT%{_mandir}/man1/musescore.1
166
44df59cf 167cd ..
2a7d97dd 168# install fonts
44df59cf
KM
169install -d $RPM_BUILD_ROOT%{_datadir}/fonts/{OTF,TTF}
170install -p fonts/*.ttf $RPM_BUILD_ROOT%{_datadir}/fonts/TTF
171install -p fonts/*/*.ttf $RPM_BUILD_ROOT%{_datadir}/fonts/TTF
172install -p fonts/bravura/BravuraText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
173install -p fonts/campania/Campania.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
174install -p fonts/edwin/*.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
175install -p fonts/gootville/GootvilleText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
176install -p fonts/leland/LelandText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
177install -p fonts/musejazz/MuseJazzText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
178install -p fonts/petaluma/PetalumaText.otf $RPM_BUILD_ROOT%{_datadir}/fonts/OTF
2a7d97dd
KM
179
180# unique names for font docs
181mv fonts/edwin/README.md fonts/edwin/README.md.edwin
182mv fonts/edwin/LICENSE.txt fonts/edwin/LICENSE.txt.edwin
183mv fonts/leland/README.md fonts/leland/README.md.leland
184mv fonts/leland/LICENSE.txt fonts/leland/LICENSE.txt.leland
623041ca 185
44df59cf
KM
186# collect doc files
187mkdir tmp_doc
188install -p thirdparty/beatroot/COPYING tmp_doc/COPYING.beatroot
189install -p thirdparty/beatroot/README.txt tmp_doc/README.txt.beatroot
190install -p thirdparty/dtl/COPYING tmp_doc/COPYING.BSD.dtl
191install -p thirdparty/freetype/README tmp_doc/README.freetype
192install -p thirdparty/intervaltree/README tmp_doc/README.intervaltree
193install -p thirdparty/rtf2html/ChangeLog tmp_doc/ChangeLog.rtf2html
194install -p thirdparty/rtf2html/COPYING.LESSER tmp_doc/COPYING.LESSER.rtf2html
195install -p thirdparty/rtf2html/README tmp_doc/README.rtf2html
196install -p thirdparty/rtf2html/README.mscore tmp_doc/README.mscore.rtf2html
197install -p thirdparty/rtf2html/README.ru tmp_doc/README.ru.rtf2html
198install -p thirdparty/singleapp/LGPL_EXCEPTION.txt tmp_doc/LGPL_EXCEPTION.txt.singleapp
199install -p thirdparty/singleapp/LICENSE.GPL3 tmp_doc/LICENSE.GPL3.singleapp
200install -p thirdparty/singleapp/LICENSE.LGPL tmp_doc/LICENSE.LGPL.singleapp
201install -p thirdparty/singleapp/README.TXT tmp_doc/README.TXT.singleapp
202install -p tools/bww2mxml/COPYING tmp_doc/COPYING.bww2mxml
203install -p tools/bww2mxml/README tmp_doc/README.bww2mxml
204install -p share/sound/README.md tmp_doc/README.md.sound
205install -p share/instruments/README.md tmp_doc/README.md.instruments
206install -p share/wallpapers/COPYRIGHT tmp_doc/COPYING.wallpaper
207
623041ca
JK
208%post
209%update_desktop_database
210%update_icon_cache hicolor
211%update_mime_database
212
213%postun
214%update_desktop_database
215%update_icon_cache hicolor
216%update_mime_database
217
44df59cf
KM
218%post fonts
219fontpostinst OTF
220fontpostinst TTF
221
222%postun fonts
223fontpostinst OTF
224fontpostinst TTF
225
623041ca
JK
226%clean
227rm -rf $RPM_BUILD_ROOT
228
229%files
230%defattr(644,root,root,755)
44df59cf 231%doc README.md Compatibility LICENSE.GPL tmp_doc/*
623041ca 232%attr(755,root,root) %{_bindir}/mscore
2a7d97dd
KM
233%{_datadir}/mscore-4.0
234%{_desktopdir}/org.musescore.MuseScore.desktop
623041ca
JK
235%{_iconsdir}/*/*/apps/*
236%{_iconsdir}/*/*/mimetypes/*
237%{_mandir}/man1/mscore.1*
238%{_mandir}/man1/musescore.1*
239%{_datadir}/mime/packages/musescore.xml
c1dcfec6 240%{_datadir}/metainfo/org.musescore.MuseScore.appdata.xml
44df59cf
KM
241
242%files fonts
243%defattr(644,root,root,755)
244%{_datadir}/fonts/TTF/*.ttf
245%{_datadir}/fonts/OTF/*.otf
246%doc fonts/README.md
247%doc fonts/bravura/bravura-text.md
248%doc fonts/bravura/OFL-FAQ.txt
249%doc fonts/bravura/OFL.txt
250%doc fonts/gootville/readme.txt fonts/campania/LICENSE
251# see section 'unique names for font docs' above
252%doc fonts/edwin/README.md.edwin fonts/edwin/LICENSE.txt.edwin
253%doc fonts/leland/README.md.leland fonts/leland/LICENSE.txt.leland
This page took 0.147592 seconds and 4 git commands to generate.