]> git.pld-linux.org Git - packages/mplayer.git/blobdiff - mplayer.spec
- release 6 (libvpx 1.14)
[packages/mplayer.git] / mplayer.spec
index 77bd130a355cb9e2ab79a10fe14062467580bf05..54753c8a15e1da23da4250d4216168a96903eeeb 100644 (file)
@@ -21,6 +21,7 @@
 %bcond_without joystick        # joystick support
 %bcond_without lirc            # lirc support
 %bcond_without live            # LIVE555 Streaming Media support
+%bcond_without live_cpp20      # LIVE555 library with C++20 atomic_flag
 %bcond_without mencoder        # mencoder (a/v encoder) compilation
 %bcond_without nemesi          # NeMeSi Streaming Media support
 %bcond_without osd             # osd menu support
 %undefine      with_crystalhd
 %endif
 
-%if %{_lib} != "lib"
+%if "%{_lib}" != "lib"
 %define                binsuf  %(lib=%{_lib} ; echo ${lib#lib})
 %else
 %ifarch        %{ix86} ppc sparc sparcv9 s390
 %endif
 %endif
 
+%if 0
 # date from directory inside of tarball (like mplayer-export-2014-04-29)
-%define        snap    2017-10-22
+%define        snap    2018-05-22
 %define        ssnap   %(echo %{snap} | tr -d -)
-%define        rel     1
+%endif
 Summary:       MPlayer - THE Movie Player for UN*X
 Summary(de.UTF-8):     MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
 Summary(es.UTF-8):     Otro reproductor de películas
@@ -121,8 +123,8 @@ Summary(ko.UTF-8):  리눅스용 미디어플레이어
 Summary(pl.UTF-8):     Odtwarzacz filmów dla systemów uniksowych
 Summary(pt_BR.UTF-8):  Reprodutor de filmes
 Name:          mplayer
-Version:       1.3
-Release:       1.%{ssnap}.%{rel}
+Version:       1.5
+Release:       6
 # DO NOT increase epoch unless it's really neccessary!
 # especially such changes like pre7->pre7try2, increase Release instead!
 # PS: $ rpmvercmp pre7try2 pre7
@@ -130,16 +132,20 @@ Release:  1.%{ssnap}.%{rel}
 Epoch:         3
 License:       GPL
 Group:         Applications/Multimedia
-# Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
-Source0:       ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
-# Source0-md5: 22761a792a834f82a87ff7f0a4c7a154
+# Source0:     http://mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
+Source0:       http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
+# Source0-md5: 0419b64db24b6db0943dbc6afece7c44
+%if 0
 Source1:       http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
-# Source1-md5: 2007a7aa18484b5531f2dc6302023dbc
-Source3:       ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
+# Source1-md5: b1b71cc56b15da49cee1ede9a7b8134e
+%endif
+Source2:       http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
+# Source2-md5: 1ecd31d17b51f16332b1fcc7da36b312
+Source3:       http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
 # Source3-md5: 7b47904a925cf58ea546ca15f3df160c
+Source4:       http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-7.tar.bz2
+# Source4-md5: 956a9d9ea51970e057f0deb7b2e25889
 Source5:       g%{name}.desktop
-Source6:       ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
-# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
 Source7:       %{name}.png
 Source8:       %{name}.desktop
 
@@ -148,11 +154,11 @@ Patch10:  %{name}-ldflags.patch
 Patch11:       %{name}-altivec.patch
 Patch12:       %{name}-check-byteswap.patch
 Patch13:       %{name}-visibility-hidden-fix.patch
-
+Patch14:       cflags.patch
 Patch15:       %{name}-live555-async.patch
-
+Patch16:       %{name}-live555-config.patch
 Patch17:       %{name}-gsm.patch
-Patch18:       %{name}-openjpeg.patch
+
 Patch19:       %{name}-shared.patch
 Patch20:       %{name}-vstream.patch
 
@@ -166,6 +172,8 @@ Patch31:    %{name}-350.patch
 # update, hard to fix right now because of gnome bug 579430:
 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
 #Patch32:      %{name}-gnome-screensaver.patch
+Patch33:       binutils2.41.patch
+Patch34:       po-charset.patch
 
 Patch101:      %{name}-link.patch
 
@@ -180,13 +188,14 @@ BuildRequires:    OpenGL-GLX-devel
 BuildRequires: a52dec-libs-devel
 %{?with_aalib:BuildRequires:   aalib-devel}
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
+BuildRequires: aom-devel
 %{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: binutils >= 2.10.1
+BuildRequires: binutils >= 1:2.10.1
 %{?with_ssse3:BuildRequires:   binutils >= 3:2.16.92}
 BuildRequires: bzip2-devel
 #%{?with_cdparanoia:BuildRequires:     cdparanoia-III-devel}
+BuildRequires: dav1d-devel
 %{?with_gnomess:BuildRequires: dbus-glib-devel}
-BuildRequires: dirac-devel
 %{?with_doc:BuildRequires:     docbook-dtd45-xml}
 %{?with_doc:BuildRequires:     docbook-style-xsl}
 %{?with_dxr2:BuildRequires:    dxr2-driver-devel}
@@ -195,7 +204,7 @@ BuildRequires:      dirac-devel
 %{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: faac-devel
 %{?with_faad:BuildRequires:    faad2-devel >= 2.0}
-%{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.4.9-4.20081024.3}
+%{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 5.1}
 BuildRequires: fontconfig-devel >= 1:2.4.2
 BuildRequires: freetype-devel >= 1:2.2.1
 BuildRequires: fribidi-devel
@@ -240,6 +249,7 @@ BuildRequires:      libvorbis-devel
 BuildRequires: libvpx-devel
 # build >= 118
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3}
+BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libxslt-progs
 # with v4l2 headers
 BuildRequires: linux-libc-headers >= 7:2.6.22
@@ -249,13 +259,12 @@ BuildRequires:    linux-libc-headers >= 7:2.6.22
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 %{?with_amr:BuildRequires:     opencore-amr-devel}
-%{?with_openjpeg:BuildRequires:        openjpeg2-devel}
+%{?with_openjpeg:BuildRequires:        openjpeg2-devel >= 2.1.0}
 BuildRequires: opus-devel
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel >= 0.9}
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.527
-BuildRequires: schroedinger-devel
 BuildRequires: speex-devel >= 1.1
 %{?with_svga:BuildRequires:    svgalib-devel}
 BuildRequires: tar >= 1:1.22
@@ -280,10 +289,9 @@ BuildRequires:     yasm
 %endif
 BuildRequires: zlib-devel
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      OpenGL
+%{?with_openjpeg:Requires:     openjpeg2 >= 2.1.0}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep   libGL.so.1 libGLU.so.1
 %define                specflags_ia32  -fomit-frame-pointer
 %if %{with altivec}
 %define                specflags_ppc   -maltivec
@@ -372,7 +380,7 @@ Summary:    Configuration files and documentation for MPlayer
 Summary(pl.UTF-8):     Pliki konfiguracyjne i dokumentacja dla MPlayera
 Group:         Applications/Multimedia
 Suggests:      unrar
-Obsoletes:     mplayer-vidix
+Obsoletes:     mplayer-vidix < 1.0-3.rc1.2
 
 %description common
 Configuration files, man page and HTML documentation for MPlayer.
@@ -405,7 +413,11 @@ package.
 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
 
 %prep
-%setup -q -n %{name}-export-%{snap} -a1 -a3 -a6
+%if 0%{?snap:1}
+%setup -q -n %{name}-export-%{snap} -a1 -a2 -a3 -a4
+%else
+%setup -q -n MPlayer-%{version} -a2 -a3 -a4
+%endif
 cp -f etc/codecs.conf etc/codecs.win32.conf
 
 # build (configure / Makefile) related:
@@ -413,11 +425,11 @@ cp -f etc/codecs.conf etc/codecs.win32.conf
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-
+%patch14 -p1
 %patch15 -p1
-
+%patch16 -p1
 %patch17 -p1
-%patch18 -p1
+
 %{?with_shared:%patch19 -p1}
 %patch20 -p1
 
@@ -429,6 +441,8 @@ cp -f etc/codecs.conf etc/codecs.win32.conf
 %patch30 -p0
 %patch31 -p1
 #%{with_gnomess:%patch32 -p1}
+%patch33 -p1 -d ffmpeg
+%patch34 -p1
 
 %patch101 -p1
 
@@ -461,9 +475,15 @@ CONFIGADD
 %{__rm} -rf ffmpeg
 %endif
 
+%if %{with live_cpp20}
+%{__sed} -i -e 's/-std=c++98/-std=c++20/' configure
+%else
+%{__sed} -i -e 's/-std=c++98/& -DNO_STD_LIB/' configure
+%endif
+
 %build
 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
-CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
+CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb: -I%{_includedir}/directfb} -DHAVE_GSM_H=1"
 
 # NOTE:
 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
@@ -536,7 +556,7 @@ build() {
        %{__disable vorbis libvorbis} \
        %{__enable_disable lirc} \
        --disable-lircc \
-       %{__disable live} \
+       %{__enable_disable live} \
        %{__disable mad} \
        %{__disable mencoder} \
        %{__enable osd menu} \
This page took 0.138093 seconds and 4 git commands to generate.