]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- release 6 (libvpx 1.14)
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
7ee3dc06 24%bcond_without live_cpp20 # LIVE555 library with C++20 atomic_flag
62ba71a7 25%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 26%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
27%bcond_without osd # osd menu support
28%bcond_without rtmp # RTMPDump Streaming Media support
29%bcond_with shared # experimental libmplayer.so support
30%bcond_without smb # Samba (SMB) input support
10a6d1a6 31%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
32# - codecs:
33%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 34%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
35%bcond_without crystalhd # CrystalHD support
36%bcond_without faad # FAAD2 (AAC) support
37%bcond_without gif # GIF support
63bba7db
JB
38%bcond_without ladspa # LADSPA plugin support
39%bcond_without libdts # libdts support
40%bcond_without libdv # libdv en/decoding support
63bba7db
JB
41%bcond_without lzo # LZO support (requires lzo 2.x)
42%bcond_without mad # mad (audio MPEG) support
43%bcond_without mpg123 # libmpg123 MP3 decoding support
44d571a0 44%bcond_with musepack # libmpcdec support (deprecated in favour of libavcodec)
63bba7db 45%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
46%bcond_without quicktime # binary quicktime dll support
47%bcond_without real # Real* 8/9 codecs support
63bba7db 48%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
44d571a0 49%bcond_with tremor # use tremor instead of libvorbis
62ba71a7
JB
50%bcond_without theora # Ogg Theora video support
51%bcond_without win32 # Win32 codecs support
52%bcond_without x264 # x264 support
53%bcond_with xmms # XMMS inputplugin support
63bba7db 54%bcond_without xvid # XviD codec
62ba71a7 55%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 56%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
57# - video output:
58%bcond_without aalib # aalib video output
59%bcond_without caca # libcaca video output
60%bcond_with directfb # DirectFB video output
10a6d1a6
JB
61%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
62%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
63%bcond_with ggi # GGI video output
64%bcond_without sdl # SDL video output
65%bcond_with svga # svgalib video output
66%bcond_without vdpau # VDPAU acceleration
67%bcond_without vidix # VIDIX video drivers
63bba7db 68%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
69%bcond_with gnomess # controling gnome screensaver [patch not updated]
70# - audio output:
71%bcond_without alsa # ALSA audio output
72%bcond_with arts # aRts audio output
73%bcond_with esd # EsounD sound support
74%bcond_without jack # JACKD support
75%bcond_with nas # NAS audio output
76%bcond_without pulseaudio # pulseaudio output
77%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 78
9accd5e5 79%if %{with alsa}
80%undefine with_select
81%endif
d1f72115 82%if %{without vorbis}
44d571a0 83%undefine with_tremor
d1f72115 84%endif
85
94cb018b
JB
86%ifnarch %{ix86}
87%undefine with_win32
7a82c266 88%undefine with_quicktime
1087e996 89%undefine with_vidix
94cb018b 90%endif
38c74592 91%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
92%undefine with_runtime
93%endif
ca278bdf
ER
94%ifnarch %{ix86} %{x8664}
95%undefine with_vdpau
96%endif
3d17ae18
ER
97%ifnarch ppc
98%undefine with_altivec
99%endif
810f3f3d
ER
100%ifnarch i686 pentium4 athlon %{x8664}
101%undefine with_crystalhd
102%endif
3d17ae18 103
b4c9d1de 104%if "%{_lib}" != "lib"
40ce9ce9 105%define binsuf %(lib=%{_lib} ; echo ${lib#lib})
1a8df7bd 106%else
40ce9ce9 107%ifarch %{ix86} ppc sparc sparcv9 s390
e2b12b5a 108%define binsuf 32
40ce9ce9
JB
109%else
110%define binsuf %{nil}
111%endif
1a8df7bd 112%endif
113
b1e29978 114%if 0
0cd1ec52 115# date from directory inside of tarball (like mplayer-export-2014-04-29)
b13d3bd9 116%define snap 2018-05-22
0cd1ec52 117%define ssnap %(echo %{snap} | tr -d -)
b1e29978 118%endif
906bf13b 119Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
120Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
121Summary(es.UTF-8): Otro reproductor de películas
122Summary(ko.UTF-8): 리눅스용 미디어플레이어
123Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
124Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 125Name: mplayer
24bfe2fa 126Version: 1.5
ef3e0358 127Release: 6
1f85fd72
ER
128# DO NOT increase epoch unless it's really neccessary!
129# especially such changes like pre7->pre7try2, increase Release instead!
130# PS: $ rpmvercmp pre7try2 pre7
131# pre7try2 > pre7
59476b48 132Epoch: 3
bc426a7f 133License: GPL
906bf13b 134Group: Applications/Multimedia
b1e29978
JB
135# Source0: http://mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
136Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
24bfe2fa 137# Source0-md5: 0419b64db24b6db0943dbc6afece7c44
b1e29978 138%if 0
0cd1ec52 139Source1: http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
dea0f5a7 140# Source1-md5: b1b71cc56b15da49cee1ede9a7b8134e
b1e29978
JB
141%endif
142Source2: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
143# Source2-md5: 1ecd31d17b51f16332b1fcc7da36b312
144Source3: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 145# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
b1e29978
JB
146Source4: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-7.tar.bz2
147# Source4-md5: 956a9d9ea51970e057f0deb7b2e25889
e601cd91 148Source5: g%{name}.desktop
11b89ef7 149Source7: %{name}.png
24481cd2 150Source8: %{name}.desktop
79907b07 151
152# build (configure / Makefile) related:
153Patch10: %{name}-ldflags.patch
154Patch11: %{name}-altivec.patch
155Patch12: %{name}-check-byteswap.patch
c2bf8f19 156Patch13: %{name}-visibility-hidden-fix.patch
2bb2f3d6 157Patch14: cflags.patch
1ee1ef52 158Patch15: %{name}-live555-async.patch
24bfe2fa 159Patch16: %{name}-live555-config.patch
63bba7db 160Patch17: %{name}-gsm.patch
7eb1aa3e 161
63bba7db 162Patch19: %{name}-shared.patch
990687b2 163Patch20: %{name}-vstream.patch
79907b07 164
165# codecs, outputs, demuxers:
990687b2
JB
166Patch21: %{name}-auto-expand.patch
167Patch22: %{name}-release_directfb.patch
79907b07 168
169# goodies:
170Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 171Patch31: %{name}-350.patch
d1f72115 172# update, hard to fix right now because of gnome bug 579430:
173# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 174#Patch32: %{name}-gnome-screensaver.patch
d03dba0e 175Patch33: binutils2.41.patch
0859151b 176Patch34: po-charset.patch
79907b07 177
b252aa8a 178Patch101: %{name}-link.patch
79907b07 179
c5b97685 180URL: http://www.mplayerhq.hu/
44d571a0
JB
181%{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
182BuildRequires: EGL-devel
aeb67db6 183BuildRequires: OpenAL-devel
44d571a0 184BuildRequires: OpenGL-GLX-devel
11421384 185%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
44d571a0
JB
186# checked, but seems actually not used
187#%{?with_sdl:BuildRequires: SDL_image-devel}
63bba7db 188BuildRequires: a52dec-libs-devel
dd6c659c
JB
189%{?with_aalib:BuildRequires: aalib-devel}
190%{?with_alsa:BuildRequires: alsa-lib-devel}
24bfe2fa 191BuildRequires: aom-devel
dd6c659c 192%{?with_arts:BuildRequires: artsc-devel}
92e0d154 193BuildRequires: binutils >= 1:2.10.1
841cb995 194%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 195BuildRequires: bzip2-devel
364125e7 196#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
24bfe2fa 197BuildRequires: dav1d-devel
df52db46 198%{?with_gnomess:BuildRequires: dbus-glib-devel}
d6da6cb0 199%{?with_doc:BuildRequires: docbook-dtd45-xml}
5dcdda0f 200%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 201%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 202%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
203%{?with_enca:BuildRequires: enca-devel}
204%{?with_esd:BuildRequires: esound-devel}
30e3739f 205BuildRequires: faac-devel
3c3fdfcc 206%{?with_faad:BuildRequires: faad2-devel >= 2.0}
24bfe2fa 207%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 5.1}
63bba7db 208BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 209BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 210BuildRequires: fribidi-devel
3d17ae18 211%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 212%{?with_gif:BuildRequires: giflib-devel}
44d571a0
JB
213%{?with_gui:BuildRequires: glib2-devel >= 1:2.6.0}
214BuildRequires: gnutls-devel
215%{?with_gui:BuildRequires: gtk+2-devel >= 2:2.4.0}
d336e259 216%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 217%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 218BuildRequires: lame-libs-devel
6bd88460 219BuildRequires: libass-devel >= 0.9.10
c3a1256a 220%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 221%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 222%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
223%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
224%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 225%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 226%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 227#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 228%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 229%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 230%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
231%{?with_ggi:BuildRequires: libggiwmh-devel}
232BuildRequires: libgsm-devel
af480c75 233BuildRequires: libjpeg-devel
dd6c659c 234%{?with_mad:BuildRequires: libmad-devel}
c521a17c 235BuildRequires: libmng-devel
63bba7db
JB
236%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
237%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
238%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 239%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 240BuildRequires: libnut-devel
af480c75 241BuildRequires: libpng-devel
63bba7db 242%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 243%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 244%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 245%{?with_vdpau:BuildRequires: libvdpau-devel}
44d571a0
JB
246%if %{with vorbis} && %{without tremor}
247BuildRequires: libvorbis-devel
248%endif
0431b837 249BuildRequires: libvpx-devel
44d571a0 250# build >= 118
bbab8eb7 251%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
24bfe2fa 252BuildRequires: libxml2-devel >= 2.0
ceb01d0e 253BuildRequires: libxslt-progs
44d571a0
JB
254# with v4l2 headers
255BuildRequires: linux-libc-headers >= 7:2.6.22
dd6c659c 256%{?with_lirc:BuildRequires: lirc-devel}
1ee1ef52 257%{?with_live:BuildRequires: live-devel >= 2:2011.01.10}
841cb995 258%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 259%{?with_nas:BuildRequires: nas-devel}
b458005d 260BuildRequires: ncurses-devel
b69a6f83 261%{?with_amr:BuildRequires: opencore-amr-devel}
4362ee26 262%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
44d571a0 263BuildRequires: opus-devel
e9d22b19 264BuildRequires: pkgconfig
86bc294f 265%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 266BuildRequires: rpm >= 4.4.9-56
9accd5e5 267BuildRequires: rpmbuild(macros) >= 1.527
aeb67db6 268BuildRequires: speex-devel >= 1.1
dd6c659c 269%{?with_svga:BuildRequires: svgalib-devel}
3af20979 270BuildRequires: tar >= 1:1.22
44d571a0 271%{?with_tremor:BuildRequires: tremor-devel}
c521a17c 272BuildRequires: twolame-devel
3af20979 273%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 274%{?with_vstream:BuildRequires: vstream-client-devel}
44d571a0 275BuildRequires: webrtc-libilbc-devel
c521a17c 276%{?with_xmms:BuildRequires: xmms-devel}
627a7a97 277BuildRequires: xorg-lib-libX11-devel
c521a17c 278BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
279BuildRequires: xorg-lib-libXext-devel
280BuildRequires: xorg-lib-libXinerama-devel
281BuildRequires: xorg-lib-libXv-devel
282BuildRequires: xorg-lib-libXvMC-devel
283BuildRequires: xorg-lib-libXxf86dga-devel
284BuildRequires: xorg-lib-libXxf86vm-devel
b57c3c6c
ER
285%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
286BuildRequires: xz
287%ifarch %{ix86} %{x8664}
288BuildRequires: yasm
289%endif
290BuildRequires: zlib-devel
4d75c49f 291Requires: %{name}-common = %{epoch}:%{version}-%{release}
4362ee26 292%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
0f2a502d 293BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 294
bb27cfbd 295%define specflags_ia32 -fomit-frame-pointer
198487b4 296%if %{with altivec}
adfd0023 297%define specflags_ppc -maltivec
20a66bdb 298%endif
2adea73e
AM
299
300%description
c902f7c6 301Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
302AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 303MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
304MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 305devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
306optionally with SHM extension, X11 using overlays with the Xvideo
307extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
308Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 309
8b146837 310If you want to use win32 codecs install w32codec package.
4228a246 311
e011d408 312%description -l de.UTF-8
deba608c 313MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
314Kennzeichnend ist die herausragende Format- und
e011d408 315Plattform-Kompatibilität.
deba608c 316
e011d408
JR
317Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
318plattformexklusive, wodurch etwa Windows Media auch außerhalb von
319Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
320Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 321ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
322Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
323installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 324
e011d408 325%description -l es.UTF-8
c902f7c6 326Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
327MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
328(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
329de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
330Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
331G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
332overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 333G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
334v1.1.7 etc.
33c4efab 335
8b146837 336Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 337
e011d408
JR
338%description -l ko.UTF-8
339MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
340파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
341MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
342Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
343(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
344수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
345크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
346있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
347부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 348
e011d408
JR
349%description -l pl.UTF-8
350Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 351RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
352(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
353Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 354Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 355rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 356G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 357
e011d408 358Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 359
e011d408
JR
360%description -l pt_BR.UTF-8
361MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
362áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 363escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
364
11421384
ER
365%package -n gmplayer
366Summary: MPlayer with GTK+ GUI interface
eeb91a66 367Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 368Group: X11/Applications/Multimedia
11421384 369Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 370Requires: %{name}-skin
11421384
ER
371
372%description -n gmplayer
373MPlayer with GUI GTK+ interface.
374
e011d408 375%description -n gmplayer -l pl.UTF-8
906bf13b
JB
376MPlayer z graficznym interfejsem GTK+.
377
11421384 378%package common
906bf13b 379Summary: Configuration files and documentation for MPlayer
eeb91a66 380Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 381Group: Applications/Multimedia
c521a17c 382Suggests: unrar
c7132fcf 383Obsoletes: mplayer-vidix < 1.0-3.rc1.2
11421384
ER
384
385%description common
906bf13b
JB
386Configuration files, man page and HTML documentation for MPlayer.
387
e011d408 388%description common -l pl.UTF-8
906bf13b 389Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 390
dc3c7d77 391%package doc
63bba7db
JB
392Summary: HTML documentation for MPlayer
393Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
394Group: Documentation
395
396%description doc
63bba7db
JB
397HTML Documentation for MPlayer.
398
399%description doc -l pl.UTF-8
400Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 401
11421384 402%package -n mencoder
906bf13b 403Summary: MEncoder - a movie encoder for Linux
eeb91a66 404Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
405Group: Applications/Multimedia
406Requires: %{name}-common = %{epoch}:%{version}-%{release}
407
408%description -n mencoder
906bf13b
JB
409MEncoder is a movie encoder for Linux and is a part of the MPlayer
410package.
411
e011d408
JR
412%description -n mencoder -l pl.UTF-8
413MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 414
2adea73e 415%prep
b1e29978
JB
416%if 0%{?snap:1}
417%setup -q -n %{name}-export-%{snap} -a1 -a2 -a3 -a4
418%else
419%setup -q -n MPlayer-%{version} -a2 -a3 -a4
420%endif
833dbe20 421cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 422
423# build (configure / Makefile) related:
424%patch10 -p1
425%patch11 -p1
426%patch12 -p1
c2bf8f19 427%patch13 -p1
2bb2f3d6 428%patch14 -p1
e2b12b5a 429%patch15 -p1
24bfe2fa 430%patch16 -p1
63bba7db 431%patch17 -p1
7eb1aa3e 432
63bba7db 433%{?with_shared:%patch19 -p1}
990687b2 434%patch20 -p1
79907b07 435
436# codecs, outputs, demuxers:
79907b07 437%patch21 -p1
990687b2 438%patch22 -p1
79907b07 439
440# goodies:
441%patch30 -p0
2833f81f 442%patch31 -p1
443#%{with_gnomess:%patch32 -p1}
d03dba0e 444%patch33 -p1 -d ffmpeg
0859151b 445%patch34 -p1
59ba0205 446
b252aa8a
PS
447%patch101 -p1
448
53f97285 449cat etc/example.conf > etc/mplayer.conf
c521a17c 450cat <<'CONFIGADD' >> etc/mplayer.conf
451
d1f72115 452######################
8b2ed1fb 453# PLD Linux Defaults #
d1f72115 454######################
2833f81f 455[default]
456
457# alternate solution for CP1250-encoded subtitles
458fontconfig = yes
459subcp = cp1250
460
461# ...or if you prefer native bitmap fonts shipped with mplayer
462#fontconfig = no
463#subcp = iso-8859-1
464
465# Standard location
466unrarexec = "%{_bindir}/unrar"
467
993f72f1
ER
468# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
469joystick=no
470
c521a17c 471CONFIGADD
d1732085 472
1f8d8779
ER
473%if %{with system_ffmpeg}
474# using external ffmpeg, but mplayer adds these to includepath
0cd1ec52 475%{__rm} -rf ffmpeg
1f8d8779
ER
476%endif
477
7ee3dc06
JB
478%if %{with live_cpp20}
479%{__sed} -i -e 's/-std=c++98/-std=c++20/' configure
480%else
481%{__sed} -i -e 's/-std=c++98/& -DNO_STD_LIB/' configure
482%endif
483
2adea73e 484%build
5dcdda0f 485CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
24bfe2fa 486CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb: -I%{_includedir}/directfb} -DHAVE_GSM_H=1"
53f97285 487
63bba7db
JB
488# NOTE:
489# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
490# - toolame is obsolete predecessor of twolame
44d571a0 491# - libcdio-paranoia is preferred over cdparanoia-III libs
11421384 492build() {
c521a17c 493 set -x
53f97285 494
11421384
ER
495 ./configure \
496 %{?debug:--enable-debug=3} \
dd6c659c 497 --prefix=%{_prefix} \
63bba7db 498 --codecsdir=%{_libdir}/codecs \
dd6c659c 499 --confdir=%{_sysconfdir}/mplayer \
53f97285 500 --cc="%{__cc}" \
501 --extra-cflags="$CFLAGS" \
79907b07 502 --real-ldflags="%{rpmldflags}" \
503 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 504 --language=all \
1f8d8779 505%if %{with system_ffmpeg}
0cd1ec52 506 --disable-ffmpeg_a \
1f8d8779 507%endif
57f87bc2 508%ifnarch %{ix86} %{x8664}
dd6c659c 509 --disable-3dnow \
a14f4270 510 --disable-3dnowext \
63bba7db
JB
511 --disable-fastmemcpy \
512 --disable-mmx \
513 --disable-mmxext \
dd6c659c
JB
514 --disable-sse \
515 --disable-sse2 \
dfeec30a 516%endif
9accd5e5 517 %{__disable ssse3} \
1837afdf 518%ifarch ppc
9accd5e5 519 %{__disable altivec} \
1837afdf 520%endif
9accd5e5 521 %{__disable aalib aa} \
9accd5e5 522 %{__enable_disable alsa} \
523 %{__disable arts} \
63bba7db 524 %{__disable bluray} \
9accd5e5 525 %{__disable caca} \
526 %{__disable cdparanoia} \
63bba7db
JB
527 --enable-dga1 \
528 --enable-dga2 \
529 %{__enable_disable directfb} \
530 %{__enable_disable dvdnav} \
531 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 532 %{__disable dxr2} \
63bba7db
JB
533 %{__disable dxr3} \
534 --enable-dynamic-plugins \
9accd5e5 535 %{__disable enca} \
536 %{__disable esd} \
9accd5e5 537 %{__disable faad} \
63bba7db 538 --enable-fbdev \
9accd5e5 539 %{__disable gif} \
63bba7db
JB
540 --enable-gl \
541 %{__disable ggi} \
542 %{__disable jack} \
9accd5e5 543 %{__enable joystick} \
63bba7db
JB
544 %{__disable cdio libcdio} \
545 %{__disable ladspa} \
10a6d1a6 546 %{__disable bs2b libbs2b} \
9accd5e5 547 %{__disable libdts libdca} \
63bba7db
JB
548 %{__disable libdv} \
549 %{__disable system_dvdcss libdvdcss-internal} \
550 %{__disable lzo liblzo} \
551 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 552 %{__disable nemesi} \
63bba7db
JB
553 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
554 %{__disable openjpeg} \
555 %{__disable rtmp librtmp} \
556 %{__disable vorbis libvorbis} \
9accd5e5 557 %{__enable_disable lirc} \
63bba7db 558 --disable-lircc \
7ee3dc06 559 %{__enable_disable live} \
9accd5e5 560 %{__disable mad} \
63bba7db
JB
561 %{__disable mencoder} \
562 %{__enable osd menu} \
563 --enable-mga \
564 %{__disable mpg123} \
565 %{__enable musepack} \
566 %{__disable nas} \
9accd5e5 567 %{__disable pulseaudio pulse} \
568 %{__disable quicktime qtx} \
63bba7db
JB
569 --enable-radio \
570 --enable-radio-capture \
9accd5e5 571 %{__disable real} \
572 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 573 %{__enable_disable sdl} \
9accd5e5 574 %{__disable select} \
10a6d1a6 575 --enable-s3fb \
9accd5e5 576 %{__disable smb} \
63bba7db
JB
577 %{__disable svga} \
578 --enable-tdfxfb \
10a6d1a6 579 --enable-tdfxvid \
9accd5e5 580 %{__disable theora} \
63bba7db 581 --disable-toolame \
44d571a0 582 %{!?with_tremor:--disable-tremor} \
63bba7db 583 --enable-unrarexec \
9accd5e5 584 %{__disable vdpau} \
63bba7db 585 %{__disable vidix} \
10a6d1a6 586 %{__disable vstream} \
dd6c659c 587 --enable-vm \
10a6d1a6
JB
588%ifarch ppc
589 --enable-wii \
590%endif
63bba7db 591 %{__disable win32 win32dll} \
dd6c659c 592 --enable-x11 \
63bba7db 593 %{__disable x264} \
dd6c659c 594 --enable-xmga \
63bba7db 595 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 596 --enable-xv \
63bba7db
JB
597 %{__disable xvid} \
598 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 599 %{__enable_disable zr} \
11421384 600 "$@"
eb52750a 601
d53c9a42 602 %{__make} %{?with_verbose:V=1}
11421384 603}
2adea73e 604
11421384
ER
605%if %{with gui}
606# build GUI version
841cb995 607build --enable-gui --disable-mencoder
d6da6cb0 608%{__mv} mplayer gmplayer
aeb67db6 609%{__make} distclean
11421384
ER
610%endif
611
612# now build regular version
613build --disable-gui
614
aab7d90d 615%if %{with doc}
ef1e3931 616%{__make} -j1 doc
11421384 617%endif
ceb01d0e 618
2adea73e
AM
619%install
620rm -rf $RPM_BUILD_ROOT
e0e4b963 621install -d \
d23c171d 622 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
40ce9ce9 623 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
9accd5e5 624 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 625 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 626
e0e4b963 627# default config files
c455a752 628install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 629
630# executables
40ce9ce9
JB
631for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
632install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
633%if "%{binsuf}" != ""
634ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
11421384 635%endif
40ce9ce9 636done
e0e4b963 637
c2bf8f19 638%if %{with shared}
639install -d $RPM_BUILD_ROOT%{_libdir}
640install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
641%endif
642
e0e4b963 643# fonts
9d62f689 644cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 645ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 646
11421384 647%if %{with gui}
f0d8c47e 648install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 649%endif
9accd5e5 650touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 651install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 652install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 653
654# man pages
59ba0205 655install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 656install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
657install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
658install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
659install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
660install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 661install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 662install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
40ce9ce9 663install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
841cb995 664#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
40ce9ce9 665install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 666
2adea73e
AM
667%clean
668rm -rf $RPM_BUILD_ROOT
669
a69eaaef 670%post -n gmplayer
cd748ae6 671umask 022
cd748ae6 672[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
673
a69eaaef 674%postun -n gmplayer
cd748ae6 675umask 022
75b3147a 676[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 677
2adea73e
AM
678%files
679%defattr(644,root,root,755)
1a8df7bd 680%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
681
682%if %{with gui}
683%files -n gmplayer
684%defattr(644,root,root,755)
1a8df7bd 685%attr(755,root,root) %{_bindir}/gmplayer*
11421384 686%{_desktopdir}/gmplayer.desktop
11421384
ER
687%endif
688
0fb5a7ee 689%if %{with mencoder}
11421384
ER
690%files -n mencoder
691%defattr(644,root,root,755)
aeb67db6 692%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
693%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
694%doc DOCS/tech/colorspaces.txt
1a8df7bd 695%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 696%endif
11421384 697
841cb995 698%if %{with doc}
dc3c7d77 699%files doc
df52db46 700%defattr(644,root,root,755)
dc3c7d77 701%doc DOCS/tech
841cb995
ER
702# HTML and XML-generated docs
703%doc DOCS/HTML/en
0ffd4cd0 704%lang(cs) %doc DOCS/HTML/cs
aeb67db6 705%lang(de) %doc DOCS/HTML/de
aee40e50 706%lang(es) %doc DOCS/HTML/es
707%lang(fr) %doc DOCS/HTML/fr
8cda16b8 708%lang(hu) %doc DOCS/HTML/hu
d6da6cb0 709%lang(it) %doc DOCS/HTML/it
aee40e50 710%lang(pl) %doc DOCS/HTML/pl
711%lang(ru) %doc DOCS/HTML/ru
d6da6cb0 712%lang(zh_CN) %doc DOCS/HTML/zh_CN
841cb995 713%endif
dc3c7d77
ER
714
715%files common
716%defattr(644,root,root,755)
841cb995 717%doc AUTHORS README
dc3c7d77
ER
718%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
719%if %{with win32}
720%doc etc/codecs.win32.conf
721%endif
11421384 722
906bf13b
JB
723%dir %{_sysconfdir}/%{name}
724%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
40ce9ce9
JB
725%{_mandir}/man1/mplayer.1*
726%lang(cs) %{_mandir}/cs/man1/mplayer.1*
727%lang(de) %{_mandir}/de/man1/mplayer.1*
728%lang(es) %{_mandir}/es/man1/mplayer.1*
729%lang(fr) %{_mandir}/fr/man1/mplayer.1*
730%lang(hu) %{_mandir}/hu/man1/mplayer.1*
731%lang(it) %{_mandir}/it/man1/mplayer.1*
732%lang(pl) %{_mandir}/pl/man1/mplayer.1*
733%lang(ru) %{_mandir}/ru/man1/mplayer.1*
734#%lang(sv) %{_mandir}/sv/man1/mplayer.1*
735%lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
24481cd2 736%{_desktopdir}/mplayer.desktop
1087e996 737%{_pixmapsdir}/mplayer.png
11421384
ER
738%dir %{_datadir}/%{name}
739%{_datadir}/%{name}/font*
59ce39fb
ER
740%dir %{_datadir}/%{name}/skins
741%ghost %{_datadir}/%{name}/skins/default
This page took 0.573711 seconds and 4 git commands to generate.