]> git.pld-linux.org Git - packages/memcached.git/blobdiff - memcached.spec
- rebuild with libevent 2.1.11
[packages/memcached.git] / memcached.spec
index 83cf0daf49525441ed2b240f77e2dc4cb7a4c153..ef3404fb49f74e305d4f87113118b43c78e46af5 100644 (file)
@@ -1,24 +1,26 @@
-#
 # NOTE
-# - release notes: https://code.google.com/p/memcached/wiki/ReleaseNotes
-
-# Conditional build:
-%bcond_with            repcached               # repcached support, http://repcached.lab.klab.org/
+# - release notes: https://github.com/memcached/memcached/wiki/ReleaseNotes
+# TODO
+# - fix x32 build failure:
+#crawler.c: In function 'crawler_metadump_eval':
+#crawler.c:229:13: warning: format '%ld' expects argument of type 'long int', but argument 5 has type 'time_t {aka long long int}' [-Wformat=]
+#             "key=%s exp=%ld la=%llu cas=%llu fetch=%s\n",
+#             ^
+#crawler.c:229:13: warning: format '%ld' expects argument of type 'long int', but argument 5 has type 'time_t {aka long long int}' [-Wformat=]
 
 Summary:       A high-performance, distributed memory object caching system
 Summary(pl.UTF-8):     Rozproszony, wysokiej wydajności system cache'owania obiektów
 Name:          memcached
-Version:       1.4.15
-Release:       1
+Version:       1.5.20
+Release:       2
 License:       BSD
 Group:         Networking/Daemons
-Source0:       http://memcached.googlecode.com/files/%{name}-%{version}.tar.gz
-# Source0-md5: 36ea966f5a29655be1746bf4949f7f69
+Source0:       http://www.memcached.org/files/%{name}-%{version}.tar.gz
+# Source0-md5: 4b64296ea0eeccdee9168c035e0488ab
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.tmpfiles
-URL:           http://memcached.org/
-Patch0:                repcached.patch
+URL:           https://memcached.org/about
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libevent-devel >= 1.1
@@ -36,18 +38,32 @@ Provides:   group(memcached)
 Provides:      user(memcached)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _bindir %{_sbindir}
+
 %description
 A high-performance, distributed memory object caching system.
 
 %description -l pl.UTF-8
 Rozproszony, wysokiej wydajności system cache'owania obiektów.
 
+%package devel
+Summary:       Files needed for development using memcached protocol
+Group:         Development/Libraries
+# does not require base
+
+%description devel
+Install memcached-devel if you are developing C/C++ applications that
+require access to the memcached binary include files.
+
 %prep
 %setup -q
-%{?with_repcached:%patch0 -p1}
 
 sed -nie '1,/^$/p' ChangeLog
 
+%ifarch x32
+%{__sed} -i -e 's/-Werror//' configure.ac
+%endif
+
 %build
 %{__aclocal}
 %{__autoconf}
@@ -61,16 +77,15 @@ sed -nie '1,/^$/p' ChangeLog
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},/var/run/memcached} \
-       $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man1} \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
-install -p memcached $RPM_BUILD_ROOT%{_sbindir}
-cp -p doc/memcached.1 $RPM_BUILD_ROOT%{_mandir}/man1
+%{__make} install \
+       INSTALL="%{__install} -p" \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
-
-install %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
 %pre
 %groupadd -g 209 %{name}
@@ -104,3 +119,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/memcached.1*
 %dir %attr(770,root,memcached) /var/run/memcached
 %{systemdtmpfilesdir}/%{name}.conf
+
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/%{name}
This page took 0.720026 seconds and 4 git commands to generate.