]> git.pld-linux.org Git - packages/lxc.git/blobdiff - lxc.spec
up to 1.0.0.beta1
[packages/lxc.git] / lxc.spec
index 9592b9486f17fcc80346ad36ade96cc27495cfe2..424505ac370d8010f7de3ae52134de91296b12db 100644 (file)
--- a/lxc.spec
+++ b/lxc.spec
@@ -1,31 +1,32 @@
 #
 # Conditional build:
 %bcond_without seccomp # SecComp syscall filter
+%bcond_without apparmor        # apparmor
 %bcond_without lua     # Lua binding
 %bcond_without python  # Python binding
+%bcond_with    selinux # SELinux
 
-Summary:       Linux Container Tools
+%define                subver  beta1
+%define                rel             0.1
+Summary:       Linux Containers userspace tools
 Summary(pl.UTF-8):     Narzędzia do kontenerów linuksowych (LXC)
 Name:          lxc
-Version:       0.9.0
-Release:       5
+Version:       1.0.0
+Release:       0.%{subver}.%{rel}
 License:       LGPL v2.1+
 Group:         Applications/System
-Source0:       http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
-# Source0-md5: 8552a4479090616f4bc04d8473765fc9
-Patch0:                %{name}-devpts.patch
+Source0:       https://github.com/lxc/lxc/archive/%{name}-%{version}.%{subver}.tar.gz
+# Source0-md5: 82ddad563fe31b80595543d838788551
+Source1:       %{name}-pld.in.sh
 Patch1:                %{name}-pld.patch
-Patch2:                am-1.14.patch
-Patch3:                checkconfig-module.patch
 Patch4:                checkconfig-vserver-config.patch
-Patch5:                fedora-template.patch
-URL:           http://lxc.sourceforge.net/
+URL:           http://linuxcontainers.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: docbook-dtd30-sgml
 BuildRequires: docbook-utils
 BuildRequires: docbook2X
-BuildRequires: libapparmor-devel
+%{?with_apparmor:BuildRequires:        libapparmor-devel}
 BuildRequires: libcap-devel
 %{?with_seccomp:BuildRequires: libseccomp-devel}
 %{?with_lua:BuildRequires:     lua51-devel >= 5.1}
@@ -34,7 +35,9 @@ BuildRequires:        pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.612
 BuildRequires: sed >= 4.0
 Requires:      rc-scripts >= 0.4.6
+Requires:      which
 Suggests:      net-tools
+Suggests:      rsync
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                configpath      /var/lib/lxc
@@ -98,13 +101,11 @@ Python (3.x) binding for LXC.
 Wiązanie Pythona (3.x) do LXC.
 
 %prep
-%setup -q
-%patch0 -p1
+%setup -q -n %{name}-%{name}-%{version}%{?subver:.%{subver}}
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
 %patch4 -p1
-%patch5 -p1
+
+cp -p %{SOURCE1} templates/lxc-pld.in
 
 %build
 %{__aclocal} -I config
@@ -115,10 +116,14 @@ Wiązanie Pythona (3.x) do LXC.
        db2xman=docbook2X2man \
        --disable-rpath \
        --enable-doc \
-       %{?with_lua:--enable-lua} \
-       %{?with_python:--enable-python} \
-       %{?with_seccomp:--enable-seccomp} \
+       --enable-examples \
+       %{__enable_disable apparmor} \
+       %{__enable_disable lua} %{?with_lua:--with-lua-pc=lua51} \
+       %{__enable_disable python} \
+       %{__enable_disable seccomp} \
+       %{__enable_disable selinux} \
        --with-config-path=%{configpath} \
+       --with-init-script=sysv,systemd \
        --with-distro=pld
 
 %{__make}
@@ -126,7 +131,7 @@ Wiązanie Pythona (3.x) do LXC.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{configpath},/var/cache/lxc}
+install -d $RPM_BUILD_ROOT{%{configpath},/var/{cache,log}/lxc}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        pcdatadir=%{_pkgconfigdir}
@@ -152,12 +157,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
+%doc AUTHORS CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
 %attr(755,root,root) %{_bindir}/lxc-attach
 %attr(755,root,root) %{_bindir}/lxc-cgroup
 %attr(755,root,root) %{_bindir}/lxc-checkconfig
 %attr(755,root,root) %{_bindir}/lxc-checkpoint
 %attr(755,root,root) %{_bindir}/lxc-clone
+%attr(755,root,root) %{_bindir}/lxc-config
 %attr(755,root,root) %{_bindir}/lxc-console
 %attr(755,root,root) %{_bindir}/lxc-create
 %attr(755,root,root) %{_bindir}/lxc-destroy
@@ -166,29 +172,36 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lxc-info
 %attr(755,root,root) %{_bindir}/lxc-kill
 %attr(755,root,root) %{_bindir}/lxc-monitor
+%attr(755,root,root) %{_bindir}/lxc-monitord
 %attr(755,root,root) %{_bindir}/lxc-netstat
 %attr(755,root,root) %{_bindir}/lxc-ps
 %attr(755,root,root) %{_bindir}/lxc-restart
-%attr(755,root,root) %{_bindir}/lxc-shutdown
+%attr(755,root,root) %{_bindir}/lxc-snapshot
 %attr(755,root,root) %{_bindir}/lxc-start
 %attr(755,root,root) %{_bindir}/lxc-stop
 %attr(755,root,root) %{_bindir}/lxc-unfreeze
 %attr(755,root,root) %{_bindir}/lxc-unshare
+%attr(755,root,root) %{_bindir}/lxc-user-nic
+%attr(755,root,root) %{_bindir}/lxc-usernsexec
 %attr(755,root,root) %{_bindir}/lxc-version
 %attr(755,root,root) %{_bindir}/lxc-wait
 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
+%attr(755,root,root) %ghost %{_libdir}/liblxc.so.1
 %dir %{_libdir}/lxc
 %dir %{_libdir}/lxc/rootfs
 %{_libdir}/lxc/rootfs/README
 %attr(755,root,root) %{_libdir}/lxc/lxc-init
 %dir %{_sysconfdir}/lxc
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
-%dir %{_datadir}/lxc
+%dir %{_datadir}/%{name}
 %{_datadir}/%{name}/lxc.functions
+%dir %{_datadir}/%{name}/config
+%{_datadir}/%{name}/config/ubuntu*.conf
 %dir %{_datadir}/%{name}/hooks
 %dir %{_datadir}/%{name}/templates
 %attr(755,root,root) %{_datadir}/%{name}/hooks/mount*
+%attr(755,root,root) %{_datadir}/%{name}/hooks/clonehostname
+%attr(755,root,root) %{_datadir}/%{name}/hooks/ubuntu-cloud-prep
 %attr(755,root,root) %{_datadir}/%{name}/templates/lxc-*
 %{_mandir}/man1/lxc-attach.1*
 %{_mandir}/man1/lxc-cgroup.1*
@@ -206,15 +219,25 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/lxc-netstat.1*
 %{_mandir}/man1/lxc-ps.1*
 %{_mandir}/man1/lxc-restart.1*
-%{_mandir}/man1/lxc-shutdown.1*
+%{_mandir}/man1/lxc-snapshot.1*
 %{_mandir}/man1/lxc-start.1*
 %{_mandir}/man1/lxc-stop.1*
 %{_mandir}/man1/lxc-unfreeze.1*
 %{_mandir}/man1/lxc-unshare.1*
+%{_mandir}/man1/lxc-user-nic.1*
 %{_mandir}/man1/lxc-version.1*
 %{_mandir}/man1/lxc-wait.1*
+%{_mandir}/man5/lxc-usernet.5*
 %{_mandir}/man5/lxc.conf.5*
 %{_mandir}/man7/lxc.7*
+%lang(ja) %{_mandir}/ja/man1/lxc*.1*
+%lang(ja) %{_mandir}/ja/man5/lxc.conf.5*
+%lang(ja) %{_mandir}/ja/man7/lxc.7*
+%exclude %{_mandir}/ja/man1/lxc-device.1*
+%exclude %{_mandir}/ja/man1/lxc-ls.1*
+%exclude %{_mandir}/ja/man1/lxc-start-ephemeral.1*
+%exclude %{_mandir}/ja/man1/lxc-top.1*
+
 %if %{without python}
 # legacy version
 %attr(755,root,root) %{_bindir}/lxc-ls
@@ -222,7 +245,8 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %dir %{configpath}
-%dir /var/cache/lxc
+%dir %attr(750,root,root) /var/log/lxc
+%dir %attr(750,root,root) /var/cache/lxc
 
 %files devel
 %defattr(644,root,root,755)
@@ -234,10 +258,11 @@ rm -rf $RPM_BUILD_ROOT
 %files -n lua-lxc
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/lxc-top
-%dir %{_libdir}/lua/5.1/lxc
-%attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
-%{_datadir}/lua/5.1/lxc.lua
+%dir %{_libdir}/lua/lxc
+%attr(755,root,root) %{_libdir}/lua/lxc/core.so
+%{_datadir}/lua/lxc.lua
 %{_mandir}/man1/lxc-top.1*
+%lang(ja) %{_mandir}/ja/man1/lxc-top.1*
 %endif
 
 %if %{with python}
@@ -252,4 +277,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/lxc-device.1*
 %{_mandir}/man1/lxc-ls.1*
 %{_mandir}/man1/lxc-start-ephemeral.1*
+%lang(ja) %{_mandir}/ja/man1/lxc-device.1*
+%lang(ja) %{_mandir}/ja/man1/lxc-ls.1*
+%lang(ja) %{_mandir}/ja/man1/lxc-start-ephemeral.1*
 %endif
This page took 0.059207 seconds and 4 git commands to generate.