]> git.pld-linux.org Git - packages/lxc.git/blobdiff - lxc.spec
Release 2. Added lxc_macvlan service, setting up host macvlan interface for lxc...
[packages/lxc.git] / lxc.spec
index 738f86c4c8c7fe6f227fbe2f9c28601b4ed34708..1c0e53fd9dc5c505cede7a268107a04ef6dd2ba0 100644 (file)
--- a/lxc.spec
+++ b/lxc.spec
@@ -1,42 +1,52 @@
-#
+# TODO
+# - package apparmor stuff
+
 # Conditional build:
 %bcond_without seccomp # SecComp syscall filter
 %bcond_without apparmor        # apparmor
 %bcond_without lua     # Lua binding
 %bcond_without python  # Python binding
 %bcond_with    selinux # SELinux
+%bcond_with    cgmanager       # Enable cgmanager (BR: libcgmanager, libnih >= 1.0.2, libnih-dbus >= 1.0.0, dbus-1 >= 1.2.16)
 
-%define                subver  beta1
-%define                rel             0.1
 Summary:       Linux Containers userspace tools
 Summary(pl.UTF-8):     Narzędzia do kontenerów linuksowych (LXC)
 Name:          lxc
-Version:       1.0.0
-Release:       0.%{subver}.%{rel}
+Version:       1.0.7
+Release:       2
 License:       LGPL v2.1+
 Group:         Applications/System
-Source0:       https://github.com/lxc/lxc/archive/%{name}-%{version}.%{subver}.tar.gz
-# Source0-md5: 82ddad563fe31b80595543d838788551
+Source0:       https://www.linuxcontainers.org/downloads/%{name}-%{version}.tar.gz
+# Source0-md5: b48f468a9bef0e4e140dd723f0a65ad0
 Source1:       %{name}-pld.in.sh
+Source2:       %{name}.init
+Source3:       %{name}_macvlan.init
+Source4:       %{name}_macvlan.sysconfig
 Patch1:                %{name}-pld.patch
-Patch4:                checkconfig-vserver-config.patch
-URL:           http://linuxcontainers.org/
+URL:           https://www.linuxcontainers.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: docbook-dtd30-sgml
 BuildRequires: docbook-utils
 BuildRequires: docbook2X
+BuildRequires: gnutls-devel
 %{?with_apparmor:BuildRequires:        libapparmor-devel}
 BuildRequires: libcap-devel
 %{?with_seccomp:BuildRequires: libseccomp-devel}
+BuildRequires: libxslt-progs
 %{?with_lua:BuildRequires:     lua51-devel >= 5.1}
 BuildRequires: pkgconfig
 %{?with_python:BuildRequires:  python3-devel >= 3.2}
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.612
 BuildRequires: sed >= 4.0
 Requires:      rc-scripts >= 0.4.6
 Requires:      which
+Suggests:      gnupg
+Suggests:      gnupg-plugin-keys_curl
+Suggests:      gnupg-plugin-keys_hkp
 Suggests:      net-tools
+Suggests:      python3-lxc
 Suggests:      rsync
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -101,10 +111,22 @@ Python (3.x) binding for LXC.
 %description -n python3-lxc -l pl.UTF-8
 Wiązanie Pythona (3.x) do LXC.
 
+%package -n bash-completion-%{name}
+Summary:       bash-completion for LXC
+Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla LXC
+Group:         Applications/Shells
+Requires:      %{name}
+Requires:      bash-completion
+
+%description -n bash-completion-%{name}
+bash-completion for LXC.
+
+%description -n bash-completion-%{name} -l pl.UTF-8
+bashowe uzupełnianie nazw dla LXC.
+
 %prep
-%setup -q -n %{name}-%{name}-%{version}%{?subver:.%{subver}}
+%setup -q
 %patch1 -p1
-%patch4 -p1
 
 cp -p %{SOURCE1} templates/lxc-pld.in
 
@@ -116,6 +138,7 @@ cp -p %{SOURCE1} templates/lxc-pld.in
 %configure \
        db2xman=docbook2X2man \
        --disable-rpath \
+       --enable-bash \
        --enable-doc \
        --enable-examples \
        %{__enable_disable apparmor} \
@@ -124,7 +147,8 @@ cp -p %{SOURCE1} templates/lxc-pld.in
        %{__enable_disable seccomp} \
        %{__enable_disable selinux} \
        --with-config-path=%{configpath} \
-       --with-init-script=sysv,systemd \
+       --with-init-script=sysvinit,systemd \
+       --with-runtime-path=/var/run \
        --with-distro=pld
 
 %{__make}
@@ -132,37 +156,64 @@ cp -p %{SOURCE1} templates/lxc-pld.in
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{configpath},/var/{cache,log}/lxc}
+install -d $RPM_BUILD_ROOT{%{configpath},%{configpath}snap,/var/{cache,log}/lxc}  \
+        -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
+
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       pcdatadir=%{_pkgconfigdir}
+       SYSTEMD_UNIT_DIR=%{systemdunitdir} \
+       pcdatadir=%{_pkgconfigdir} \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} -C doc install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
 
+# apparmor profiles are not packaged, remove to avoid packagers confusion
+%{__rm} -r $RPM_BUILD_ROOT/etc/apparmor.d
+
+# yum plugin, no idea where to package this
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/lxc-patch.py
+
+install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/lxc
+install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lxc_macvlan
+install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/lxc_macvlan
+
 %if %{with python}
 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
 %endif
 %if %{with lua}
-%{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
+%{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua5.1,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
 %endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  -p /sbin/ldconfig
+/sbin/chkconfig --add lxc
+/sbin/chkconfig --add lxc_macvlan
+
+# %service lxc restart
+
+%preun
+if [ "$1" = "0" ]; then
+       %service lxc stop
+       /sbin/chkconfig --del lxc
+       %service lxc_macvlan stop
+       /sbin/chkconfig --del lxc_macvlan
+fi
+
 %postun        -p /sbin/ldconfig
 
+
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
+%doc AUTHORS CONTRIBUTING MAINTAINERS README  doc/FAQ.txt doc/examples/*.conf
 %attr(755,root,root) %{_bindir}/lxc-attach
+%attr(755,root,root) %{_bindir}/lxc-autostart
 %attr(755,root,root) %{_bindir}/lxc-cgroup
 %attr(755,root,root) %{_bindir}/lxc-checkconfig
-%attr(755,root,root) %{_bindir}/lxc-checkpoint
 %attr(755,root,root) %{_bindir}/lxc-clone
 %attr(755,root,root) %{_bindir}/lxc-config
 %attr(755,root,root) %{_bindir}/lxc-console
@@ -171,74 +222,88 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lxc-execute
 %attr(755,root,root) %{_bindir}/lxc-freeze
 %attr(755,root,root) %{_bindir}/lxc-info
-%attr(755,root,root) %{_bindir}/lxc-kill
 %attr(755,root,root) %{_bindir}/lxc-monitor
-%attr(755,root,root) %{_bindir}/lxc-monitord
-%attr(755,root,root) %{_bindir}/lxc-netstat
-%attr(755,root,root) %{_bindir}/lxc-ps
-%attr(755,root,root) %{_bindir}/lxc-restart
 %attr(755,root,root) %{_bindir}/lxc-snapshot
 %attr(755,root,root) %{_bindir}/lxc-start
 %attr(755,root,root) %{_bindir}/lxc-stop
 %attr(755,root,root) %{_bindir}/lxc-unfreeze
 %attr(755,root,root) %{_bindir}/lxc-unshare
-%attr(755,root,root) %{_bindir}/lxc-user-nic
 %attr(755,root,root) %{_bindir}/lxc-usernsexec
-%attr(755,root,root) %{_bindir}/lxc-version
 %attr(755,root,root) %{_bindir}/lxc-wait
+%attr(755,root,root) %{_sbindir}/init.lxc
 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.1
-%dir %{_libdir}/lxc
-%dir %{_libdir}/lxc/rootfs
-%{_libdir}/lxc/rootfs/README
-%attr(755,root,root) %{_libdir}/lxc/lxc-init
+%attr(754,root,root) /etc/rc.d/init.d/lxc
+%attr(754,root,root) /etc/rc.d/init.d/lxc_macvlan
+
+%{systemdunitdir}/lxc.service
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/rootfs
+%{_libdir}/%{name}/rootfs/README
+%attr(755,root,root) %{_libdir}/%{name}/lxc-devsetup
+%attr(755,root,root) %{_libdir}/%{name}/lxc-monitord
+%attr(755,root,root) %{_libdir}/%{name}/lxc-user-nic
+%attr(755,root,root) %{_libdir}/%{name}/lxc-autostart-helper
 %dir %{_sysconfdir}/lxc
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lxc_macvlan
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/lxc.functions
 %dir %{_datadir}/%{name}/config
-%{_datadir}/%{name}/config/ubuntu*.conf
+%{_datadir}/%{name}/config/centos.*.conf
+%{_datadir}/%{name}/config/common.seccomp
+%{_datadir}/%{name}/config/debian.*.conf
+%{_datadir}/%{name}/config/fedora.*.conf
+%{_datadir}/%{name}/config/gentoo.*.conf
+%{_datadir}/%{name}/config/oracle.*.conf
+%{_datadir}/%{name}/config/plamo.*.conf
+%{_datadir}/%{name}/config/ubuntu-cloud.*.conf
+%{_datadir}/%{name}/config/ubuntu.*.conf
 %dir %{_datadir}/%{name}/hooks
 %dir %{_datadir}/%{name}/templates
-%attr(755,root,root) %{_datadir}/%{name}/hooks/mount*
 %attr(755,root,root) %{_datadir}/%{name}/hooks/clonehostname
+%attr(755,root,root) %{_datadir}/%{name}/hooks/mount*
+%attr(755,root,root) %{_datadir}/%{name}/hooks/squid-deb-proxy-client
 %attr(755,root,root) %{_datadir}/%{name}/hooks/ubuntu-cloud-prep
 %attr(755,root,root) %{_datadir}/%{name}/templates/lxc-*
 %{_mandir}/man1/lxc-attach.1*
+%{_mandir}/man1/lxc-autostart.1*
 %{_mandir}/man1/lxc-cgroup.1*
 %{_mandir}/man1/lxc-checkconfig.1*
-%{_mandir}/man1/lxc-checkpoint.1*
 %{_mandir}/man1/lxc-clone.1*
+%{_mandir}/man1/lxc-config.1*
 %{_mandir}/man1/lxc-console.1*
 %{_mandir}/man1/lxc-create.1*
 %{_mandir}/man1/lxc-destroy.1*
 %{_mandir}/man1/lxc-execute.1*
 %{_mandir}/man1/lxc-freeze.1*
 %{_mandir}/man1/lxc-info.1*
-%{_mandir}/man1/lxc-kill.1*
 %{_mandir}/man1/lxc-monitor.1*
-%{_mandir}/man1/lxc-netstat.1*
-%{_mandir}/man1/lxc-ps.1*
-%{_mandir}/man1/lxc-restart.1*
 %{_mandir}/man1/lxc-snapshot.1*
 %{_mandir}/man1/lxc-start.1*
 %{_mandir}/man1/lxc-stop.1*
 %{_mandir}/man1/lxc-unfreeze.1*
 %{_mandir}/man1/lxc-unshare.1*
 %{_mandir}/man1/lxc-user-nic.1*
-%{_mandir}/man1/lxc-version.1*
+%{_mandir}/man1/lxc-usernsexec.1*
 %{_mandir}/man1/lxc-wait.1*
 %{_mandir}/man5/lxc-usernet.5*
 %{_mandir}/man5/lxc.conf.5*
+%{_mandir}/man5/lxc.container.conf.5*
+%{_mandir}/man5/lxc.system.conf.5*
 %{_mandir}/man7/lxc.7*
 %lang(ja) %{_mandir}/ja/man1/lxc*.1*
+%lang(ja) %{_mandir}/ja/man5/lxc-usernet.5*
 %lang(ja) %{_mandir}/ja/man5/lxc.conf.5*
+%lang(ja) %{_mandir}/ja/man5/lxc.container.conf.5*
+%lang(ja) %{_mandir}/ja/man5/lxc.system.conf.5*
 %lang(ja) %{_mandir}/ja/man7/lxc.7*
 %exclude %{_mandir}/ja/man1/lxc-device.1*
 %exclude %{_mandir}/ja/man1/lxc-ls.1*
 %exclude %{_mandir}/ja/man1/lxc-start-ephemeral.1*
 %exclude %{_mandir}/ja/man1/lxc-top.1*
 
+
 %if %{without python}
 # legacy version
 %attr(755,root,root) %{_bindir}/lxc-ls
@@ -246,6 +311,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %dir %{configpath}
+%dir %{configpath}snap
 %dir %attr(750,root,root) /var/log/lxc
 %dir %attr(750,root,root) /var/cache/lxc
 
@@ -282,3 +348,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_mandir}/ja/man1/lxc-ls.1*
 %lang(ja) %{_mandir}/ja/man1/lxc-start-ephemeral.1*
 %endif
+
+%files -n bash-completion-%{name}
+%defattr(644,root,root,755)
+/etc/bash_completion.d/lxc
This page took 0.331956 seconds and 4 git commands to generate.