]> git.pld-linux.org Git - packages/lxc.git/blame_incremental - lxc.spec
add usptream tracker url
[packages/lxc.git] / lxc.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without seccomp # SecComp syscall filter
4%bcond_without lua # Lua binding
5%bcond_without python # Python binding
6
7Summary: Linux Container Tools
8Summary(pl.UTF-8): Narzędzia do kontenerów linuksowych (LXC)
9Name: lxc
10Version: 0.9.0
11Release: 4
12License: LGPL v2.1+
13Group: Applications/System
14Source0: http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
15# Source0-md5: 8552a4479090616f4bc04d8473765fc9
16Patch0: %{name}-devpts.patch
17Patch1: %{name}-pld.patch
18Patch2: am-1.14.patch
19Patch3: checkconfig-module.patch
20Patch4: checkconfig-vserver-config.patch
21URL: http://lxc.sourceforge.net/
22BuildRequires: autoconf >= 2.50
23BuildRequires: automake
24BuildRequires: docbook-dtd30-sgml
25BuildRequires: docbook-utils
26BuildRequires: docbook2X
27BuildRequires: libapparmor-devel
28BuildRequires: libcap-devel
29%{?with_seccomp:BuildRequires: libseccomp-devel}
30%{?with_lua:BuildRequires: lua51-devel >= 5.1}
31BuildRequires: pkgconfig
32%{?with_python:BuildRequires: python3-devel >= 3.2}
33BuildRequires: rpmbuild(macros) >= 1.612
34BuildRequires: sed >= 4.0
35Suggests: net-tools
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%define configpath /var/lib/lxc
39
40%description
41Tools to create and manage containers. It contains a full featured
42container with the isolation / virtualization of the pids, the ipc,
43the utsname, the mount points, /proc, /sys, the network and it takes
44into account the control groups. It is very light, flexible, and
45provides a set of tools around the container like the monitoring with
46asynchronous events notification, or the freeze of the container. This
47package is useful to create Virtual Private Server, or to run isolated
48applications like bash or sshd.
49
50%description -l pl.UTF-8
51Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
52w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
53utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
54grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
55do czynności związanych z kontenerami, takich jak monitorowanie z
56asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
57pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
58oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
59
60%package devel
61Summary: Header files for lxc library
62Summary(pl.UTF-8): Pliki nagłówkowe biblioteki lxc
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description devel
67Header files for lxc library.
68
69%description devel -l pl.UTF-8
70Pliki nagłówkowe biblioteki lxc.
71
72%package -n lua-lxc
73Summary: Lua binding for LXC
74Summary(pl.UTF-8): Wiązanie Lua do LXC
75Group: Libraries
76Requires: %{name} = %{version}-%{release}
77Requires: lua51-libs >= 5.1
78
79%description -n lua-lxc
80Lua binding for LXC.
81
82%description -n lua-lxc -l pl.UTF-8
83Wiązanie Lua do LXC.
84
85%package -n python3-lxc
86Summary: Python (3.x) binding for LXC
87Summary(pl.UTF-8): Wiązanie Pythona (3.x) do LXC
88Group: Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: python3-libs >= 3.2
91
92%description -n python3-lxc
93Python (3.x) binding for LXC.
94
95%description -n python3-lxc -l pl.UTF-8
96Wiązanie Pythona (3.x) do LXC.
97
98%prep
99%setup -q
100%patch0 -p1
101%patch1 -p1
102%patch2 -p1
103%patch3 -p1
104%patch4 -p1
105
106%build
107%{__aclocal} -I config
108%{__autoconf}
109%{__autoheader}
110%{__automake}
111%configure \
112 db2xman=docbook2X2man \
113 --disable-rpath \
114 --enable-doc \
115 %{?with_lua:--enable-lua} \
116 %{?with_python:--enable-python} \
117 %{?with_seccomp:--enable-seccomp} \
118 --with-config-path=%{configpath} \
119 --with-distro=pld
120
121%{__make}
122%{__make} -C doc
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127%{__make} install \
128 DESTDIR=$RPM_BUILD_ROOT \
129 pcdatadir=%{_pkgconfigdir}
130
131%{__make} -C doc install \
132 DESTDIR=$RPM_BUILD_ROOT
133
134%{__rm} -r $RPM_BUILD_ROOT%{_docdir}
135
136install -d $RPM_BUILD_ROOT%{configpath}
137
138%if %{with python}
139%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
140%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
141%endif
142%if %{with lua}
143%{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
144%endif
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%post -p /sbin/ldconfig
150%postun -p /sbin/ldconfig
151
152%files
153%defattr(644,root,root,755)
154%doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
155%attr(755,root,root) %{_bindir}/lxc-attach
156%attr(755,root,root) %{_bindir}/lxc-cgroup
157%attr(755,root,root) %{_bindir}/lxc-checkconfig
158%attr(755,root,root) %{_bindir}/lxc-checkpoint
159%attr(755,root,root) %{_bindir}/lxc-clone
160%attr(755,root,root) %{_bindir}/lxc-console
161%attr(755,root,root) %{_bindir}/lxc-create
162%attr(755,root,root) %{_bindir}/lxc-destroy
163%attr(755,root,root) %{_bindir}/lxc-execute
164%attr(755,root,root) %{_bindir}/lxc-freeze
165%attr(755,root,root) %{_bindir}/lxc-info
166%attr(755,root,root) %{_bindir}/lxc-kill
167%attr(755,root,root) %{_bindir}/lxc-monitor
168%attr(755,root,root) %{_bindir}/lxc-netstat
169%attr(755,root,root) %{_bindir}/lxc-ps
170%attr(755,root,root) %{_bindir}/lxc-restart
171%attr(755,root,root) %{_bindir}/lxc-shutdown
172%attr(755,root,root) %{_bindir}/lxc-start
173%attr(755,root,root) %{_bindir}/lxc-stop
174%attr(755,root,root) %{_bindir}/lxc-unfreeze
175%attr(755,root,root) %{_bindir}/lxc-unshare
176%attr(755,root,root) %{_bindir}/lxc-version
177%attr(755,root,root) %{_bindir}/lxc-wait
178%attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
179%attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
180%dir %{configpath}
181%dir %{_libdir}/lxc
182%dir %{_libdir}/lxc/rootfs
183%{_libdir}/lxc/rootfs/README
184%attr(755,root,root) %{_libdir}/lxc/lxc-init
185%dir %{_sysconfdir}/lxc
186%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
187%{_datadir}/lxc
188%{_mandir}/man1/lxc-attach.1*
189%{_mandir}/man1/lxc-cgroup.1*
190%{_mandir}/man1/lxc-checkconfig.1*
191%{_mandir}/man1/lxc-checkpoint.1*
192%{_mandir}/man1/lxc-clone.1*
193%{_mandir}/man1/lxc-console.1*
194%{_mandir}/man1/lxc-create.1*
195%{_mandir}/man1/lxc-destroy.1*
196%{_mandir}/man1/lxc-execute.1*
197%{_mandir}/man1/lxc-freeze.1*
198%{_mandir}/man1/lxc-info.1*
199%{_mandir}/man1/lxc-kill.1*
200%{_mandir}/man1/lxc-monitor.1*
201%{_mandir}/man1/lxc-netstat.1*
202%{_mandir}/man1/lxc-ps.1*
203%{_mandir}/man1/lxc-restart.1*
204%{_mandir}/man1/lxc-shutdown.1*
205%{_mandir}/man1/lxc-start.1*
206%{_mandir}/man1/lxc-stop.1*
207%{_mandir}/man1/lxc-unfreeze.1*
208%{_mandir}/man1/lxc-unshare.1*
209%{_mandir}/man1/lxc-version.1*
210%{_mandir}/man1/lxc-wait.1*
211%{_mandir}/man5/lxc.conf.5*
212%{_mandir}/man7/lxc.7*
213%if %{without python}
214# legacy version
215%attr(755,root,root) %{_bindir}/lxc-ls
216%{_mandir}/man1/lxc-ls.1*
217%endif
218
219%files devel
220%defattr(644,root,root,755)
221%attr(755,root,root) %{_libdir}/liblxc.so
222%{_includedir}/lxc
223%{_pkgconfigdir}/lxc.pc
224
225%if %{with lua}
226%files -n lua-lxc
227%defattr(644,root,root,755)
228%attr(755,root,root) %{_bindir}/lxc-top
229%dir %{_libdir}/lua/5.1/lxc
230%attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
231%{_datadir}/lua/5.1/lxc.lua
232%{_mandir}/man1/lxc-top.1*
233%endif
234
235%if %{with python}
236%files -n python3-lxc
237%defattr(644,root,root,755)
238%attr(755,root,root) %{_bindir}/lxc-device
239%attr(755,root,root) %{_bindir}/lxc-ls
240%attr(755,root,root) %{_bindir}/lxc-start-ephemeral
241%{py3_sitedir}/lxc
242%attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
243%{py3_sitedir}/_lxc-0.1-py*.egg-info
244%{_mandir}/man1/lxc-device.1*
245%{_mandir}/man1/lxc-ls.1*
246%{_mandir}/man1/lxc-start-ephemeral.1*
247%endif
This page took 0.070864 seconds and 4 git commands to generate.