]> git.pld-linux.org Git - packages/log4cxx.git/blame - log4cxx.spec
- updated to 1.1.0
[packages/log4cxx.git] / log4cxx.spec
CommitLineData
d316c1c0
JB
1#
2# Conditional build:
3%bcond_without libesmtp # (E)SMTP support via libesmtp
ff9ca09b 4%bcond_without qt # Qt support library
d316c1c0 5
12cd7d45 6Summary: Log4cxx - a port to C++ of the log4j project
b081aded 7Summary(pl.UTF-8): Log4cxx - port projektu log4j dla C++
9eb0d9b9 8Name: log4cxx
f4c06078
JB
9Version: 1.1.0
10Release: 1
61d4f696 11License: Apache v2.0
9eb0d9b9 12Group: Libraries
f4c06078
JB
13Source0: https://downloads.apache.org/logging/log4cxx/%{version}/apache-%{name}-%{version}.tar.gz
14# Source0-md5: 50b76cadf829152371011d2db38351b2
9eb0d9b9 15URL: http://logging.apache.org/log4cxx/
ff9ca09b 16%{?with_qt:BuildRequires: Qt5Core-devel >= 5}
b7e3fe72
JB
17BuildRequires: apr-devel >= 1
18BuildRequires: apr-util-devel >= 1
3f19a639 19BuildRequires: boost-devel
b7e3fe72
JB
20BuildRequires: cmake >= 3.13
21# for tests
22BuildRequires: expat-devel >= 1.95
d316c1c0 23%{?with_libesmtp:BuildRequires: libesmtp-devel}
b7e3fe72
JB
24BuildRequires: libfmt-devel >= 7.1
25BuildRequires: libstdc++-devel >= 6:7
26BuildRequires: pkgconfig
27BuildRequires: rpmbuild(macros) >= 1.605
28BuildRequires: unixODBC-devel
9eb0d9b9 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
d4b912c0 32Log4cxx is C++ port of Log4j. Log4cxx attempts to mimic log4j usage as
9eb0d9b9 33much as the language will allow and to be compatible with log4j
34configuration and output formats.
35
97f33763
JR
36%description -l pl.UTF-8
37Log4cxx jest portem Log4j dla C++. Log4cxx próbuje naśladować
3f19a639
AM
38użytkowanie log4j tak bardzo na ile pozwala na to język oraz próbuje
39być kompatybilnym z plikami konfiguracyjnymi i formatami wyjściowymi
40log4j.
d4b912c0 41
9eb0d9b9 42%package devel
43Summary: Header files for log4cxx library
b081aded 44Summary(pl.UTF-8): Pliki nagłówkowe biblioteki log4cxx
9eb0d9b9 45Group: Development/Libraries
12cd7d45 46Requires: %{name} = %{version}-%{release}
b7e3fe72
JB
47Requires: apr-devel >= 1
48Requires: apr-util-devel >= 1
49Requires: libstdc++-devel >= 6:7
006f5065 50Obsoletes: log4cxx-static < 1
9eb0d9b9 51
52%description devel
53This is the package containing the header files for log4cxx library.
54
97f33763
JR
55%description devel -l pl.UTF-8
56Ten pakiet zawiera pliki nagłówkowe biblioteki log4cxx.
9eb0d9b9 57
ff9ca09b
JB
58%package qt
59Summary: Qt support library for log4cxx C++ logging framework
60Summary(pl.UTF-8): Biblioteka wsparcia Qt do szkieletu logującego C++ log4cxx
61Group: Libraries
62Requires: %{name} = %{version}-%{release}
63
64%description qt
65Qt support library for log4cxx C++ logging framework.
66
67%description qt -l pl.UTF-8
68Biblioteka wsparcia Qt do szkieletu logującego C++ log4cxx.
69
70%package qt-devel
71Summary: Header files for log4cxx Qt library
72Summary(pl.UTF-8): Pliki nagłówkowe biblioteki log4cxx Qt
73Group: Development/Libraries
74Requires: %{name}-devel = %{version}-%{release}
75Requires: %{name}-qt = %{version}-%{release}
76Requires: Qt5Core-devel >= 5
77
78%description qt-devel
79Header files for log4cxx Qt library.
80
81%description qt-devel -l pl.UTF-8
82Pliki nagłówkowe biblioteki log4cxx Qt.
83
9eb0d9b9 84%prep
de4213a3 85%setup -q -n apache-%{name}-%{version}
2c729fc0 86
9eb0d9b9 87%build
b7e3fe72
JB
88%cmake -B build \
89 -DCMAKE_INSTALL_INCLUDEDIR=include \
90 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
ff9ca09b
JB
91 %{!?with_libesmtp:-DHAS_LIBESMTP=OFF} \
92 %{?with_qt:-DLOG4CXX_QT_SUPPORT=ON}
b7e3fe72
JB
93
94%{__make} -C build
9eb0d9b9 95
96%install
97rm -rf $RPM_BUILD_ROOT
b7e3fe72 98
3f19a639 99%{__make} -C build install \
9eb0d9b9 100 DESTDIR=$RPM_BUILD_ROOT
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
b7e3fe72
JB
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
9eb0d9b9 107
108%files
109%defattr(644,root,root,755)
57c55d87 110%doc KEYS LICENSE NOTICE
9eb0d9b9 111%attr(755,root,root) %{_libdir}/liblog4cxx.so.*.*.*
3f19a639 112%attr(755,root,root) %ghost %{_libdir}/liblog4cxx.so.15
9eb0d9b9 113
114%files devel
115%defattr(644,root,root,755)
9eb0d9b9 116%attr(755,root,root) %{_libdir}/liblog4cxx.so
12cd7d45 117%{_includedir}/%{name}
61d4f696 118%{_pkgconfigdir}/liblog4cxx.pc
3f19a639 119%{_libdir}/cmake/log4cxx
ff9ca09b
JB
120
121%if %{with qt}
122%files qt
123%defattr(644,root,root,755)
124%attr(755,root,root) %{_libdir}/liblog4cxx-qt.so.*.*.*
125%attr(755,root,root) %ghost %{_libdir}/liblog4cxx-qt.so.15
126
127%files qt-devel
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_libdir}/liblog4cxx-qt.so
130%{_includedir}/log4cxx-qt
131%{_pkgconfigdir}/liblog4cxx-qt.pc
f4c06078 132%{_libdir}/cmake/log4cxx-qt
ff9ca09b 133%endif
This page took 0.387699 seconds and 4 git commands to generate.