]> git.pld-linux.org Git - packages/linux-gpib.git/blame - linux-gpib.spec
- rel 4
[packages/linux-gpib.git] / linux-gpib.spec
CommitLineData
d4054fe9 1#
d4054fe9 2# Conditional build:
2ee896be 3%bcond_without kernel # kernel modules
25beb8e8 4%bcond_without drivers_isa # ISA kernel drivers [ix86 only]
25beb8e8 5%bcond_without drivers_usb # USB kernel drivers
2ee896be
JB
6%bcond_without userspace # userspace packages
7%bcond_without verbose # verbose modules build (V=1)
df990a65 8
635db00a 9%bcond_without doc # documentation build
08f3bc97 10%bcond_with hotplug # legacy hotplug support
2ee896be 11%bcond_without static_libs # static library
91dbb874 12%bcond_without guile # guile binding
2ee896be 13%bcond_without perl # Perl binding
b3693ec1 14%bcond_with php # PHP binding
fb21f50f
JB
15%bcond_without python # Python (any) binding
16%bcond_without python2 # Python 2.x binding
2ee896be 17%bcond_without tcl # Tcl binding
df990a65 18
4c4f156c
JR
19# The goal here is to have main, userspace, package built once with
20# simple release number, and only rebuild kernel packages with kernel
21# version as part of release number, without the need to bump release
22# with every kernel change.
23%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24%{error:kernel and userspace cannot be built at the same time on PLD builders}
25exit 1
26%endif
27
eda43fa2
JR
28%if %{without userspace}
29# nothing to be placed to debuginfo package
30%define _enable_debug_packages 0
31%endif
32
25beb8e8
JB
33%ifnarch %{ix86}
34%undefine with_drivers_isa
fb21f50f
JB
35%endif
36%if %{without python}
37%undefine with_python2
25beb8e8 38%endif
4c4f156c 39
76a67c9a 40%define php_name php%{?php_suffix}
4c4f156c 41
a94a5022 42%define rel 4
4c4f156c 43%define pname linux-gpib
2ee896be
JB
44Summary: GPIB (IEEE 488) Linux support
45Summary(pl.UTF-8): Obsługa GPIB (IEEE 488) dla Linuksa
4c4f156c 46Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
fb21f50f 47Version: 4.3.3
2d0c8827 48Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
2ee896be 49License: GPL v2+
cc64c2aa 50Group: Applications/System
996e3d04 51Source0: http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
fb21f50f 52# Source0-md5: 1243aa44f788cf23f9b40ded54c14685
4c4f156c
JR
53Patch2: %{pname}-python.patch
54Patch3: %{pname}-perl.patch
55Patch4: %{pname}-firmwaredir.patch
56Patch5: %{pname}-guile2.patch
57Patch6: %{pname}-php7.patch
82a3ed18 58Patch8: kernel-5.2.patch
403be2a0 59Patch9: kernel-5.10.patch
659cb172 60Patch10: pkgconfig-version.patch
d4054fe9 61URL: http://linux-gpib.sourceforge.net/
2ee896be
JB
62BuildRequires: autoconf >= 2.50
63BuildRequires: automake
64BuildRequires: libtool
fb21f50f 65BuildRequires: rpmbuild(macros) >= 1.745
0a86a1d5 66%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.32}}
2ee896be
JB
67%if %{with userspace}
68BuildRequires: bison
635db00a 69%{?with_doc:BuildRequires: docbook-utils}
2ee896be 70BuildRequires: flex
91dbb874 71%{?with_guile:BuildRequires: guile-devel >= 1.4}
df990a65 72%{?with_perl:BuildRequires: perl-devel}
76a67c9a 73%{?with_php:BuildRequires: %{php_name}-devel >= 3:5}
2ee896be
JB
74%{?with_python:BuildRequires: python-devel >= 2}
75BuildRequires: readline-devel
df990a65 76%{?with_tcl:BuildRequires: tcl-devel}
2ee896be 77%endif
4c4f156c 78Requires: %{pname}-libs = %{version}-%{release}
4ffc9310
JB
79# for agilent_82357a and ni_usb_gpib
80Suggests: fxload
81# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
82Suggests: linux-gpib-firmware
d4054fe9 83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85%description
cc64c2aa 86The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
d4054fe9 87
bc9733fa
JR
88%description -l pl.UTF-8
89Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
d4054fe9 90
08f3bc97
JB
91%package hotplug
92Summary: Linux GPIB support for legacy USB hotplug
93Summary(pl.UTF-8): Obsługa Linux GPIB dla starego systemu hotplug USB
94Group: Applications/System
4c4f156c 95Requires: %{pname} = %{version}-%{release}
08f3bc97
JB
96Requires: hotplug
97
98%description hotplug
99Linux GPIB support for legacy USB hotplug.
100
101%description hotplug -l pl.UTF-8
102Obsługa Linux GPIB dla starego systemu hotplug USB.
103
2ee896be
JB
104%package libs
105Summary: Shared GPIB library
106Summary(pl.UTF-8): Biblioteka współdzielona GPIB
107Group: Libraries
d7b3679a 108
2ee896be
JB
109%description libs
110Shared GPIB library.
111
112%description libs -l pl.UTF-8
113Biblioteka współdzielona GPIB.
114
115%package devel
116Summary: Header file for GPIB library
117Summary(pl.UTF-8): Plik nagłówkowy biblioteki GPIB
118Group: Development/Libraries
4c4f156c 119Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
120
121%description devel
122Header file for GPIB library.
123
124%description devel -l pl.UTF-8
125Plik nagłówkowy biblioteki GPIB.
126
127%package static
128Summary: Static GPIB library
129Summary(pl.UTF-8): Biblioteka statyczna GPIB
130Group: Development/Libraries
4c4f156c 131Requires: %{pname}-devel = %{version}-%{release}
2ee896be
JB
132
133%description static
134Static GPIB library.
135
136%description static -l pl.UTF-8
137Biblioteka statyczna GPIB.
138
91dbb874
JB
139%package -n guile-gpib
140Summary: Guile bindings for GPIB library
141Summary(pl.UTF-8): Wiązania Guile do biblioteki GPIB
142Group: Development/Languages/Perl
4c4f156c 143Requires: %{pname}-libs = %{version}-%{release}
91dbb874
JB
144Requires: guile-libs
145
146%description -n guile-gpib
147Guile bindings for GPIB library.
148
149%description -n guile-gpib -l pl.UTF-8
150Wiązania Guile do biblioteki GPIB.
151
2ee896be
JB
152%package -n perl-gpib
153Summary: Perl bindings for GPIB library
154Summary(pl.UTF-8): Wiązania Perla do biblioteki GPIB
155Group: Development/Languages/Perl
4c4f156c 156Requires: %{pname}-libs = %{version}-%{release}
d7b3679a 157
2ee896be
JB
158%description -n perl-gpib
159Perl bindings for GPIB library.
d7b3679a 160
2ee896be
JB
161%description -n perl-gpib -l pl.UTF-8
162Wiązania Perla do biblioteki GPIB.
d7b3679a 163
76a67c9a
JB
164%package -n %{php_name}-gpib
165Summary: PHP bindings for GPIB library
166Summary(pl.UTF-8): Wiązania PHP do biblioteki GPIB
167Group: Development/Languages/PHP
168Provides: php(gpib) = %{version}
4c4f156c 169Requires: %{pname}-libs = %{version}-%{release}
76a67c9a
JB
170%{?requires_php_extension}
171
172%description -n %{php_name}-gpib
173PHP bindings for GPIB library.
174
175%description -n %{php_name}-gpib -l pl.UTF-8
176Wiązania PHP do biblioteki GPIB.
177
2ee896be 178%package -n python-gpib
fb21f50f
JB
179Summary: Python 2 bindings for GPIB library
180Summary(pl.UTF-8): Wiązania Pythona 2 do biblioteki GPIB
2ee896be 181Group: Libraries/Python
4c4f156c 182Requires: %{pname}-libs = %{version}-%{release}
2ee896be 183Requires: python-libs
d7b3679a 184
2ee896be 185%description -n python-gpib
fb21f50f 186Python 2 bindings for GPIB library.
2ee896be
JB
187
188%description -n python-gpib -l pl.UTF-8
fb21f50f
JB
189Wiązania Pythona 2 do biblioteki GPIB.
190
191%package -n python3-gpib
192Summary: Python 3 bindings for GPIB library
193Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki GPIB
194Group: Libraries/Python
195Requires: %{pname}-libs = %{version}-%{release}
196Requires: python3-libs
197
198%description -n python3-gpib
199Python 3 bindings for GPIB library.
200
201%description -n python3-gpib -l pl.UTF-8
202Wiązania Pythona 3 do biblioteki GPIB.
2ee896be
JB
203
204%package -n tcl-gpib
205Summary: Tcl bindings for GPIB library
206Summary(pl.UTF-8): Wiązania Tcl-a do biblioteki GPIB
207Group: Libraries
4c4f156c 208Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
209Requires: tcl
210
211%description -n tcl-gpib
212Tcl bindings for GPIB library.
213
214%description -n tcl-gpib -l pl.UTF-8
215Wiązania Tcl-a do biblioteki GPIB.
216
217%package doc
218Summary: Linux-GPIB tools and library documentation
219Summary(pl.UTF-8): Dokumentacja narzędzi i biblioteki Linux-GPIB
220License: GFDL v1.2+ or GPL v2+
221Group: Documentation
222
223%description doc
224Linux-GPIB tools and library documentation.
225
226%description doc -l pl.UTF-8
227Dokumentacja narzędzi i biblioteki Linux-GPIB.
228
229%define kernel_pkg()\
230%package -n kernel%{_alt_kernel}-gpib\
231Summary: Linux GPIB drivers\
232Summary(pl.UTF-8): Sterowniki GPIB dla Linuksa\
233Release: %{rel}@%{_kernel_ver_str}\
234Group: Base/Kernel\
235Requires(post,postun): /sbin/depmod\
236%requires_releq_kernel\
237Requires(postun): %releq_kernel\
238\
239%description -n kernel%{_alt_kernel}-gpib\
240This package contains Linux drivers for GPIB (IEEE 488) hardware.\
241\
242%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
243Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
244\
245%if %{with kernel}\
246%files -n kernel%{_alt_kernel}-gpib\
247%defattr(644,root,root,755)\
248/lib/modules/%{_kernel_ver}/kernel/gpib\
249%endif\
250\
251%post -n kernel%{_alt_kernel}-gpib\
252%depmod %{_kernel_ver}\
253\
254%postun -n kernel%{_alt_kernel}-gpib\
255%depmod %{_kernel_ver}\
256%{nil}
257
258%define build_kernel_pkg()\
55cbc6e3 259%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
2ee896be 260cd drivers/gpib\
403be2a0
JR
261%if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
262%if %{with drivers_usb}\
263%install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
264%endif\
265%endif\
82a3ed18 266%ifarch %{ix86}\
403be2a0 267%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 268%else\
403be2a0 269%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 270%endif\
b69cc3e0 271cd ../..\
2ee896be
JB
272%{nil}
273
274%define install_kernel_pkg()\
275%{nil}
276
277%{?with_kernel:%{expand:%create_kernel_packages}}
d7b3679a 278
d4054fe9 279%prep
996e3d04 280%setup -q -n %{pname}-%{version}
16f00101
JR
281%if %{with userspace}
282tar xzf linux-gpib-user-%{version}.tar.gz
283cd linux-gpib-user-%{version}
2ee896be
JB
284%patch2 -p1
285%patch3 -p1
08f3bc97 286%patch4 -p1
91dbb874 287%patch5 -p1
16f00101 288#%patch6 -p1
659cb172 289%patch10 -p1
16f00101
JR
290cd ..
291%endif
292
293%if %{with kernel}
294tar xzf linux-gpib-kernel-%{version}.tar.gz
295cd linux-gpib-kernel-%{version}
41ab8c5b 296%patch9 -p1
5e300ced
JR
297%ifarch %{ix86}
298%patch8 -p1
299%endif
16f00101 300%endif
d7b3679a 301
d4054fe9 302%build
16f00101
JR
303%if %{with userspace}
304cd linux-gpib-user-%{version}
302b72f6
JR
305%{__libtoolize}
306%{__aclocal}
307%{__autoconf}
308%{__autoheader}
309%{__automake}
91dbb874 310%if %{with guile}
d53b2ad5 311CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
91dbb874 312%endif
d7b3679a 313%configure \
55cbc6e3 314 --with-udev-libdir=/lib/udev \
635db00a 315 %{!?with_doc:--disable-documentation} \
2ee896be
JB
316 %{!?with_guile:--disable-guile-binding} \
317 %{!?with_perl:--disable-perl-binding} \
318 %{!?with_php:--disable-php-binding} \
319 %{!?with_python:--disable-python-binding} \
320 %{?with_static_libs:--enable-static} \
16f00101 321 %{!?with_tcl:--disable-tcl-binding}
d7b3679a 322
9e3b7024 323%{__make}
fb21f50f
JB
324
325%if %{with python2}
326cd language/python
327%py_build
328cd ../..
329%endif
16f00101 330cd ..
2ee896be 331%endif
d7b3679a 332
2ee896be 333%if %{with kernel}
16f00101 334cd linux-gpib-kernel-%{version}
2ee896be
JB
335%{expand:%build_kernel_packages}
336%endif
d4054fe9 337
338%install
339rm -rf $RPM_BUILD_ROOT
2ee896be 340install -d $RPM_BUILD_ROOT%{_examplesdir}
d4054fe9 341
8eefbf3b 342%if %{with kernel}
16f00101 343cd linux-gpib-kernel-%{version}
2ee896be
JB
344%{expand:%install_kernel_packages}
345cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
302b72f6 346cd ..
8eefbf3b
MWP
347%endif
348
d4054fe9 349%if %{with userspace}
302b72f6
JR
350cd linux-gpib-user-%{version}
351%{__make} install \
08f3bc97
JB
352 DESTDIR=$RPM_BUILD_ROOT \
353 HOTPLUG_USB_CONF_DIR=/lib/udev \
354 UDEV_RULES_DIR=/lib/udev/rules.d \
355 USB_FIRMWARE_DIR=/lib/firmware
25beb8e8 356
fb21f50f
JB
357%if %{with python2}
358cd language/python
359%py_install
360cd ../..
361%endif
362
25beb8e8 363%if %{with hotplug}
08f3bc97
JB
364# use udev paths as base and legacy hotplug as addon (not the opposite)
365install -d $RPM_BUILD_ROOT/etc/hotplug/usb
366%{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
367ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
368ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
25beb8e8 369%endif
2ee896be
JB
370
371# obsoleted by pkg-config
372%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
373
91dbb874
JB
374%if %{with guile}
375%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
376%if %{with static_libs}
377%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
378%endif
379%endif
380
2ee896be
JB
381%if %{with perl}
382%{__make} -C language/perl pure_install \
383 DESTDIR=$RPM_BUILD_ROOT
76a67c9a 384
2ee896be 385cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
76a67c9a 386
2ee896be
JB
387%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
388%endif
389
76a67c9a
JB
390%if %{with php}
391install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
392cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
393; Enable gpib extension module
394extension=gpib_php.so
395EOF
396
397%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
398%if %{with static_libs}
399%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
400%endif
401%endif
402
2ee896be
JB
403%if %{with python}
404%py_postclean
405%endif
406
407%if %{with tcl}
408cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
76a67c9a 409
2ee896be
JB
410%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
411%if %{with static_libs}
412%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
413%endif
414%endif
415
635db00a 416%if %{with doc}
2ee896be 417# packaged as %doc
302b72f6 418%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
d4054fe9 419%endif
82a3ed18 420%endif
d4054fe9 421
d4054fe9 422%clean
423rm -rf $RPM_BUILD_ROOT
424
2ee896be
JB
425%post libs -p /sbin/ldconfig
426%postun libs -p /sbin/ldconfig
d4054fe9 427
91dbb874
JB
428%post -n guile-gpib -p /sbin/ldconfig
429%postun -n guile-gpib -p /sbin/ldconfig
430
431%post -n tcl-gpib -p /sbin/ldconfig
432%postun -n tcl-gpib -p /sbin/ldconfig
433
76a67c9a
JB
434%post -n %{php_name}-gpib
435%php_webserver_restart
436
437%postun -n %{php_name}-gpib
438if [ "$1" = 0 ]; then
439 %php_webserver_restart
440fi
441
2ee896be
JB
442%if %{with userspace}
443%files
444%defattr(644,root,root,755)
302b72f6 445%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
2ee896be
JB
446%attr(755,root,root) %{_bindir}/ibterm
447%attr(755,root,root) %{_bindir}/ibtest
448%attr(755,root,root) %{_sbindir}/gpib_config
55cbc6e3 449/lib/udev/rules.d/98-gpib-generic.rules
08f3bc97 450/lib/udev/rules.d/99-agilent_82357a.rules
08f3bc97 451/lib/udev/rules.d/99-ni_usb_gpib.rules
55cbc6e3
JR
452%attr(755,root,root) /lib/udev/gpib_udev_config
453%attr(755,root,root) /lib/udev/gpib_udev_fxloader
454%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
08f3bc97
JB
455
456%if %{with hotplug}
457%files hotplug
458%defattr(644,root,root,755)
2ee896be
JB
459%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
460%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
461/etc/hotplug/usb/agilent_82357a.usermap
462/etc/hotplug/usb/ni_usb_gpib.usermap
08f3bc97 463%endif
d4054fe9 464
2ee896be 465%files libs
0e4898e2 466%defattr(644,root,root,755)
302b72f6 467%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
2ee896be
JB
468%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
469%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
470
471%files devel
472%defattr(644,root,root,755)
473%attr(755,root,root) %{_libdir}/libgpib.so
474%{_includedir}/gpib
475%{_pkgconfigdir}/libgpib.pc
476
477%if %{with static_libs}
478%files static
479%defattr(644,root,root,755)
480%{_libdir}/libgpib.a
481%endif
482
91dbb874
JB
483%if %{with guile}
484%files -n guile-gpib
485%defattr(644,root,root,755)
996e3d04 486%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
91dbb874
JB
487%attr(755,root,root) %{_libdir}/libgpib-guile.so
488%endif
489
2ee896be
JB
490%if %{with perl}
491%files -n perl-gpib
492%defattr(644,root,root,755)
302b72f6 493%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
2ee896be
JB
494%{perl_vendorarch}/LinuxGpib.pm
495%dir %{perl_vendorarch}/auto/LinuxGpib
496%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
497%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
498%{_mandir}/man3/LinuxGpib.3pm*
499%{_examplesdir}/perl-gpib-%{version}
500%endif
501
76a67c9a
JB
502%if %{with php}
503%files -n %{php_name}-gpib
504%defattr(644,root,root,755)
505%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
996e3d04 506%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
76a67c9a
JB
507%attr(755,root,root) %{php_extensiondir}/gpib_php.so
508%endif
509
fb21f50f 510%if %{with python2}
2ee896be
JB
511%files -n python-gpib
512%defattr(644,root,root,755)
302b72f6 513%doc linux-gpib-user-%{version}/language/python/README
2ee896be
JB
514%attr(755,root,root) %{py_sitedir}/gpib.so
515%{py_sitedir}/Gpib.py[co]
516%{py_sitedir}/gpib-1.0-py*.egg-info
517%endif
518
fb21f50f
JB
519%if %{with python}
520%files -n python3-gpib
521%defattr(644,root,root,755)
522%doc linux-gpib-user-%{version}/language/python/README
523%attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
524%{py3_sitedir}/Gpib.py
525%{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
526%{py3_sitedir}/gpib-1.0-py*.egg-info
527%endif
528
2ee896be
JB
529%if %{with tcl}
530%files -n tcl-gpib
531%defattr(644,root,root,755)
302b72f6 532%doc linux-gpib-user-%{version}/language/tcl/README
996e3d04 533%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
2ee896be
JB
534%attr(755,root,root) %{_libdir}/libgpib_tcl.so
535%{_examplesdir}/tcl-gpib-%{version}
536%endif
537
635db00a 538%if %{with doc}
2ee896be
JB
539%files doc
540%defattr(644,root,root,755)
302b72f6 541%doc linux-gpib-user-%{version}/doc/doc_html/*
2ee896be 542%endif
1fc85825 543%endif
This page took 0.151602 seconds and 4 git commands to generate.