]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
- use dropin
[packages/libvpx.git] / libvpx.spec
index 072f14d19b56d70c7a45574a2747e6b2baf6fdc1..6ab4aa76471b47798fbb4cc3a0bf3d7d04a0fb5b 100644 (file)
@@ -1,29 +1,46 @@
 #
 # Conditional build:
 %bcond_without asm     # x86 assembler
-#
+
 Summary:       VP8, a high-quality video codec
 Summary(pl.UTF-8):     VP8 - kodek obrazu wysokiej jakoĊ›ci
 Name:          libvpx
-Version:       0.9.5
-Release:       2
+Version:       1.3.0
+Release:       1
 License:       BSD
 Group:         Libraries
-#Source0-Download: http://code.google.com/p/webm/downloads/list
-Source0:       http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
-# Source0-md5: 4bf2f2c76700202c1fe9201fcb0680e3
-Source1:       %{name}.ver
-Patch0:                %{name}-0.9.0-no-explicit-dep-on-static-lib.patch
+#Source0Download: http://code.google.com/p/webm/downloads/list
+#Source0:      https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
+# source, but regenerated on each fetch
+#Source0:      https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
+Source0:       %{name}-%{version}.tar.gz
+# Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
 URL:           http://www.webmproject.org/
 BuildRequires: /usr/bin/php
 BuildRequires: doxygen
 BuildRequires: php-common >= 4:5.0.0
 BuildRequires: php-pcre
+BuildRequires: sed >= 4.0
 %ifarch %{ix86} %{x8664}
-%{?with_asm:BuildRequires:     yasm}
+%{?with_asm:BuildRequires:     yasm >= 0.8}
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define        generic_target  generic-gnu
+%define        vpxtarget       %{generic_target}
+%ifarch %{x8664}
+%define        vpxtarget       x86_64-linux-gcc
+%endif
+%ifarch %{ix86}
+%define        vpxtarget       x86-linux-gcc
+%endif
+%ifarch ppc
+%define        vpxtarget       ppc32-linux-gcc
+%endif
+%ifarch ppc64
+%define        vpxtarget       ppc64-linux-gcc
+%endif
+
 %description
 VP8, a high-quality video codec.
 
@@ -55,8 +72,8 @@ Static libvpx library.
 Statyczna biblioteka libvpx.
 
 %prep
-%setup -q -n %{name}-v%{version}
-%patch0 -p1
+#%setup -q -n %{name}-v%{version}
+%setup -q -c
 
 %build
 install -d obj
@@ -65,48 +82,41 @@ cd obj
 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
 ../configure \
 %if %{with asm}
-%ifarch %{x8664}
-       --target=x86_64-linux-gcc \
-%endif
-%ifarch %{ix86}
-       --target=x86-linux-gcc \
-%endif
-%else
-       --target=generic-gnu \
+       --as=yasm \
 %endif
+       --target=%{vpxtarget} \
+%if "%{vpxtarget}" != "%{generic_target}"
        --enable-shared \
+%endif
        --disable-optimizations \
        --enable-vp8 \
        --enable-postproc \
        --enable-runtime-cpu-detect
 
-# disable stripping
-sed -i "s|STRIP=.*|STRIP=|g" {libs,examples,docs}-*.mk
-
 %{__make} verbose=true target=libs \
+       HAVE_GNU_STRIP=no \
        CC="%{__cc}" \
+       LD="%{__cc}" \
        LDFLAGS="%{rpmldflags}"
 
 %{__make} verbose=true target=examples \
        CC="%{__cc}" \
-       LDFLAGS="%{rpmldflags}"
+       LD="%{__cc}" \
+       LDFLAGS="%{rpmldflags} -L."
 %{__make} verbose=true target=docs
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
 
-install -d outdir
 %{__make} -C obj verbose=true install \
-       DIST_DIR=$(pwd)/outdir
+       LIBSUBDIR=%{_lib} \
+       DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
 
-install -p outdir/bin/* $RPM_BUILD_ROOT%{_bindir}
-install -p obj/libvpx.so.* $RPM_BUILD_ROOT%{_libdir}
-ln -s libvpx.so.0.9.5 $RPM_BUILD_ROOT%{_libdir}/libvpx.so.0
-ln -s libvpx.so.0.9.5 $RPM_BUILD_ROOT%{_libdir}/libvpx.so
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
 
-cp -a outdir/include/vpx/*.h $RPM_BUILD_ROOT%{_includedir}/vpx
-cp -a outdir/lib/*.a $RPM_BUILD_ROOT%{_libdir}
+# adjust prefix and libdir
+%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -117,15 +127,18 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGELOG LICENSE PATENTS README
+%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
+%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder
 %attr(755,root,root) %{_bindir}/vpxdec
 %attr(755,root,root) %{_bindir}/vpxenc
 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libvpx.so.0
+%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libvpx.so
 %{_includedir}/vpx
+%{_pkgconfigdir}/vpx.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.10029 seconds and 4 git commands to generate.