]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
drop duplicate yasm check
[packages/libvpx.git] / libvpx.spec
index d70e1384088ece2b56a63ca3f58d852a2323ed07..02880f7cfd3147e5eb96691fe7b4743e83f5fb53 100644 (file)
@@ -1,25 +1,39 @@
 #
 # Conditional build:
 %bcond_without asm     # x86 assembler
+%bcond_without doc     # don't build doc
+%bcond_without ssse3   # use SSSE3 instructions (Intel since Core2, Via Nano)
+
+%ifnarch %{ix86} %{x8664}
+%undefine      with_asm
+%endif
+
+%if "%{pld_release}" == "ac"
+# not supported by compiler
+%undefine      with_ssse3
+%endif
 
 Summary:       VP8, a high-quality video codec
 Summary(pl.UTF-8):     VP8 - kodek obrazu wysokiej jakoĊ›ci
 Name:          libvpx
-Version:       1.2.0
+Version:       1.3.0
 Release:       1
 License:       BSD
 Group:         Libraries
-# Source0Download: http://code.google.com/p/webm/downloads/list
-Source0:       https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
-# Source0-md5: f8de058e6ba14555144583a2d031fe19
+#Source0Download: http://code.google.com/p/webm/downloads/list
+#Source0:      https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
+# source, but regenerated on each fetch
+#Source0:      https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
+Source0:       %{name}-%{version}.tar.gz
+# Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
 URL:           http://www.webmproject.org/
-BuildRequires: /usr/bin/php
 BuildRequires: doxygen
-BuildRequires: php-common >= 4:5.0.0
-BuildRequires: php-pcre
+BuildRequires: rpmbuild(macros) >= 1.673
 BuildRequires: sed >= 4.0
-%ifarch %{ix86} %{x8664}
 %{?with_asm:BuildRequires:     yasm >= 0.8}
+%if %{with doc}
+BuildRequires: %{php_name}-pcre
+BuildRequires: %{php_name}-program
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -69,7 +83,8 @@ Static libvpx library.
 Statyczna biblioteka libvpx.
 
 %prep
-%setup -q -n %{name}-v%{version}
+#%setup -q -n %{name}-v%{version}
+%setup -qc
 
 %build
 install -d obj
@@ -84,6 +99,7 @@ CFLAGS="%{rpmcflags} %{rpmcppflags}" \
 %if "%{vpxtarget}" != "%{generic_target}"
        --enable-shared \
 %endif
+       %{!?with_ssse3:--disable-ssse3} \
        --disable-optimizations \
        --enable-vp8 \
        --enable-postproc \
@@ -99,7 +115,10 @@ CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        CC="%{__cc}" \
        LD="%{__cc}" \
        LDFLAGS="%{rpmldflags} -L."
+
+%if %{with doc}
 %{__make} verbose=true target=docs
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -109,7 +128,7 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
        LIBSUBDIR=%{_lib} \
        DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
 
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.2
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
 
 # adjust prefix and libdir
 %{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
@@ -124,6 +143,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGELOG LICENSE PATENTS README
 %attr(755,root,root) %{_bindir}/vp8_scalable_patterns
+%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder
 %attr(755,root,root) %{_bindir}/vpxdec
 %attr(755,root,root) %{_bindir}/vpxenc
 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
This page took 0.135296 seconds and 4 git commands to generate.