]> git.pld-linux.org Git - packages/libvpx.git/blame_incremental - libvpx.spec
- updated to 1.6.0 (note: new soname)
[packages/libvpx.git] / libvpx.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without asm # x86 assembler
4%bcond_without doc # don't build doc
5%bcond_with tests # build tests (not useful, creates libgtest.a)
6%bcond_without ssse3 # use SSSE3 instructions (Intel since Core2, Via Nano)
7
8%ifnarch %{ix86} %{x8664} x32
9%undefine with_asm
10%endif
11
12%if "%{pld_release}" == "ac"
13# not supported by compiler
14%undefine with_ssse3
15%endif
16
17Summary: VP8, a high-quality video codec
18Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
19Name: libvpx
20Version: 1.6.0
21Release: 1
22License: BSD
23Group: Libraries
24#Source0Download: http://downloads.webmproject.org/releases/webm/index.html
25Source0: https://storage.googleapis.com/downloads.webmproject.org/releases/webm/%{name}-%{version}.tar.bz2
26# Source0-md5: f95a176768a0e1bb4fe42742e27a41af
27URL: http://www.webmproject.org/
28BuildRequires: doxygen
29%{?with_tests:BuildRequires: libstdc++-devel}
30BuildRequires: pkgconfig
31BuildRequires: rpmbuild(macros) >= 1.673
32BuildRequires: sed >= 4.0
33%{?with_asm:BuildRequires: yasm >= 0.8}
34%if %{with doc}
35BuildRequires: %{php_name}-pcre
36BuildRequires: %{php_name}-program
37%endif
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define generic_target generic-gnu
41%define vpxtarget %{generic_target}
42%ifarch %{x8664}
43%define vpxtarget x86_64-linux-gcc
44%endif
45%ifarch %{ix86}
46%define vpxtarget x86-linux-gcc
47%endif
48%ifarch ppc
49%define vpxtarget ppc32-linux-gcc
50%endif
51%ifarch ppc64
52%define vpxtarget ppc64-linux-gcc
53%endif
54
55%description
56VP8, a high-quality video codec.
57
58%description -l pl.UTF-8
59VP8 - kodek obrazu wysokiej jakości.
60
61%package devel
62Summary: Header files for libvpx
63Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description devel
68Header files for libvpx library.
69
70%description devel -l pl.UTF-8
71Pliki nagłówkowe biblioteki libvpx.
72
73%package static
74Summary: Static libvpx library
75Summary(pl.UTF-8): Statyczna biblioteka libvpx
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78
79%description static
80Static libvpx library.
81
82%description static -l pl.UTF-8
83Statyczna biblioteka libvpx.
84
85%prep
86%setup -q
87
88%build
89install -d obj
90cd obj
91# not autoconf configure
92CC="%{__cc}" \
93CXX="%{__cxx}" \
94CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
95../configure \
96%if %{with asm}
97 --as=yasm \
98%endif
99 --target=%{vpxtarget} \
100 --enable-shared \
101 %{!?with_ssse3:--disable-ssse3} \
102 --disable-optimizations \
103 --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
104 --%{!?with_doc:dis}%{?with_doc:en}able-docs \
105 --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
106 --enable-vp8 \
107 --enable-vp8 \
108 --enable-postproc \
109 --enable-runtime-cpu-detect
110
111%{__make} verbose=true target=libs \
112 HAVE_GNU_STRIP=no \
113 LDFLAGS="%{rpmldflags}"
114
115%{__make} verbose=true target=examples \
116 LDFLAGS="%{rpmldflags} -L."
117
118%if %{with doc}
119%{__make} verbose=true target=docs
120%endif
121
122%install
123rm -rf $RPM_BUILD_ROOT
124install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
125
126%{__make} -C obj verbose=true install \
127 LIBSUBDIR=%{_lib} \
128 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
129
130%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.4.0
131
132# adjust prefix and libdir
133%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%post -p /sbin/ldconfig
139%postun -p /sbin/ldconfig
140
141%files
142%defattr(644,root,root,755)
143%doc AUTHORS CHANGELOG LICENSE PATENTS README
144%attr(755,root,root) %{_bindir}/vpxdec
145%attr(755,root,root) %{_bindir}/vpxenc
146%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
147%attr(755,root,root) %ghost %{_libdir}/libvpx.so.4
148
149%files devel
150%defattr(644,root,root,755)
151%attr(755,root,root) %{_libdir}/libvpx.so
152%{_includedir}/vpx
153%{_pkgconfigdir}/vpx.pc
154
155%files static
156%defattr(644,root,root,755)
157%{_libdir}/libvpx.a
This page took 0.02637 seconds and 4 git commands to generate.