]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
- drop broken manual shared linking and --enable-shared
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930
JB
3%bcond_without asm # x86 assembler
4#
bccc9f86 5Summary: VP8, a high-quality video codec
d5d82930 6Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 7Name: libvpx
946a004e 8Version: 0.9.5
6c7c0f8b 9Release: 2
bccc9f86
AM
10License: BSD
11Group: Libraries
d5d82930 12#Source0-Download: http://code.google.com/p/webm/downloads/list
34eceac6 13Source0: http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
946a004e 14# Source0-md5: 4bf2f2c76700202c1fe9201fcb0680e3
5cb65362 15Source1: %{name}.ver
0257ab6e 16Patch0: %{name}-0.9.0-no-explicit-dep-on-static-lib.patch
bccc9f86 17URL: http://www.webmproject.org/
13542557 18BuildRequires: /usr/bin/php
a28e5963 19BuildRequires: doxygen
47f853c3 20BuildRequires: php-common >= 4:5.0.0
13542557 21BuildRequires: php-pcre
d5d82930 22%ifarch %{ix86} %{x8664}
7b991969 23%{?with_asm:BuildRequires: yasm}
d5d82930 24%endif
bccc9f86
AM
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28VP8, a high-quality video codec.
29
d5d82930
JB
30%description -l pl.UTF-8
31VP8 - kodek obrazu wysokiej jakości.
32
bccc9f86 33%package devel
d5d82930
JB
34Summary: Header files for libvpx
35Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 36Group: Development/Libraries
d5d82930 37Requires: %{name} = %{version}-%{release}
bccc9f86
AM
38
39%description devel
d5d82930
JB
40Header files for libvpx library.
41
42%description devel -l pl.UTF-8
43Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
44
45%package static
46Summary: Static libvpx library
d5d82930 47Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 48Group: Development/Libraries
d5d82930 49Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
50
51%description static
52Static libvpx library.
53
d5d82930
JB
54%description static -l pl.UTF-8
55Statyczna biblioteka libvpx.
56
bccc9f86 57%prep
946a004e 58%setup -q -n %{name}-v%{version}
0257ab6e 59%patch0 -p1
bccc9f86
AM
60
61%build
d5d82930
JB
62install -d obj
63cd obj
bccc9f86 64# not autoconf configure
d5d82930 65CFLAGS="%{rpmcflags} %{rpmcppflags}" \
bccc9f86 66../configure \
7b991969 67%if %{with asm}
bccc9f86
AM
68%ifarch %{x8664}
69 --target=x86_64-linux-gcc \
70%endif
71%ifarch %{ix86}
72 --target=x86-linux-gcc \
7b991969
AM
73%endif
74%else
75 --target=generic-gnu \
bccc9f86 76%endif
6c7c0f8b 77 --enable-shared \
0257ab6e 78 --disable-optimizations \
bccc9f86
AM
79 --enable-vp8 \
80 --enable-postproc \
81 --enable-runtime-cpu-detect
0257ab6e 82
d5d82930 83# disable stripping
7b991969 84sed -i "s|STRIP=.*|STRIP=|g" {libs,examples,docs}-*.mk
0257ab6e
AM
85
86%{__make} verbose=true target=libs \
6c7c0f8b
JP
87 CC="%{__cc}" \
88 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
89
90%{__make} verbose=true target=examples \
6c7c0f8b
JP
91 CC="%{__cc}" \
92 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
93%{__make} verbose=true target=docs
94
bccc9f86
AM
95%install
96rm -rf $RPM_BUILD_ROOT
464fefd2 97install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e
AM
98
99install -d outdir
6c7c0f8b 100%{__make} -C obj verbose=true install \
0257ab6e
AM
101 DIST_DIR=$(pwd)/outdir
102
c9ee805b 103install -p outdir/bin/* $RPM_BUILD_ROOT%{_bindir}
d5d82930 104install -p obj/libvpx.so.* $RPM_BUILD_ROOT%{_libdir}
6c7c0f8b
JP
105ln -s libvpx.so.0.9.5 $RPM_BUILD_ROOT%{_libdir}/libvpx.so.0
106ln -s libvpx.so.0.9.5 $RPM_BUILD_ROOT%{_libdir}/libvpx.so
0257ab6e 107
ac10c7c7 108cp -a outdir/include/vpx/*.h $RPM_BUILD_ROOT%{_includedir}/vpx
c9ee805b 109cp -a outdir/lib/*.a $RPM_BUILD_ROOT%{_libdir}
bccc9f86
AM
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
d5d82930
JB
119%doc AUTHORS CHANGELOG LICENSE PATENTS README
120%attr(755,root,root) %{_bindir}/vpxdec
121%attr(755,root,root) %{_bindir}/vpxenc
47f853c3 122%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
0257ab6e 123%attr(755,root,root) %ghost %{_libdir}/libvpx.so.0
bccc9f86
AM
124
125%files devel
126%defattr(644,root,root,755)
47f853c3 127%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 128%{_includedir}/vpx
bccc9f86
AM
129
130%files static
131%defattr(644,root,root,755)
0257ab6e 132%{_libdir}/libvpx.a
This page took 0.052076 seconds and 4 git commands to generate.