]> git.pld-linux.org Git - packages/libmemcached.git/blobdiff - libmemcached.spec
Release 9 (by relup.sh)
[packages/libmemcached.git] / libmemcached.spec
index a6f84b955c927b552686d69d03e013a9ac311c32..209ec485659935128294fc12dca39ebe32f87a69 100644 (file)
@@ -1,36 +1,38 @@
 #
+# TODO:
+# m4 macros from pandora-build (http://code.launchpad.net/pandora-build)
+#
 # Conditional build
 %bcond_without  static_libs    # don't build static library
-#
+
 Summary:       memcached client library
 Summary(pl.UTF-8):     Blblioteka kliencka memcached
 Name:          libmemcached
-Version:       0.49
-Release:       1
+Version:       1.0.18
+Release:       9
 License:       BSD
 Group:         Libraries
-Source0:       http://launchpad.net/libmemcached/1.0/%{version}/+download/%{name}-%{version}.tar.gz
-# Source0-md5: 95f2e182192934c0dd043eaecd8caa20
-URL:           http://libmemcached.org/
-BuildRequires: autoconf
-BuildRequires: automake
+Source0:       https://launchpad.net/libmemcached/1.0/%{version}/+download/%{name}-%{version}.tar.gz
+# Source0-md5: b3958716b4e53ddc5992e6c49d97e819
+Patch1:                pointer_comparison.patch
+URL:           https://libmemcached.org/
 BuildRequires: cyrus-sasl-devel
 BuildRequires: libevent-devel
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
 BuildRequires: perl-tools-pod
+BuildRequires: sphinx-pdg
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 libmemcached is a C and C++ client library to the memcached server
-(http://danga.com/memcached). It has been designed to be light on
-memory usage, thread safe, and provide full access to server side
+(http://memcached.org/). It has been designed to be light on memory
+usage, thread safe, and provide full access to server side
 methods.
 
 %description -l pl.UTF-8
 libmemcached to biblioteka kliencka serwera memcached
-(http://danga.com/memcached) dla języków C/C++. Została zaprojektowana
-myślą o niewielkim zużyciu pamięci, bezpieczeństwe i pełnym dostępie
+(http://memcached.org/) dla języków C/C++. Została zaprojektowana z
+myślą o niewielkim zużyciu pamięci, bezpieczeństwe i pełnym dostępie
 do metod po stronie serwera.
 
 %package devel
@@ -61,17 +63,18 @@ Statyczna biblioteka memcached.
 %prep
 %setup -q
 
+%patch1 -p1
+
 %build
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
 %configure \
-       LIBS="-lrt -lsasl" \
-       %{?with_static_libs:--enable-static} \
+       PTHREAD_CFLAGS="-pthread" \
+       PTHREAD_LIBS="-lpthread" \
+       --enable-dtrace \
+       --enable-libmemcachedprotocol \
        --disable-silent-rules \
-       --with-memcached=no # disable memcached detection, we're not doing tests
+       %{?with_static_libs:--enable-static} \
+       --without-memcached # disable memcached detection, we're not doing tests
+
 %{__make}
 
 %install
@@ -89,25 +92,27 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README THANKS TODO
-%attr(755,root,root) %{_bindir}/memaslap
 %attr(755,root,root) %{_bindir}/memcapable
 %attr(755,root,root) %{_bindir}/memcat
 %attr(755,root,root) %{_bindir}/memcp
 %attr(755,root,root) %{_bindir}/memdump
 %attr(755,root,root) %{_bindir}/memerror
+%attr(755,root,root) %{_bindir}/memexist
 %attr(755,root,root) %{_bindir}/memflush
 %attr(755,root,root) %{_bindir}/memparse
+%attr(755,root,root) %{_bindir}/memping
 %attr(755,root,root) %{_bindir}/memrm
 %attr(755,root,root) %{_bindir}/memslap
 %attr(755,root,root) %{_bindir}/memstat
+%attr(755,root,root) %{_bindir}/memtouch
 %attr(755,root,root) %{_libdir}/libhashkit.so.*.*.*
 %attr(755,root,root) %{_libdir}/libmemcached.so.*.*.*
 %attr(755,root,root) %{_libdir}/libmemcachedprotocol.so.*.*.*
 %attr(755,root,root) %{_libdir}/libmemcachedutil.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libhashkit.so.?
-%attr(755,root,root) %ghost %{_libdir}/libmemcached.so.?
-%attr(755,root,root) %ghost %{_libdir}/libmemcachedprotocol.so.?
-%attr(755,root,root) %ghost %{_libdir}/libmemcachedutil.so.?
+%attr(755,root,root) %ghost %{_libdir}/libhashkit.so.2
+%attr(755,root,root) %ghost %{_libdir}/libmemcached.so.11
+%attr(755,root,root) %ghost %{_libdir}/libmemcachedprotocol.so.0
+%attr(755,root,root) %ghost %{_libdir}/libmemcachedutil.so.2
 %{_mandir}/man1/mem*.1*
 
 %files devel
@@ -121,9 +126,17 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libmemcachedprotocol.la
 %{_libdir}/libmemcachedutil.la
 %{_includedir}/libhashkit
+%{_includedir}/libhashkit-1.0
 %{_includedir}/libmemcached
+%{_includedir}/libmemcached-1.0
+%{_includedir}/libmemcachedprotocol-0.0
+%{_includedir}/libmemcachedutil-1.0
 %{_pkgconfigdir}/libmemcached.pc
-%{_mandir}/man3/*.3*
+%{_aclocaldir}/ax_libmemcached.m4
+%{_mandir}/man3/hashkit_*.3*
+%{_mandir}/man3/libhashkit.3*
+%{_mandir}/man3/libmemcached*.3*
+%{_mandir}/man3/memcached*.3*
 
 %if %{with static_libs}
 %files static
This page took 0.120574 seconds and 4 git commands to generate.