]> git.pld-linux.org Git - packages/libgusb.git/blame - libgusb.spec
- updated to 0.2.0
[packages/libgusb.git] / libgusb.spec
CommitLineData
b8f9753f
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
0c72b7a8 4%bcond_without vala # Vala API
b8f9753f
JB
5#
6Summary: GUsb - GObject wrapper for libusb1 library
7Summary(pl.UTF-8): GUsb - obudowanie GObject biblioteki libusb1
8Name: libgusb
73aece39 9Version: 0.2.0
7ba4ab3e 10Release: 1
b8f9753f
JB
11License: LGPL v2.1+
12Group: Libraries
13Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
73aece39 14# Source0-md5: ce38ec3885713af0c06d110997fb3789
b8f9753f
JB
15BuildRequires: autoconf >= 2.63
16BuildRequires: automake >= 1:1.11
17BuildRequires: gtk-doc >= 1.9
73aece39 18BuildRequires: glib2-devel >= 1:2.32.0
0c72b7a8 19BuildRequires: gobject-introspection-devel >= 1.29
b8f9753f 20BuildRequires: libtool >= 2:2.2
73aece39 21BuildRequires: libusb-devel >= 1.0.19
b8f9753f
JB
22BuildRequires: pkgconfig
23BuildRequires: tar >= 1:1.22
0c72b7a8 24%{?with_vala:BuildRequires: vala >= 2:0.16}
b8f9753f 25BuildRequires: xz
73aece39
JB
26Requires: glib2 >= 1:2.32.0
27Requires: libusb >= 1.0.19
b8f9753f
JB
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31GUsb is a GObject wrapper for libusb1 that makes it easy to do
32asynchronous control, bulk and interrupt transfers with proper
33cancellation and integration into a mainloop. This makes it easy to
34integrate low level USB transfers with your high-level application or
35system daemon.
36
37%description -l pl.UTF-8
38GUsb to obudowanie GObject biblioteki libusb1, ułatwiające
39asynchroniczne sterowanie oraz przesyłanie danych (typu bulk jak i
40z użyciem przerwań) z właściwym przerywaniem i integracją w głównej
41pętli. Ułatwia to integrowanie niskopoziomowego przesyłania danych po
42USB w wysokopoziomowej aplikacji lub demonie systemowym.
43
44%package devel
45Summary: Header files for GUsb library
46Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GUsb
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
73aece39
JB
49Requires: glib2-devel >= 1:2.32.0
50Requires: libusb-devel >= 1.0.19
b8f9753f
JB
51
52%description devel
53Header files for GUsb library.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe biblioteki GUsb.
57
58%package static
59Summary: Static GUsb library
60Summary(pl.UTF-8): Statyczna biblioteka GUsb
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65Static GUsb library.
66
67%description static -l pl.UTF-8
68Statyczna biblioteka GUsb.
69
70%package apidocs
71Summary: GUsb API documentation
72Summary(pl.UTF-8): Dokumentacja API biblioteki GUsb
73Group: Documentation
74
75%description apidocs
76API and internal documentation for GUsb library.
77
78%description apidocs -l pl.UTF-8
79Dokumentacja API biblioteki GUsb.
80
0c72b7a8
JB
81%package -n vala-libgusb
82Summary: Vala API for libgusb
83Summary(pl.UTF-8): API języka Vala do libgusb
84Group: Development/Libraries
85Requires: %{name}-devel = %{version}-%{release}
86Requires: vala >= 2:0.16
87
88%description -n vala-libgusb
89Vala API for libgusb.
90
91%description -n vala-libgusb -l pl.UTF-8
92API języka Vala do libgusb.
93
b8f9753f
JB
94%prep
95%setup -q
b8f9753f
JB
96
97%build
98%{__libtoolize}
99%{__aclocal}
100%{__autoconf}
101%{__autoheader}
102%{__automake}
103%configure \
104 --disable-silent-rules \
0c72b7a8 105 %{!?with_vala:--disable-vala} \
b8f9753f
JB
106 --with-html-dir=%{_gtkdocdir}
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
115# obsoleted by pkg-config
116%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgusb.la
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(644,root,root,755)
126%doc AUTHORS MAINTAINERS NEWS README TODO
127%attr(755,root,root) %{_libdir}/libgusb.so.*.*.*
128%attr(755,root,root) %ghost %{_libdir}/libgusb.so.2
0c72b7a8 129%{_libdir}/girepository-1.0/GUsb-1.0.typelib
b8f9753f
JB
130
131%files devel
132%defattr(644,root,root,755)
133%attr(755,root,root) %{_libdir}/libgusb.so
134%{_includedir}/gusb-1
0c72b7a8 135%{_datadir}/gir-1.0/GUsb-1.0.gir
b8f9753f
JB
136%{_pkgconfigdir}/gusb.pc
137
138%files static
139%defattr(644,root,root,755)
140%{_libdir}/libgusb.a
141
142%if %{with apidocs}
143%files apidocs
144%defattr(644,root,root,755)
145%{_gtkdocdir}/gusb
146%endif
0c72b7a8
JB
147
148%if %{with vala}
149%files -n vala-libgusb
150%defattr(644,root,root,755)
151%{_datadir}/vala/vapi/gusb.vapi
152%endif
This page took 0.163498 seconds and 4 git commands to generate.