]> git.pld-linux.org Git - packages/libgltf.git/blame - libgltf.spec
- rel 2
[packages/libgltf.git] / libgltf.spec
CommitLineData
bf774e2f
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
5Summary: C++ library for rendering OpenGL models stored in glTF format
6Summary(pl.UTF-8): Biblioteka C++ do renderowania modeli OpenGL zapisanych w formacie glTF
7Name: libgltf
0d7734b8 8Version: 0.1.0
268b659d 9Release: 2
bf774e2f
JB
10License: MPL v2.0
11Group: Libraries
0d7734b8
AM
12Source0: http://dev-www.libreoffice.org/src/libgltf/%{name}-%{version}.tar.gz
13# Source0-md5: 63ae962d0c436909979826fce0fca2fd
bf774e2f
JB
14URL: http://www.libreoffice.org/
15BuildRequires: GLM >= 0.9.0.0
16BuildRequires: OpenGL-devel >= 3.0
17BuildRequires: boost-devel >= 1.41.0
e2b39568 18BuildRequires: libepoxy-devel >= 1.3.1
bf774e2f
JB
19BuildRequires: libstdc++-devel
20BuildRequires: pkgconfig >= 1:0.20
21Requires: OpenGL >= 3.0
e2b39568 22Requires: libepoxy >= 1.3.1
bf774e2f
JB
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26libgltf is a C++ library for rendering OpenGL models stored in glTF
27format.
28
29The glTF, the GL Transmission Format, is the runtime asset format for
30the GL APIs: WebGL, OpenGL ES, and OpenGL. glTF bridges the gap
31between formats used by modeling tools and the GL APIs. You can read
32more about the format in it's specification:
33https://github.com/KhronosGroup/glTF/blob/schema/specification/README.md
34
35libgltf provides methods to load the OpenGL scene from glTF format and
36render it into an existing OpenGL context. libgltf also allows to
37change the camera position so the scene can be displayed from
38different points of view.
39
40Summary, libgltf can be a good base of a glTF viewer.
41
42%description -l pl.UTF-8
43libgltf to biblioteka C++ do renderowania modeli OpenGL zapisanych w
44formacie glTF.
45
46glTF (GL Transmission Format - format transmisyjny GL) to format
47danych uruchomieniowych dla API GL: WebGL, OpenGL ES oraz OpenGL. glTF
48wypełnia lukę między formatami używanymi przez narzędzia modelujące
49oraz API GL. Więcej o formacie można znaleźć w specyfikacji:
50https://github.com/KhronosGroup/glTF/blob/schema/specification/README.md
51
52libgltf udostępnia metody do wczytywania sceny OpenGL z formatu glTF
53oraz renderowania jej w istniejącym kontekście OpenGL. Pozwala także
54zmieniać położenie kamery, dzięki czemu scena może być wyświetlana z
55innych punktów widzenia.
56
57Podsumowując, libgltf może być dobrą podstawą dla przeglądarki glTF.
58
59%package devel
60Summary: Header files for libgltf library
61Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libgltf
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
0f08141c 64Requires: GLM >= 0.9.0.0
e2b39568 65Requires: libepoxy-devel >= 1.3.1
bf774e2f
JB
66Requires: libstdc++-devel
67
68%description devel
69Header files for libgltf library.
70
71%description devel -l pl.UTF-8
72Pliki nagłówkowe biblioteki libgltf.
73
74%package static
75Summary: Static libgltf library
76Summary(pl.UTF-8): Statyczna biblioteka libgltf
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79
80%description static
81Static libgltf library.
82
83%description static -l pl.UTF-8
84Statyczna biblioteka libgltf.
85
86%prep
87%setup -q
88
89%build
90%configure \
91 --disable-silent-rules \
92 %{?with_static_libs:--enable-static}
93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98%{__make} install \
99 DESTDIR=$RPM_BUILD_ROOT
100
101# obsoleted by pkg-config
102%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgltf-*.la
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
112%doc AUTHORS ChangeLog LICENSE NEWS README
0d7734b8
AM
113%attr(755,root,root) %{_libdir}/libgltf-0.1.so.*.*.*
114%attr(755,root,root) %ghost %{_libdir}/libgltf-0.1.so.1
bf774e2f
JB
115
116%files devel
117%defattr(644,root,root,755)
0d7734b8
AM
118%attr(755,root,root) %{_libdir}/libgltf-0.1.so
119%{_includedir}/libgltf-0.1
120%{_pkgconfigdir}/libgltf-0.1.pc
bf774e2f
JB
121
122%if %{with static_libs}
123%files static
124%defattr(644,root,root,755)
0d7734b8 125%{_libdir}/libgltf-0.1.a
bf774e2f 126%endif
This page took 0.075469 seconds and 4 git commands to generate.