]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- updated to 0.9.2
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
98d72535
JB
7Summary: Library for high-performing platform-independent programs
8Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 9Name: libfilezilla
02115c6c 10Version: 0.9.2
fdec25bb
WF
11Release: 1
12License: GPL v2
13Group: Libraries
defa0a72 14Source0: http://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
02115c6c
WF
15# Source0-md5: d52a0e7229efb3c9fafc8a2b649d665d
16Patch0: cppunit-pkgconfig.patch
fdec25bb 17URL: http://lib.filezilla-project.org/
98d72535
JB
18%{?with_tests:BuildRequires: cppunit-devel >= 1.10.2}
19%{?with_apidocs:BuildRequires: doxygen}
20%if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
21BuildRequires: glibc-localedb-all
22%endif
02115c6c
WF
23BuildRequires: autoconf >= 2.50
24BuildRequires: automake
25BuildRequires: libtool >= 2:2
26BuildRequires: pkgconfig >= 1:0.7
98d72535
JB
27# -std=c++14
28BuildRequires: libstdc++-devel >= 6:5
fdec25bb
WF
29BuildRequires: rpmbuild(macros) >= 1.583
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33libfilezilla is a free, open source C++ library, offering some basic
34functionality to build high-performing, platform-independent programs.
35Some of the highlights include:
36
37- A typesafe, multi-threaded event system that's very simple to use
38 yet extremely efficient
39- Timers for periodic events
40- A datetime class that not only tracks timestamp but also their
41 accuracy, which simplifies dealing with timestamps originating from
42 different sources
43- Simple process handling for spawning child processes with redirected
44 I/O
45
98d72535
JB
46%description -l pl.UTF-8
47libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
48oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
49programów niezależnych od platformy. Uwzględnione funkcje obejmują:
50- bezpieczny pod względem typów, wielowątkowy system zdarzeń -
51 bardzo prosty w użyciu, a jednocześnie bardzo wydajny
52- zegary do zdarzeń regularnych
53- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
54 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
55 różnych źródeł
56- prostą obsługę procesów do tworzenia procesów potomnych z
57 przekierowanym wejściem/wyjściem
fdec25bb
WF
58
59%package devel
98d72535
JB
60Summary: Header files for libfilezilla library
61Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
98d72535 64Requires: libstdc++-devel >= 6:5
fdec25bb
WF
65
66%description devel
98d72535 67Header files for libfilezilla library.
fdec25bb
WF
68
69%description devel -l pl.UTF-8
98d72535 70Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
71
72%package static
98d72535
JB
73Summary: Static libfilezilla library
74Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
75Group: Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77
78%description static
98d72535 79Static libfilezilla library.
fdec25bb
WF
80
81%description static -l pl.UTF-8
98d72535 82Statyczna biblioteka libfilezilla.
fdec25bb
WF
83
84%package apidocs
85Summary: %{name} API documentation
86Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
87Group: Documentation
88
89%description apidocs
90API documentation for %{name} library.
91
92%description apidocs -l pl.UTF-8
93Dokumentacja API biblioteki %{name}.
94
95%prep
96%setup -q
02115c6c 97%patch0 -p1
fdec25bb
WF
98
99%build
02115c6c
WF
100%{__libtoolize}
101%{__aclocal} -I m4
102%{__autoconf}
103%{__autoheader}
104%{__automake}
fdec25bb
WF
105%configure \
106 %{!?with_static_libs:--disable-static}
107%{__make}
108
98d72535
JB
109%if %{with tests}
110# wide char conversion test fails with plain C locale
111LC_ALL=C.UTF-8 \
112%{__make} check
113%endif
114
115%if %{with apidocs}
116%{__make} -C doc html
117%endif
118
fdec25bb
WF
119%install
120rm -rf $RPM_BUILD_ROOT
121
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT
124
125%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131%postun -p /sbin/ldconfig
132
133%files
134%defattr(644,root,root,755)
98d72535
JB
135%doc AUTHORS ChangeLog NEWS README
136%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
137%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
fdec25bb
WF
138
139%files devel
140%defattr(644,root,root,755)
98d72535
JB
141%attr(755,root,root) %{_libdir}/libfilezilla.so
142%{_includedir}/libfilezilla
143%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
144
145%if %{with static_libs}
146%files static
147%defattr(644,root,root,755)
98d72535 148%{_libdir}/libfilezilla.a
fdec25bb
WF
149%endif
150
98d72535 151%if %{with apidocs}
fdec25bb
WF
152%files apidocs
153%defattr(644,root,root,755)
98d72535 154%doc doc/doxygen-doc/html/*
fdec25bb 155%endif
This page took 0.087681 seconds and 4 git commands to generate.