]> git.pld-linux.org Git - packages/lemon.git/blame - lemon.spec
- updated to 1.3.1 (note: new soname; build system changed to cmake)
[packages/lemon.git] / lemon.spec
CommitLineData
8367cb3b 1# TODO: coin support
b2972915
JB
2#
3# Conditional build:
96826377 4%bcond_with cplex # CPLEX support [IBM proprietary]
b2972915 5%bcond_without glpk # GLPK support
8367cb3b 6%bcond_with soplex # SoPlex support
b2972915
JB
7#
8Summary: Library of Efficient Models and Optimization in Networks
9Summary(pl.UTF-8): Biblioteka wydajnych modeli i optymalizacji w sieciach
10Name: lemon
d4a4dbb6 11Version: 1.3.1
b2972915
JB
12Release: 1
13License: Boost v1.0
14Group: Libraries
15Source0: http://lemon.cs.elte.hu/pub/sources/%{name}-%{version}.tar.gz
d4a4dbb6 16# Source0-md5: e89f887559113b68657eca67cf3329b5
b2972915 17URL: http://lemon.cs.elte.hu/
d4a4dbb6 18BuildRequires: cmake >= 2.8
b2972915
JB
19BuildRequires: doxygen
20BuildRequires: ghostscript
21%{?with_glpk:BuildRequires: glpk-devel >= 4.33}
22BuildRequires: libstdc++-devel
b2972915 23BuildRequires: python
8367cb3b 24%{?with_soplex:BuildRequires: soplex-devel}
b2972915
JB
25%{?with_glpk:Requires: glpk >= 4.33}
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29LEMON stands for Library for Efficient Modeling and Optimization in
30Networks. It is a C++ template library providing efficient
31implementations of common data structures and algorithms with focus on
32combinatorial optimization tasks connected mainly with graphs and
33networks.
34
35%description -l pl.UTF-8
36LEMON to skrót od Library for Efficient Modeling and Optimization in
37Networks (biblioteka do wydajnego modelowania i optymalizacji w
38sieciach). Jest to biblioteka szablonów C++ udostępniająca wydajne
39implementacje popularnych struktur danych i algorytmów przeznaczonych
40do zadań optymalizacji kombinatorycznej, związanych głównie z grafami
41i sieciami.
42
43%package devel
44Summary: Header files for LEMON library
45Summary(pl.UTF-8): Pliki nagłówkowe biblioteki LEMON
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
b2972915 48Requires: libstdc++-devel
d4a4dbb6 49Obsoletes: lemon-static
b2972915
JB
50
51%description devel
52Header files for LEMON library.
53
54%description devel -l pl.UTF-8
55Pliki nagłówkowe biblioteki LEMON.
56
b2972915
JB
57%package apidocs
58Summary: LEMON API documentation
59Summary(pl.UTF-8): Dokumentacja API biblioteki LEMON
60Group: Documentation
61
62%description apidocs
63API documentation for LEMON library.
64
65%description apidocs -l pl.UTF-8
66Dokumentacja API biblioteki LEMON.
67
68%prep
69%setup -q
b2972915
JB
70
71%build
d4a4dbb6
JB
72install -d build
73cd build
74%cmake .. \
75 %{!?with_coin:-DLEMON_ENABLE_COIN=OFF} \
76 %{!?with_glpk:-DLEMON_ENABLE_GLPK=OFF} \
77 %{!?with_cplex:-DLEMON_ENABLE_ILOG=OFF} \
78 %{!?with_soplex:-DLEMON_ENABLE_SOPLEX=OFF}
b2972915
JB
79%{__make}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
d4a4dbb6 84%{__make} -C build install \
b2972915
JB
85 DESTDIR=$RPM_BUILD_ROOT
86
b2972915
JB
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%files
94%defattr(644,root,root,755)
95%doc AUTHORS LICENSE NEWS README
96%attr(755,root,root) %{_bindir}/dimacs-solver
97%attr(755,root,root) %{_bindir}/dimacs-to-lgf
98%attr(755,root,root) %{_bindir}/lemon-0.x-to-1.x.sh
99%attr(755,root,root) %{_bindir}/lgf-gen
d4a4dbb6 100%attr(755,root,root) %{_libdir}/libemon.so.%{version}
b2972915
JB
101
102%files devel
103%defattr(644,root,root,755)
104%attr(755,root,root) %{_libdir}/libemon.so
105%{_includedir}/lemon
106%{_pkgconfigdir}/lemon.pc
d4a4dbb6
JB
107%dir %{_datadir}/lemon
108%{_datadir}/lemon/cmake
b2972915
JB
109
110%files apidocs
111%defattr(644,root,root,755)
d4a4dbb6 112%{_docdir}/lemon
This page took 0.886599 seconds and 4 git commands to generate.