]> git.pld-linux.org Git - packages/kp5-kde-gtk-config.git/blobdiff - kp5-kde-gtk-config.spec
- updated to 5.27.11
[packages/kp5-kde-gtk-config.git] / kp5-kde-gtk-config.spec
index e9f01be048298acc1e2807d8a7934ce7b73327d5..54d5a8ad83d31088be45a716e3f43341647bf0e1 100644 (file)
@@ -1,19 +1,26 @@
-%define                kdeplasmaver    5.21.5
-%define                qtver           5.9.0
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.27.11
+%define                qtver           5.15.2
 %define                kpname          kde-gtk-config
 Summary:       GTK2 and GTK3 Configurator for KDE
 Name:          kp5-%{kpname}
-Version:       5.21.5
+Version:       5.27.11
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: 257f7ea856dd02bebd460bddfa75e170
+Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
+# Source0-md5: 1b83e41e34b91f06efff8f6c0b855043
 Patch0:                x32.patch
 %define                specflags       -I/usr/include/harfbuzz
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
-BuildRequires: cmake >= 2.8.12
+BuildRequires: cmake >= 3.16.0
+BuildRequires: gsettings-desktop-schemas
+BuildRequires: gsettings-desktop-schemas-devel
+BuildRequires: gtk+2-devel
+BuildRequires: gtk+3-devel
 BuildRequires: kf5-extra-cmake-modules >= 1.4.0
 BuildRequires: kf5-karchive-devel
 BuildRequires: kf5-kauth-devel
@@ -29,6 +36,7 @@ BuildRequires:        kf5-kio-devel
 BuildRequires: kf5-knewstuff-devel
 BuildRequires: kf5-knewstuff-devel
 BuildRequires: kf5-kxmlgui-devel
+BuildRequires: kp5-kdecoration-devel >= 5.23.0
 BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
@@ -44,13 +52,16 @@ GTK2 and GTK3 Configurator for KDE.
 #%%patch0 -p1
 
 %build
-install -d build
-cd build
-%cmake -G Ninja \
+%cmake -B build \
+       -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       -DHTML_INSTALL_DIR=%{_kdedocdir} \
-       ..
-%ninja_build
+       -DHTML_INSTALL_DIR=%{_kdedocdir}
+%ninja_build -C build
+
+%if %{with tests}
+ctest
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -74,3 +85,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libwindow-decorations-gtk-module.so
 %attr(755,root,root) %{_datadir}/kconf_update/remove_window_decorations_from_gtk_css.sh
 %{_datadir}/themes/Breeze/window_decorations.css
+%dir %{_datadir}/kcm-gtk-module
+%{_datadir}/kcm-gtk-module/preview.ui
+%attr(755,root,root) %{_libdir}/kconf_update_bin/remove_deprecated_gtk4_option
This page took 0.0830880000000001 seconds and 4 git commands to generate.