]> git.pld-linux.org Git - packages/kismet.git/blame - kismet.spec
Release 2 (by relup.sh)
[packages/kismet.git] / kismet.spec
CommitLineData
496b93f1 1%define tarver %(echo %{version} | tr _ -)
ce8d2811 2Summary: Wireless network sniffer
3197fdd7 3Summary(pl.UTF-8): Sniffer sieci bezprzewodowych
ce8d2811 4Name: kismet
d7f9660c 5Version: 2021_05_R1
3c687977 6Release: 2
ce8d2811
AM
7License: GPL
8Group: Networking/Utilities
4c554cef 9Source0: http://www.kismetwireless.net/code/%{name}-%{tarver}.tar.xz
d7f9660c 10# Source0-md5: df4cc90d5183b7fd45846a33bf598339
ce8d2811 11URL: http://www.kismetwireless.net/
58c65496
JB
12BuildRequires: autoconf
13BuildRequires: automake
412db6e5 14BuildRequires: bluez-libs-devel
7d77e3fc 15BuildRequires: gmp-devel
412db6e5 16BuildRequires: libcap-devel
399fadea 17BuildRequires: libnl-devel
387a2d36 18BuildRequires: libpcap-devel >= 2:0.9.4-1
6870d034 19BuildRequires: libstdc++-devel
8d802250 20BuildRequires: libwebsockets-devel >= 3.1.0
92c7dc22 21BuildRequires: ncurses-ext-devel
412db6e5 22BuildRequires: openssl-devel
23BuildRequires: pcre-devel
9cf4f36b 24BuildRequires: pkgconfig
496b93f1 25BuildRequires: sed >= 4.0
8d802250
JR
26Requires(postun): /usr/sbin/groupdel
27Requires(pre): /usr/sbin/groupadd
28Provides: group(kismet)
29Obsoletes: kismet-server < 2021_05_R1
58c65496
JB
30# it uses internal structures - so strict deps
31%requires_eq libpcap
472ae821 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ce8d2811 33
d7f9660c 34%define plugins plugin-alertsyslog plugin-dashboard
89d87381 35
ce8d2811
AM
36%description
37Kismet is a 802.11b wireless network sniffer. It is capable of
38sniffing using almost any wireless card supported in Linux, including
39Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
40Rangelan, etc), cards which support standard packet capture via
41libpcap (Cisco), and limited support for cards without RF Monitor
42support.
43
280f6f5a 44%description -l pl.UTF-8
ce8d2811 45Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
280f6f5a
JR
46sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
47w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
48(Linksys, Dlink, Rangelan, etc), kart które umożliwiają
49przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
50wsparcie dla kart bez obsługi Monitora RF.
ce8d2811
AM
51
52%prep
496b93f1 53%setup -q -n %{name}-%{tarver}
ce8d2811 54
496b93f1
ER
55# make lib64 aware, include exec bits on install
56%{__sed} -i -e 's!\$(prefix)/lib/!%_libdir/!g' plugin-*/Makefile
57%{__sed} -i -e '/install/ s!-m644!-m755!' plugin-*/Makefile
58
59# make %doc friendly
60for a in plugin-*/README; do
61 mv $a README.${a%/README}
62done
a824f1d9 63
69914467
JB
64%build
65cp -f /usr/share/automake/config.* .
2be18a10
SZ
66%{__aclocal}
67%{__autoconf}
496b93f1 68%configure
2be18a10 69
d7f9660c
JR
70# -j1 due to OOM
71%{__make} -j1
ce8d2811 72
89d87381 73for plugin in %plugins; do
496b93f1
ER
74 %{__make} -C $plugin \
75 KIS_SRC_DIR=$PWD
89d87381 76done
77
ce8d2811
AM
78%install
79rm -rf $RPM_BUILD_ROOT
1c58060a 80install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir},/var/log/%{name}}
496b93f1
ER
81for dir in . %plugins; do
82 %{__make} -C $dir install \
83 DESTDIR="$RPM_BUILD_ROOT" \
84 KIS_SRC_DIR=$PWD \
85 INSTUSR=%(id -un) \
86 INSTGRP=%(id -gn) \
d7f9660c 87 SUIDGROUP=%(id -gn) \
496b93f1 88 MANGRP=%(id -gn)
89d87381 89done
90
ce8d2811
AM
91%clean
92rm -rf $RPM_BUILD_ROOT
93
8d802250
JR
94%pre
95%groupadd -P %{name} -g 180 kismet
9128618d 96
8d802250 97%preun
9128618d
ER
98if [ "$1" = "0" ]; then
99 %groupremove kismet
100fi
101
8d802250
JR
102%triggerpostun -- kismet-server < 2021_05_R1
103%groupadd -P %{name} -g 180 kismet
9128618d 104
8d802250 105%files
9128618d 106%defattr(644,root,root,755)
8d802250 107%doc README.md README.plugin-alertsyslog README.plugin-dashboard
496b93f1 108%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet.conf
8d802250
JR
109%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_80211.conf
110%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_alerts.conf
111%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_filter.conf
112%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_httpd.conf
113%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_logging.conf
114%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_memory.conf
115%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_uav.conf
116%attr(755,root,root) %{_bindir}/kismet
117%attr(755,root,root) %{_bindir}/kismet_cap_freaklabs_zigbee
118%attr(755,root,root) %{_bindir}/kismet_cap_kismetdb
119%attr(755,root,root) %{_bindir}/kismet_cap_linux_bluetooth
120%attr(755,root,root) %{_bindir}/kismet_cap_linux_wifi
121%attr(755,root,root) %{_bindir}/kismet_cap_nrf_51822
122%attr(755,root,root) %{_bindir}/kismet_cap_nrf_52840
123%attr(755,root,root) %{_bindir}/kismet_cap_nrf_mousejack
124%attr(755,root,root) %{_bindir}/kismet_cap_nxp_kw41z
125%attr(755,root,root) %{_bindir}/kismet_cap_pcapfile
126%attr(755,root,root) %{_bindir}/kismet_cap_rz_killerbee
127%attr(755,root,root) %{_bindir}/kismet_cap_sdr_rtl433
128%attr(755,root,root) %{_bindir}/kismet_cap_sdr_rtladsb
129%attr(755,root,root) %{_bindir}/kismet_cap_sdr_rtlamr
130%attr(755,root,root) %{_bindir}/kismet_cap_ti_cc_2531
131%attr(755,root,root) %{_bindir}/kismet_cap_ti_cc_2540
132%attr(755,root,root) %{_bindir}/kismet_discovery
9128618d 133%attr(755,root,root) %{_bindir}/kismet_server
8d802250
JR
134%attr(755,root,root) %{_bindir}/kismetdb_clean
135%attr(755,root,root) %{_bindir}/kismetdb_dump_devices
136%attr(755,root,root) %{_bindir}/kismetdb_statistics
137%attr(755,root,root) %{_bindir}/kismetdb_strip_packets
138%attr(755,root,root) %{_bindir}/kismetdb_to_gpx
139%attr(755,root,root) %{_bindir}/kismetdb_to_kml
140%attr(755,root,root) %{_bindir}/kismetdb_to_pcap
141%attr(755,root,root) %{_bindir}/kismetdb_to_wiglecsv
142%{_datadir}/%{name}
496b93f1 143%dir %{_libdir}/kismet
8d802250
JR
144%dir %{_libdir}/kismet/alertsyslog
145%attr(755,root,root) %{_libdir}/kismet/alertsyslog/alertsyslog.so
146%{_libdir}/kismet/alertsyslog/manifest.conf
147%{_libdir}/kismet/dashboard
148%{py3_sitedir}/KismetCapture*
This page took 0.1225 seconds and 4 git commands to generate.