]> git.pld-linux.org Git - packages/kismet.git/blame - kismet.spec
- release 6: hacks, BR: bluez-libs and -ltinfo
[packages/kismet.git] / kismet.spec
CommitLineData
7d77e3fc 1#
c95f2c3c 2# TODO: Anybody knows, why it will not build,
7d77e3fc 3# when kernel-headers are installed?
4#
ce8d2811 5Summary: Wireless network sniffer
3197fdd7 6Summary(pl.UTF-8): Sniffer sieci bezprzewodowych
ce8d2811 7Name: kismet
72646fca 8Version: 2010_01_R1
9%define _ver 2010-01-R1
c0067f80 10Release: 6
ce8d2811
AM
11License: GPL
12Group: Networking/Utilities
b689f981 13Source0: http://www.kismetwireless.net/code/%{name}-%{_ver}.tar.gz
72646fca 14# Source0-md5: a6d6edcf65d5bb2cb5de6472bcc16f19
399fadea 15Patch0: %{name}-if_arp.patch
ce8d2811 16URL: http://www.kismetwireless.net/
58c65496
JB
17BuildRequires: autoconf
18BuildRequires: automake
412db6e5 19BuildRequires: bluez-libs-devel
7d77e3fc 20BuildRequires: gmp-devel
412db6e5 21BuildRequires: libcap-devel
399fadea 22BuildRequires: libnl-devel
387a2d36 23BuildRequires: libpcap-devel >= 2:0.9.4-1
6870d034 24BuildRequires: libstdc++-devel
92c7dc22 25BuildRequires: ncurses-ext-devel
412db6e5 26BuildRequires: openssl-devel
27BuildRequires: pcre-devel
9cf4f36b 28BuildRequires: pkgconfig
58c65496
JB
29# it uses internal structures - so strict deps
30%requires_eq libpcap
c0067f80 31# plugin-btscan.so, not detected automatically for whatever reason
32Requires: bluez-libs
472ae821 33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ce8d2811 34
89d87381 35%define plugins plugin-autowep plugin-btscan plugin-ptw plugin-spectools
36
ce8d2811
AM
37%description
38Kismet is a 802.11b wireless network sniffer. It is capable of
39sniffing using almost any wireless card supported in Linux, including
40Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
41Rangelan, etc), cards which support standard packet capture via
42libpcap (Cisco), and limited support for cards without RF Monitor
43support.
44
280f6f5a 45%description -l pl.UTF-8
ce8d2811 46Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
280f6f5a
JR
47sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
48w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
49(Linksys, Dlink, Rangelan, etc), kart które umożliwiają
50przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
51wsparcie dla kart bez obsługi Monitora RF.
ce8d2811
AM
52
53%prep
b689f981 54%setup -q -n %{name}-%{_ver}
399fadea 55%patch0 -p1
ce8d2811 56
db37893b 57sed -i -e 's#-o $(INSTUSR)##g' -e 's#-o $(INSTGRP)##g' Makefile.in
a824f1d9 58
69914467
JB
59%build
60cp -f /usr/share/automake/config.* .
2be18a10
SZ
61%{__aclocal}
62%{__autoconf}
58c65496 63CPPFLAGS="-I/usr/include/ncurses"
ce8d2811 64%configure \
58c65496 65 --enable-syspcap \
d5da126a 66 --with-linuxheaders=no \
1e0f374d 67 --with-ethereal=%{_includedir} \
ce8d2811 68%ifarch arm
1e0f374d 69 --enable-zaurus
ce8d2811 70%endif
2be18a10 71
c0067f80 72%{__make} \
73 CLIENTLIBS="-ldl -lncurses -lpanel -ltinfo" # hack to add -ltinfo
ce8d2811 74
89d87381 75for plugin in %plugins; do
76 sed -ie 's/install -o $(INSTUSR) -g $(INSTGRP)/install/' $plugin/Makefile
77 %{__make} KIS_SRC_DIR=$PWD -C $plugin;
78done
79
ce8d2811
AM
80%install
81rm -rf $RPM_BUILD_ROOT
ce8d2811
AM
82install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
83
84%{__make} install \
85 INSTGRP=$(id -g) \
86 MANGRP=$(id -g) \
87 prefix=$RPM_BUILD_ROOT%{_prefix} \
88 exec_prefix=$RPM_BUILD_ROOT%{_prefix} \
89 ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
90 BIN=$RPM_BUILD_ROOT%{_bindir} \
91 SHARE=$RPM_BUILD_ROOT%{_datadir}/%{name} \
92 MAN=$RPM_BUILD_ROOT%{_mandir}
a824f1d9 93
89d87381 94for plugin in %plugins; do
95 %{__make} KIS_SRC_DIR=$PWD -C $plugin install \
96 INSTGRP=$(id -g) \
97 MANGRP=$(id -g) \
98 prefix=$RPM_BUILD_ROOT%{_prefix} \
99 exec_prefix=$RPM_BUILD_ROOT%{_prefix} \
100 ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
101 BIN=$RPM_BUILD_ROOT%{_bindir} \
102 SHARE=$RPM_BUILD_ROOT%{_datadir}/%{name} \
103 MAN=$RPM_BUILD_ROOT%{_mandir}
104done
105
ce8d2811
AM
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%files
110%defattr(644,root,root,755)
72646fca 111%doc docs/* CHANGELOG README
ce8d2811
AM
112%attr(755,root,root) %{_bindir}/*
113%{_datadir}/%{name}
114%{_mandir}/man?/*
c95f2c3c 115%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}*
89d87381 116# FIXME: verify this path on x86_64, does Kismet search in lib64 or here?
117%attr(755,root,root) %{_prefix}/lib/kismet
118%attr(755,root,root) %{_prefix}/lib/kismet_client
This page took 0.056021 seconds and 4 git commands to generate.