]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel-virtio-gl-accel.patch
- 3.18.48 [EOL]
[packages/kernel.git] / kernel-virtio-gl-accel.patch
index fbd282acbb4c52d09edc3607cfc33629bce5bfad..d77015546294e9e5f7b488ba1a521c344ca0eba6 100644 (file)
@@ -4,8 +4,8 @@ index 30879df..35699a0 100644
 --- a/drivers/gpu/Makefile
 +++ b/drivers/gpu/Makefile
 @@ -1 +1 @@
--obj-y                 += drm/ vga/ stub/
-+obj-y                 += drm/ vga/ stub/ misc/
+-obj-y                 += drm/ vga/
++obj-y                 += drm/ vga/ misc/
 diff --git a/drivers/gpu/misc/Kconfig b/drivers/gpu/misc/Kconfig
 new file mode 100644
 index 0000000..50043d3
@@ -32,7 +32,7 @@ new file mode 100644
 index 0000000..8882bda
 --- /dev/null
 +++ b/drivers/gpu/misc/virtio-gl.c
-@@ -0,0 +1,312 @@
+@@ -0,0 +1,315 @@
 +/*
 + * Copyright (C) 2010 Intel Corporation
 + *
@@ -176,7 +176,10 @@ index 0000000..8882bda
 +      }
 +
 +      /* Transfer data */
-+      if (virtqueue_add_buf(vq, sg_list, o_page, i_page, (void *)1, GFP_ATOMIC) >= 0) {
++      struct scatterlist *sgs[2];
++      sgs[0] = &sg_list[0];
++      sgs[1] = &sg_list[1];
++      if (virtqueue_add_sgs(vq, sgs, o_page, i_page, (void *)1, GFP_ATOMIC) >= 0) {
 +              virtqueue_kick(vq);
 +              /* Chill out until it's done with the buffer. */
 +              while (!virtqueue_get_buf(vq, &count))
@@ -242,7 +245,7 @@ index 0000000..8882bda
 +      return 0;
 +}
 +
-+static int glmem_fsync(struct file *filp, int datasync)
++static int glmem_fsync(struct file *filp, loff_t unusued1, loff_t unused2, int datasync)
 +{
 +      struct virtio_gl_data *gldata = to_virtio_gl_data(filp);
 +
@@ -350,9 +353,9 @@ index 3d94a14..9a9a6cc 100644
 --- a/drivers/video/Kconfig
 +++ b/drivers/video/Kconfig
 @@ -16,6 +16,7 @@ source "drivers/char/agp/Kconfig"
- source "drivers/gpu/vga/Kconfig"
+ endmenu
  
- source "drivers/gpu/drm/Kconfig"
+ source "drivers/video/backlight/Kconfig"
 +source "drivers/gpu/misc/Kconfig"
  
  config VGASTATE
This page took 0.032452 seconds and 4 git commands to generate.