]> git.pld-linux.org Git - packages/kde4-umbrello.git/blame - kde4-umbrello.spec
- updated to 4.14.3 (by update-kde4.sh)
[packages/kde4-umbrello.git] / kde4-umbrello.spec
CommitLineData
d9521da7
WF
1#
2# TODO:
3# - add man files
4#
5%define orgname umbrello
6%define _state stable
7%define qtver 4.8.1
8
9Summary: UML Modeler
10Summary(pl.UTF-8): Modeler UML
11Name: kde4-%{orgname}
fc3e37f3 12Version: 4.14.3
d9521da7
WF
13Release: 1
14License: GPL
15Group: X11/Development/Tools
83c95344 16Source0: http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
fc3e37f3 17# Source0-md5: 15926874ff8ca38e58b853a7731d151a
d9521da7
WF
18URL: http://www.kde.org/
19BuildRequires: QtNetwork-devel >= %{qtver}
20BuildRequires: QtScriptTools-devel >= %{qtver}
21BuildRequires: automoc4 >= 0.9.88
22BuildRequires: boost-devel
23BuildRequires: bzip2-devel
24BuildRequires: cmake >= 2.8.0
25BuildRequires: db-devel
26BuildRequires: docbook-dtd42-xml
27BuildRequires: docbook-style-xsl
28BuildRequires: gettext-devel
29BuildRequires: hunspell-devel
30BuildRequires: kde4-kdebase-devel >= %{version}
31BuildRequires: kde4-kdepimlibs-devel >= %{version}
32BuildRequires: libxml2-devel
33BuildRequires: libxslt-devel
34BuildRequires: qca-devel >= 2.0.0
35BuildRequires: qt4-build >= %{qtver}
36BuildRequires: qt4-qmake >= %{qtver}
37BuildRequires: rpm-pythonprov
38BuildRequires: rpmbuild(macros) >= 1.600
39BuildRequires: shared-mime-info
40BuildRequires: utempter-devel
41BuildRequires: xorg-lib-libXpm-devel
42BuildRequires: xorg-lib-libXtst-devel
43Obsoletes: kde4-kdesdk-%{orgname}
44Obsoletes: umbrello
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
48Umbrello UML Modeller is a UML diagram tool that can support you in
49the software development process. Especially during the analysis and
50design phases of this process, Umbrello UML Modeller will help you to
51get a high quality product. UML can also be used to document your
52software designs to help you and your fellow developers.
53
54UML is the diagramming language used to describing such models. You
55can represent your ideas in UML using different types of diagrams.
56Umbrello UML Modeller 1.2 supports the following types:
57- class Diagram
58- sequence Diagram
59- collaboration Diagram
60- use Case Diagram
61- state Diagram
62- activity Diagram
63- component Diagram
64
65%description -l pl.UTF-8
66Modeler UML Umbrello to narzędzie do diagramów UML pomagające w
67procesie tworzenia oprogramowania. Szczególnie podczas etapów analizy
68i projektowania, modeler UML Umbrello może pomóc w uzyskaniu wysokiej
69jakości produktu. UML może być używany do dokumentowania projektu
70programu, aby pomóc programiście i jego współpracownikom.
71
72UML to język diagramów używany do opisu takich modeli. Można
73przedstawiać idee w UML-u przy użyciu różnych rodzajów diagramów.
74Modeler UML Umbrello 1.2 obsługuje następujące rodzaje:
75 - diagram klas
76 - diagram sekwencji
77 - diagram współpracy
78 - diagram przypadków użycia
79 - diagram stanów
80 - diagram aktywności
81 - diagram składników.
82
83%prep
84%setup -q -n %{orgname}-%{version}
85
86%build
87install -d build
88cd build
89%cmake \
90 ../
91
92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97install -d $RPM_BUILD_ROOT{%{_gimpdir}/palettes,%{_appdefsdir}}
98
99%{__make} -C build install \
100 DESTDIR=$RPM_BUILD_ROOT \
101 kde_htmldir=%{_kdedocdir}
102
103rm -rf $RPM_BUILD_ROOT%{_iconsdir}/locolor
104
105%find_lang %{orgname} --with-kde
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files -f %{orgname}.lang
111%defattr(644,root,root,755)
112%attr(755,root,root) %{_bindir}/umbrello
113%{_datadir}/apps/umbrello
114%{_desktopdir}/kde4/umbrello.desktop
115%{_iconsdir}/*/*x*/*/umbrello*.*
116%{_iconsdir}/*/*/mimetypes/application-x-uml.png
117%{_iconsdir}/hicolor/scalable/apps/umbrello.svgz
This page took 0.137776 seconds and 4 git commands to generate.