]> git.pld-linux.org Git - packages/ka5-konsole.git/blobdiff - ka5-konsole.spec
- updated to 23.08.5
[packages/ka5-konsole.git] / ka5-konsole.spec
index 0ea8a5adda51733063765fd179a4e754ed2a55e0..bc2afdc121f4b801b902d14d8ab52dbe906a5e7a 100644 (file)
@@ -1,21 +1,24 @@
-%define                kdeappsver      21.12.0
-%define                qtver           5.15.0
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeappsver      23.08.5
+%define                qtver           5.15.2
 %define                kf5ver          5.71.0
 %define                kaname          konsole
 Summary:       KDE Terminal Emulator
 Name:          ka5-%{kaname}
-Version:       21.12.0
-Release:       3
+Version:       23.08.5
+Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: cc980609c26e904029b652cf987ba452
+# Source0-md5: 7c7297f44101d0765c9d843fc99a44d6
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5DBus-devel >= %{qtver}
 BuildRequires: Qt5PrintSupport-devel >= %{qtver}
 BuildRequires: Qt5Widgets-devel >= %{qtver}
-BuildRequires: cmake >= 3.13
+BuildRequires: cmake >= 3.20
 BuildRequires: kf5-extra-cmake-modules >= %{kf5ver}
 BuildRequires: kf5-kbookmarks-devel >= %{kf5ver}
 BuildRequires: kf5-kconfig-devel >= %{kf5ver}
@@ -86,27 +89,35 @@ Konsole jest emulatorem terminala.
 
 Cechy
 
-• Karty • Wiele profili • Monitoring ciszy i aktywności • Zakładki •
-Szukanie • Zapisywanie danych wyjściowych
+• Karty • Wiele profili • Monitoring ciszy i aktywności •
+Zakładki • Szukanie • Zapisywanie danych wyjściowych
 
 %prep
 %setup -q -n %{kaname}-%{version}
 
 %build
-install -d build
-cd build
 %cmake \
+       -B build \
        -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DHTML_INSTALL_DIR=%{_kdedocdir} \
-       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       ..
-%ninja_build
+       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+%ninja_build -C build
+
+%if %{with tests}
+ctest --test-dir build
+%endif
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
 
 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{sr,zh_CN}
+
+# not supported by glibc yet
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
+
 %find_lang %{kaname} --all-name --with-kde
 
 %clean
@@ -117,7 +128,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{kaname}.lang
 %defattr(644,root,root,755)
-%defattr(644,root,root,755)
+/etc/xdg/konsolerc
 %attr(755,root,root) %{_bindir}/konsole
 %attr(755,root,root) %{_bindir}/konsoleprofile
 %ghost %{_libdir}/libkonsoleprivate.so.1
@@ -131,9 +142,15 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/org.kde.konsole.desktop
 %{_datadir}/knotifications5/konsole.notifyrc
 %{_datadir}/konsole
-%{_datadir}/kservices5/ServiceMenus/konsolerun.desktop
 %{_datadir}/kservices5/konsolepart.desktop
 %{_datadir}/kservicetypes5/terminalemulator.desktop
-%{_datadir}/khotkeys/konsole.khotkeys
 %{_datadir}/knsrcfiles/konsole.knsrc
 %{_datadir}/qlogging-categories5/konsole.categories
+%attr(755,root,root) %{_libdir}/qt5/plugins/konsoleplugins/konsole_quickcommandsplugin.so
+%{_datadir}/kio/servicemenus/konsolerun.desktop
+%attr(755,root,root)%{_libdir}/kconf_update_bin/konsole_globalaccel
+%attr(755,root,root)%{_libdir}/kconf_update_bin/konsole_show_menubar
+%{_datadir}/kconf_update/konsole.upd
+%attr(755,root,root)%{_datadir}/kconf_update/konsole_add_hamburgermenu_to_toolbar.sh
+%{zsh_compdir}/_konsole
+%{_datadir}/kglobalaccel/org.kde.konsole.desktop
This page took 0.261801 seconds and 4 git commands to generate.