]> git.pld-linux.org Git - packages/ka5-baloo-widgets.git/blobdiff - ka5-baloo-widgets.spec
- updated to 23.08.5
[packages/ka5-baloo-widgets.git] / ka5-baloo-widgets.spec
index c2eb303a61681d57fa5c8a1af26d873afe8b432a..71c8d631ceae9f00a884568682b31c91ee9cb125 100644 (file)
@@ -1,19 +1,32 @@
-%define                kdeappsver      17.08.2
-%define                qtver           5.3.2
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeappsver      23.08.5
+%define                kframever       5.94.0
+%define                qtver           5.15.2
 %define                kaname          baloo-widgets
-Summary:       A KDE Feed Reader
+Summary:       Baloo widgets
 Name:          ka5-%{kaname}
-Version:       17.08.2
+Version:       23.08.5
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: 5e485118ac64d7d25b048bfacbfdc937
+Source0:       https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
+# Source0-md5: e009be9182808f2f40ef9fb1edf6435d
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
-BuildRequires: cmake >= 2.8.12
-BuildRequires: kf5-baloo-devel
-BuildRequires: kf5-extra-cmake-modules >= 1.4.0
+BuildRequires: Qt5Gui-devel >= 5.11.1
+BuildRequires: Qt5Test-devel
+BuildRequires: Qt5Widgets-devel
+BuildRequires: cmake >= 3.20
+BuildRequires: gettext-devel
+BuildRequires: kf5-baloo-devel >= %{kframever}
+BuildRequires: kf5-extra-cmake-modules >= %{kframever}
+BuildRequires: kf5-kconfig-devel >= %{kframever}
+BuildRequires: kf5-kfilemetadata-devel >= %{kframever}
+BuildRequires: kf5-ki18n-devel >= %{kframever}
+BuildRequires: kf5-kio-devel >= %{kframever}
+BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: shared-mime-info
@@ -22,11 +35,14 @@ BuildRequires:      xz
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Baloo widgets.
+Widgets for Baloo.
+
+%description -l pl.UTF-8
+Widżety dla Baloo.
 
 %package devel
 Summary:       Header files for %{kaname} development
-Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kpname}
+Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kaname}
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -40,17 +56,22 @@ Pliki nagłówkowe dla programistów używających %{kaname}.
 %setup -q -n %{kaname}-%{version}
 
 %build
-install -d build
-cd build
 %cmake \
-       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       ..
-%{__make}
+       -B build \
+       -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
+       -DHTML_INSTALL_DIR=%{_kdedocdir} \
+       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+%ninja_build -C build
+
+%if %{with tests}
+ctest --test-dir build
+%endif
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{kaname} --all-name --with-kde
 
@@ -63,11 +84,14 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{kaname}.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/baloo_filemetadata_temp_extractor
-%attr(755,root,root) %ghost %{_libdir}/libKF5BalooWidgets.so.5
+%ghost %{_libdir}/libKF5BalooWidgets.so.5
 %attr(755,root,root) %{_libdir}/libKF5BalooWidgets.so.*.*.*
+%attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kfileitemaction/tagsfileitemaction.so
+%attr(755,root,root) %{_libdir}/qt5/plugins/kf5/propertiesdialog/baloofilepropertiesplugin.so
+%{_datadir}/qlogging-categories5/baloo-widgets.categories
 
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/KF5/BalooWidgets
 %{_libdir}/cmake/KF5BalooWidgets
-%attr(755,root,root) %{_libdir}/libKF5BalooWidgets.so
+%{_libdir}/libKF5BalooWidgets.so
This page took 0.076031 seconds and 4 git commands to generate.