]> git.pld-linux.org Git - packages/john.git/blobdiff - john.spec
- fixed bogus commitlog
[packages/john.git] / john.spec
index 327657ab4769562e95b47b13b4f18800eb0b0453..7165061ccebd02114faf3062aa5ed7005551aeb8 100644 (file)
--- a/john.spec
+++ b/john.spec
@@ -1,25 +1,30 @@
 #
 # Conditional build:
-# _with_mmx    - MMX optimization
+%bcond_with    mmx     # MMX optimization
 # Optimization must be chosen at compile time :(
 # Maybe some patch...? But not yet.
 #
 %ifarch athlon
-%define _with_mmx 1
+%define                with_mmx        1
+%endif
+%ifnarch %{x86}
+%undefine      with_mmx
 %endif
 Summary:       Password cracker
 Summary(pl):   £amacz hase³
 Name:          john
-Version:       1.6.34
+Version:       1.6.37
 Release:       2
 License:       GPL
 Group:         Applications/System
-Source0:       http://www.openwall.com/john/%{name}-1.6.tar.gz
-# Source0-md5: aae782f160041b2bdc624b0a84054e32
-Patch0:                %{name}-%{version}.patch
-Patch1:                %{name}-1.6.PLD.diff
-Patch2:                %{name}-1.6.ini.diff
-Patch3:                %{name}-1.6.makefile.diff
+Source0:       http://www.openwall.com/john/a/%{name}-%{version}.tar.gz
+# Source0-md5: 9403233b640927295c05b0564ff1f678
+# needed for docs and charset files
+Source1:       http://www.openwall.com/john/%{name}-1.6.tar.gz
+# Source1-md5: aae782f160041b2bdc624b0a84054e32
+Patch0:                %{name}-1.6.PLD.diff
+Patch1:                %{name}-1.6.ini.diff
+Patch2:                %{name}-1.6.makefile.diff
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -36,11 +41,11 @@ hase
 Solaris 2.x SPARC i x86, Digital UNIX, AIX, HP-UX oraz IRIX.
 
 %prep
-%setup -q -n %{name}-1.6
+%setup -q -a1
+# -n %{name}-1.6
 %patch0 -p1
-%patch1 -p1
+#%patch1 -p1
 #%patch2 -p1
-#%patch3 -p1
 
 %build
 cd src
@@ -49,30 +54,29 @@ COPT="%{rpmcflags}"
 # bleh... MMX code must be chosen at compile time :(
 # cannot use MMX for generic i586 nor i686 (Pentium/Pentium Pro have no MMX)
 # K6 optimization exists only in Makefile
+
+TARG=generic
+%if %{with mmx}
+       TARG=linux-x86-mmx-elf
+%endif
 %ifarch %{ix86}
-       %if %{?_with_mmx:1}%{!?_with_mmx:0}
-               TARG=linux-x86-mmx-elf
-       %else
-               TARG=linux-x86-any-elf
-       %endif
-%else
-       %ifarch alpha
-               TARG=linux-alpha
-       %else
-               %ifarch sparc sparc64
-                       TARG=linux-sparc
-               %else
-                       TARG=generic
-               %endif
-       %endif
+       TARG=linux-x86-any-elf
+%endif
+%ifarch alpha
+       TARG=linux-alpha
+%endif
+%ifarch sparc sparc64
+       TARG=linux-sparc
 %endif
 
-%{__make} OPT="$COPT" CC="%{__cc}" $TARG
+%{__make} $TARG \
+       OPT="$COPT" \
+       CC="%{__cc}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/john}
-install run/{*.chr,john.conf} $RPM_BUILD_ROOT%{_libdir}/john
+install run/john.conf john-1.6/run/*.chr $RPM_BUILD_ROOT%{_libdir}/john
 install run/john $RPM_BUILD_ROOT%{_bindir}
 
 rm -f doc/INSTALL
@@ -87,6 +91,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc doc/* run/mailer
+%doc doc/* john-1.6/doc/{CONFIG,EXAMPLES,EXTERNAL,FAQ,MODES,NEWS,OPTIONS,RULES} run/mailer
 %attr(755,root,root) %{_bindir}/*
 %{_libdir}/john
This page took 0.122358 seconds and 4 git commands to generate.