]> git.pld-linux.org Git - packages/john.git/blobdiff - john.spec
- merged into john-x32.patch
[packages/john.git] / john.spec
index 355381d687c4d9ed6d7a5e8747dabdc705e3456f..14faef01a7b49d0e58ba886c4da58c3f17b1688c 100644 (file)
--- a/john.spec
+++ b/john.spec
@@ -1,28 +1,37 @@
-#
-%ifarch i586 i686 athlon pentium2 pentium3 pentium4
-%define do_mmx 1
-%else
-%define        do_mmx 0
-%endif
-%ifarch i586 i686
-%define do_mmxfb 1
-%define        optmmxfb        -DCPU_FALLBACK=1
-%else
-%define do_mmxfb 0
-%undefine optmmxfb
-%endif
+# Conditional build:
+%bcond_without opencl          # OpenCL support (in jumbo version)
+%bcond_without openmp          # OpenMP support (in jumbo version)
+
+%define                snap            20181101
+%define                githash         d73288b91d92f3bd670c18d3853ddaf0e02159f0
+
 Summary:       Password cracker
 Summary(pl.UTF-8):     Łamacz haseł
 Name:          john
-Version:       1.7.3.4
-Release:       1
-License:       GPL
+Version:       1.8.0
+Release:       2.%{snap}.1
+License:       GPL v2
 Group:         Applications/System
-Source0:       http://www.openwall.com/john/g/%{name}-%{version}.tar.bz2
-# Source0-md5: 2f2310c49961c3edea6f92b8dcd45ff4
+Source0:       https://github.com/magnumripper/JohnTheRipper/archive/%{githash}/john-%{snap}.tar.gz
+# Source0-md5: a75c1108111c5181b471a9f4a9dab898
 Patch0:                %{name}-mailer.patch
+Patch1:                jumbo-optflags.patch
+Patch4:                %{name}-x32.patch
 URL:           http://www.openwall.com/john/
 BuildRequires: rpmbuild(macros) >= 1.213
+BuildRequires: autoconf >= 2.69
+BuildRequires: tar >= 1:1.22
+%{?with_opencl:BuildRequires:  OpenCL-devel}
+BuildRequires: bzip2-devel
+%{?with_openmp:BuildRequires:  gcc >= 6:4.2}
+BuildRequires: gmp-devel
+%{?with_openmp:BuildRequires:  libgomp-devel}
+# for SIPdump and vncpcap2john binaries, which are not packaged
+#BuildRequires:        libpcap-devel
+BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: pkgconfig
+BuildRequires: yasm
+BuildRequires: zlib-devel
 Requires:      words
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -46,63 +55,35 @@ na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
 Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
 
 %prep
-%setup -q
+%setup -q -n JohnTheRipper-%{githash}
 %patch0 -p1
+%patch1 -p1
+%ifarch x32
+%patch4 -p1
+%endif
 
 %build
 cd src
+%{__autoconf}
 
-%if %{do_mmxfb}
-%{__make} linux-x86-any \
-       CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
-       CC="%{__cc}"
-mv ../run/john ../run/john-non-mmx
-%{__make} clean
+%ifarch x32
+ax_intel_x32=yes \
 %endif
+%configure \
+       %{!?with_opencl:--disable-opencl} \
+       %{!?with_openmp:--disable-openmp}
 
-%ifarch %{ix86}
-       %if %{do_mmx}
-               TARG=linux-x86-mmx
-       %else
-               TARG=linux-x86-any
-       %endif
-%else
-       %ifarch alpha
-               TARG=linux-alpha
-       %else
-               %ifarch sparc sparcv9
-                       TARG=linux-sparc
-               %else
-                       %ifarch %{x8664}
-                               TARG=linux-x86-64
-                       %else
-                               TARG=generic
-                       %endif
-               %endif
-       %endif
-%endif
-
-%{__make} $TARG \
-       CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}" \
-       CC="%{__cc}"
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
-install run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
-install run/john $RPM_BUILD_ROOT%{_bindir}
-%if %{do_mmxfb}
-install -d $RPM_BUILD_ROOT%{_libdir}/john
-install run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
-%endif
+cp -a run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
+install -p run/john $RPM_BUILD_ROOT%{_bindir}
 
-rm -f doc/INSTALL
-
-cd $RPM_BUILD_ROOT%{_bindir}
-ln -sf john unafs
-ln -sf john unique
-ln -sf john unshadow
+ln -sf john $RPM_BUILD_ROOT%{_bindir}/unafs
+ln -sf john $RPM_BUILD_ROOT%{_bindir}/unique
+ln -sf john $RPM_BUILD_ROOT%{_bindir}/unshadow
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -110,9 +91,8 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc doc/* run/mailer
-%attr(755,root,root) %{_bindir}/*
-%if %{do_mmxfb}
-%dir %{_libdir}/john
-%attr(755,root,root) %{_libdir}/john/john-non-mmx
-%endif
+%attr(755,root,root) %{_bindir}/john
+%attr(755,root,root) %{_bindir}/unafs
+%attr(755,root,root) %{_bindir}/unique
+%attr(755,root,root) %{_bindir}/unshadow
 %{_datadir}/john
This page took 0.084491 seconds and 4 git commands to generate.