]> git.pld-linux.org Git - packages/john.git/blame - john.spec
- rediff patch
[packages/john.git] / john.spec
CommitLineData
bbd8a457
AG
1#
2# TODO:
5529214f 3# - investigate build-time vs runtime CPU features detection
bbd8a457 4#
d502d3d5 5# Conditional build:
5529214f
AG
6%bcond_without opencl # OpenCL support
7%bcond_without openmp # OpenMP support
3dbf4b73 8
051c645d
AG
9%define snap 20190415
10%define githash af81c8de3ec1031c71307057d82fe1cd2bb8eb4b
70a25942 11%define rel 1
3dbf4b73 12
00a4c442 13Summary: Password cracker
25772a4c 14Summary(pl.UTF-8): Łamacz haseł
00a4c442 15Name: john
051c645d
AG
16Version: 1.9.0
17Release: 1.%{snap}.%{rel}
20299915 18License: GPL v2
94f3ed69 19Group: Applications/System
b1820b03 20Source0: https://github.com/magnumripper/JohnTheRipper/archive/%{githash}/%{name}-%{snap}.tar.gz
051c645d 21# Source0-md5: 41561eb1863807f08ffb63780418210c
18fb1460 22Patch0: %{name}-mailer.patch
f1598274
AG
23Patch1: jumbo-optflags.patch
24Patch4: %{name}-x32.patch
ad326883 25URL: http://www.openwall.com/john/
b282b6dc 26%{?with_opencl:BuildRequires: OpenCL-devel}
b1820b03 27BuildRequires: autoconf >= 2.69
b282b6dc 28BuildRequires: bzip2-devel
bd15433c 29%{?with_openmp:BuildRequires: gcc >= 6:4.2}
b282b6dc 30BuildRequires: gmp-devel
bd15433c 31%{?with_openmp:BuildRequires: libgomp-devel}
b1820b03
AG
32BuildRequires: rpmbuild(macros) >= 1.213
33BuildRequires: tar >= 1:1.22
b282b6dc
JB
34# for SIPdump and vncpcap2john binaries, which are not packaged
35#BuildRequires: libpcap-devel
36BuildRequires: openssl-devel >= 0.9.7
37BuildRequires: pkgconfig
b282b6dc 38BuildRequires: yasm
b282b6dc 39BuildRequires: zlib-devel
53d2a984 40Requires: words
fbb20392 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
00a4c442 42
43%description
8e3a118d
JB
44John the Ripper is a fast password cracker, currently available for
45many flavors of Unix (11 are officially supported, not counting
46different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
47requires a contributed patch). Its primary purpose is to detect weak
48Unix passwords. Besides several crypt(3) password hash types most
49commonly found on various Unix flavors, supported out of the box are
50Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
51contributed patches.
e73a58f8 52
15ea9c6b
JR
53%description -l pl.UTF-8
54John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
55rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
8e3a118d 56architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
15ea9c6b
JR
57łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
58Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
59na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
60Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
e73a58f8 61
00a4c442 62%prep
f1598274 63%setup -q -n JohnTheRipper-%{githash}
00a4c442 64%patch0 -p1
f1598274
AG
65%patch1 -p1
66%ifarch x32
67%patch4 -p1
68%endif
3443e32b 69
00a4c442 70%build
71cd src
f1598274 72%{__autoconf}
94f3ed69 73
4b4e0bd3
JR
74%ifarch x32
75ax_intel_x32=yes \
76%endif
b282b6dc
JB
77%configure \
78 %{!?with_opencl:--disable-opencl} \
bd15433c 79 %{!?with_openmp:--disable-openmp}
582fa295 80
f1598274 81%{__make}
94f3ed69 82
00a4c442 83%install
84rm -rf $RPM_BUILD_ROOT
18fb1460 85install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
3443e32b
ER
86cp -a run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
87install -p run/john $RPM_BUILD_ROOT%{_bindir}
0d881e9e 88
3443e32b
ER
89ln -sf john $RPM_BUILD_ROOT%{_bindir}/unafs
90ln -sf john $RPM_BUILD_ROOT%{_bindir}/unique
91ln -sf john $RPM_BUILD_ROOT%{_bindir}/unshadow
00a4c442 92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%files
97%defattr(644,root,root,755)
1f693868 98%doc doc/* run/mailer
3443e32b
ER
99%attr(755,root,root) %{_bindir}/john
100%attr(755,root,root) %{_bindir}/unafs
101%attr(755,root,root) %{_bindir}/unique
102%attr(755,root,root) %{_bindir}/unshadow
18fb1460 103%{_datadir}/john
This page took 0.188316 seconds and 4 git commands to generate.