]> git.pld-linux.org Git - packages/jenkins.git/blame - jenkins.spec
- 1.434
[packages/jenkins.git] / jenkins.spec
CommitLineData
bd576c3d 1# TODO
deef92a8 2# - build it from sources
90079d51 3# https://hudson.dev.java.net/files/documents/2402/125619/hudson-1.280-src.zip
050ac313 4# - use system jars
bd576c3d
ER
5%include /usr/lib/rpm/macros.java
6Summary: Hudson Continuous Build Server
4cf9a5b8 7Name: jenkins
d82aae2a 8Version: 1.434
7fa2e37f 9Release: 1
bd576c3d 10License: MIT License
82ea2910 11Group: Networking/Daemons/Java/Servlets
4cf9a5b8
ER
12# Check for new releases and URLs here: http://mirrors.jenkins-ci.org/war/
13Source0: http://mirrors.jenkins-ci.org/war/%{version}/%{name}.war#/%{name}-%{version}.war
d82aae2a 14# Source0-md5: ab08df72959dd8c302ea4969c206f518
4cf9a5b8
ER
15Source1: context.xml
16Patch0: webxml.patch
17URL: http://www.jenkins-ci.org/
bd576c3d
ER
18BuildRequires: jpackage-utils
19BuildRequires: rpm-javaprov
6eb2a986 20BuildRequires: rpmbuild(macros) >= 1.546
4cf9a5b8 21Obsoletes: hudson < 1.396
bd576c3d 22Requires: jpackage-utils
2777ea66 23Requires: jre-X11
6eb2a986 24Requires: tomcat
bd576c3d
ER
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
4cf9a5b8 29Jenkins monitors executions of repeated jobs, such as building a
bd576c3d
ER
30software project or jobs run by cron.
31
4cf9a5b8 32Among those things, current Jenkins focuses on the following two jobs:
bd576c3d 33- Building/testing software projects continuously, just like
4cf9a5b8 34 CruiseControl or DamageControl. In a nutshell, Jenkins provides an
bd576c3d
ER
35 easy-to-use so-called continuous integration system, making it easier
36 for developers to integrate changes to the project, and making it
37 easier for users to obtain a fresh build. The automated, continoues
38 build increases the productivity.
39- Monitoring executions of externally-run jobs, such as cron jobs and
40 procmail jobs, even those that are run on a remote machine. For
41 example, with cron, all you receive is regular e-mails that capture
42 the output, and it is up to you to look at them diligently and notice
4cf9a5b8 43 when it broke. Jenkins keeps those outputs and makes it easy for you to
bd576c3d
ER
44 notice when something is wrong.
45
46%prep
8cb70730 47%setup -qc
82ea2910 48rm *.class
49rm winstone.jar
aa36fe55 50%patch0 -p1
51
4cf9a5b8
ER
52find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
53
bd576c3d
ER
54%install
55rm -rf $RPM_BUILD_ROOT
6eb2a986 56install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_datadir}/%{name},%{_sharedstatedir}/%{name},%{_tomcatconfdir}}
aa36fe55 57mv WEB-INF/web.xml $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/web.xml
58cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/tomcat-context.xml
21b2e2a1 59ln -sf %{_sysconfdir}/%{name}/tomcat-context.xml $RPM_BUILD_ROOT%{_tomcatconfdir}/%{name}.xml
6eb2a986
ER
60cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
61ln -sf %{_sysconfdir}/%{name}/web.xml $RPM_BUILD_ROOT%{_datadir}/%{name}/WEB-INF/web.xml
bd576c3d 62
4cf9a5b8
ER
63%post
64# If we have an old hudson install, rename it to jenkins
65if test -d /var/lib/hudson; then
66 echo >&2 "Moving /var/lib/hudson -> /var/lib/jenkins"
67 # leave a marker to indicate this came from Hudson.
68 # could be useful down the road
69 # This also ensures that the .??* wildcard matches something
70 touch /var/lib/hudson/.moving-hudson
71 mv -f /var/lib/hudson/* /var/lib/hudson/.??* /var/lib/jenkins
72 rmdir /var/lib/hudson
73fi
74if test -d /var/run/hudson; then
75 mv -f /var/run/hudson/* /var/run/jenkins
76 rmdir /var/run/hudson
77fi
78
21b2e2a1 79%postun
80%tomcat_clear_cache %{name}
81
bd576c3d
ER
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%files
86%defattr(644,root,root,755)
6eb2a986
ER
87%dir %{_sysconfdir}/%{name}
88%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.xml
21b2e2a1 89%{_tomcatconfdir}/%{name}.xml
90%{_datadir}/%{name}
6eb2a986 91%attr(2775,root,servlet) %dir %{_sharedstatedir}/%{name}
This page took 0.0983000000000001 seconds and 4 git commands to generate.