]> git.pld-linux.org Git - packages/javacc.git/blame - javacc.spec
- update md5
[packages/javacc.git] / javacc.spec
CommitLineData
f6999b2e
ER
1Summary: A parser/scanner generator for java
2Name: javacc
3Version: 4.0
382db443 4Release: 1
f6999b2e
ER
5License: BSD
6Source0: https://javacc.dev.java.net/files/documents/17/26783/%{name}-%{version}src.tar.gz
54d6578f 7# Source0-md5: bf91835dc1bb4821f4b26fd552b43c8d
f6999b2e
ER
8Source1: %{name}
9Source2: jjdoc
10Source3: jjtree
11Group: Development/Languages/Java
12URL: https://javacc.dev.java.net/
13BuildRequires: /bin/bash
14BuildRequires: ant
15BuildRequires: jpackage-utils
16BuildRequires: junit >= 3.8.1
17BuildRequires: rpmbuild(macros) >= 1.300
18Requires: jpackage-utils >= 0:1.5
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Java Compiler Compiler (JavaCC) is the most popular parser generator
24for use with Java applications. A parser generator is a tool that
25reads a grammar specification and converts it to a Java program that
26can recognize matches to the grammar. In addition to the parser
27generator itself, JavaCC provides other standard capabilities related
28to parser generation such as tree building (via a tool called JJTree
29included with JavaCC), actions, debugging, etc.
30
31%package manual
32Summary: Manual for %{name}
33Group: Documentation
34
35%description manual
36Manual for %{name}.
37
38%package demo
39Summary: Examples for %{name}
40Group: Documentation
41
42%description demo
43Examples for %{name}.
44
45%prep
46%setup -q -n %{name}
47cp %{SOURCE1} javacc
48cp %{SOURCE2} jjdoc
49cp %{SOURCE3} jjtree
50mv www/doc .
51
52%build
382db443
ER
53required_jars="junit"
54export CLASSPATH=$(/usr/bin/build-classpath $required_jars)
55
f6999b2e
ER
56%ant \
57 -Dversion=%{version} \
58 jar
59
60%install
61rm -rf $RPM_BUILD_ROOT
62install -d $RPM_BUILD_ROOT%{_javadir}
63install bin/lib/%{name}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
64ln -s %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
65install -d $RPM_BUILD_ROOT%{_bindir}
66install javacc jjdoc jjtree $RPM_BUILD_ROOT%{_bindir}
67install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
68cp -pr examples $RPM_BUILD_ROOT%{_datadir}/%{name}
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%files
74%defattr(644,root,root,755)
75%{_javadir}/*.jar
76%doc LICENSE README
77%defattr(0755,root,root,0755)
78%attr(755,root,root) %{_bindir}/*
79
80%files manual
81%defattr(644,root,root,755)
82%doc doc/*
83
84%files demo
85%defattr(644,root,root,755)
86%{_datadir}/%{name}/*
This page took 0.196934 seconds and 4 git commands to generate.