]> git.pld-linux.org Git - packages/ipset.git/blobdiff - ipset.spec
- release 22
[packages/ipset.git] / ipset.spec
index fbf0a5637a8ac1f5f443be42465b14c35f6df43f..586b0ee29a486c44df47e048501e7364116fa468 100644 (file)
 %define                _enable_debug_packages  0
 %endif
 
-%define                rel     6
+%define                rel     22
 %define                pname   ipset
 Summary:       IP sets utility
 Summary(pl.UTF-8):     Narzędzie do zarządzania zbiorami IP
 Name:          %{pname}%{_alt_kernel}
-Version:       4.2
+Version:       4.4
 Release:       %{rel}
 License:       GPL
 Group:         Networking/Admin
 Source0:       http://ipset.netfilter.org/%{pname}-%{version}.tar.bz2
-# Source0-md5: 9060d549a18c1c0794fa47a71343d627
+# Source0-md5: e21e9d9dfb8a01fc0122323ff1d6cbdb
 Source1:       %{pname}.init
+Patch0:                shadow-args.patch
 URL:           http://ipset.netfilter.org/
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
 %{?with_userspace:BuildRequires:       linux-libc-headers >= 7:2.6.22.1-2}
-BuildRequires: perl-base
 BuildRequires: rpmbuild(macros) >= 1.379
+Suggests:      kernel-net-ipset
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -102,13 +103,21 @@ Ten pakiet zawiera moduły jądra oferujące wsparcie dla zbiorów IP.
 
 %prep
 %setup -q -n %{pname}-%{version}
+%patch0 -p1
 mv kernel/{Kbuild,Makefile}
 
+# these options can be overriden by module parameters.
 # maximum number of ipsets.
 %{__sed} -i 's:$(IP_NF_SET_MAX):256:' kernel/Makefile
 # hash size for bindings of IP sets.
 %{__sed} -i 's:$(IP_NF_SET_HASHSIZE):1024:' kernel/Makefile
-# these options can be overriden by module parameters.
+
+%if "%{cc_version}" < "3.4"
+%{__sed} -i -e 's/-Wextra//' Makefile
+%{__sed} -i -e 's/-Winit-self//' Makefile
+%{__sed} -i -e 's/-Wold-style-definition//' Makefile
+%{__sed} -i -e 's/-Wno-missing-field-initializers//' Makefile
+%endif
 
 %build
 %if %{with userspace}
@@ -122,7 +131,7 @@ mv kernel/{Kbuild,Makefile}
 %endif
 
 %if %{with kernel}
-# ugly hack for satisfy rpm build macro. in fact all modules will be build.
+# ugly hack for satisfy rpm build macro. in fact all modules will be built.
 %build_kernel_modules -C kernel -m ip_set
 %endif
 
@@ -139,15 +148,15 @@ install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_includedir}}
        MANDIR="%{_mandir}" \
        BINDIR="%{_sbindir}"
 
-install *.h $RPM_BUILD_ROOT%{_includedir}
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{pname}
+cp -a *.h $RPM_BUILD_ROOT%{_includedir}
+install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{pname}
 %endif
 
 %if %{with kernel}
 cd kernel
 %install_kernel_modules -m ip_set -d kernel/net/ipv4/netfilter
-install ip_set_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
-install ipt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
+install -p ip_set_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
+install -p ipt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
 cd -
 %endif
 
@@ -172,14 +181,15 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog ChangeLog.ippool TODO
-%attr(755,root,root) %{_sbindir}/*
+%attr(755,root,root) %{_sbindir}/ipset
 %dir %{_libdir}/ipset
-%attr(755,root,root) %{_libdir}/ipset/*.so
-%{_mandir}/man8/*
+%attr(755,root,root) %{_libdir}/ipset/libipset_*.so
+%{_mandir}/man8/ipset.8*
 
 %files devel
 %defattr(644,root,root,755)
-%{_includedir}/*.h
+%{_includedir}/ipset.h
+%{_includedir}/libipt_set.h
 
 %files init
 %defattr(644,root,root,755)
@@ -189,5 +199,7 @@ fi
 %if %{with kernel}
 %files -n kernel%{_alt_kernel}-net-ipset
 %defattr(644,root,root,755)
-/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/*.ko*
+/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/ip_set*.ko*
+/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/ipt_set*.ko*
+/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/ipt_SET*.ko*
 %endif
This page took 0.105467 seconds and 4 git commands to generate.