]> git.pld-linux.org Git - packages/icewm.git/blobdiff - icewm.spec
- replace wmstyle startup script with script run directly by icewm-session
[packages/icewm.git] / icewm.spec
index 83474c0c27e07fadbd49866ebcbb1cda330ab841..dd4f889eb15a1e71f02887f90ecab6772324806a 100644 (file)
@@ -1,64 +1,67 @@
 #
 # Conditional build:
-%bcond_without gradients       # disable gradients (implies with_antialiasing)
-%bcond_without antialiasing    # disable antialiasing
+%bcond_without gradients       # disable gradients (requires antialiasing which requires freetype)
 %bcond_without freetype        # disable xfreetype support (implies !with_antialiasing)
 %bcond_without guievents       # disable guievents
-%bcond_without imlib           # disable imlib support
 #
 # TODO:
 # - make a PLD-theme - default :]
-# - -home_etc.patch needs update
 
 Summary:       IceWM X11 Window Manager
+Summary(de.UTF-8):     IceWM ist ein Window Manager für X
 Summary(es.UTF-8):     Administrador de Ventanas X11
 Summary(pl.UTF-8):     IceWM - zarządca okienek X11
 Summary(pt_BR.UTF-8):  Gerenciador de Janelas X11
 Summary(ru.UTF-8):     Оконный менеджер для X11
 Summary(uk.UTF-8):     Віконний менеджер для X11
-Summary(de.UTF-8):     IceWM ist ein Window Manager für X
 Name:          icewm
-Version:       1.2.32
-#%define _pre pre1
+Version:       1.3.7
 %define        _iceicons_ver           0.6
 %define        _netscapeicons_ver      0.2
-Release:       1
+Release:       2
 Epoch:         2
 License:       LGPL
 Group:         X11/Window Managers
-#Source0:      http://dl.sourceforge.net/icewm/%{name}-%{version}%{_pre}.tar.gz
 Source0:       http://dl.sourceforge.net/icewm/%{name}-%{version}.tar.gz
-# Source0-md5: 49084971689c04b739766a3f5d576d83
+# Source0-md5: 224695231aedb2b91db3254a13e1c8dd
 Source1:       IceWM.desktop
 Source3:       http://dl.sourceforge.net/icewm/iceicons-%{_iceicons_ver}.tar.gz
 # Source3-md5: 53ed111a3c4d1e609bd1604ddccd4701
-Source4:       IceWM.RunWM
+Source4:       icewm-startup.sh
 Source6:       http://dl.sourceforge.net/icewm/netscapeicons-%{_netscapeicons_ver}.tar.gz
 # Source6-md5: 409aa9b02adc11309ed546c5120c01d2
 Source7:       %{name}-xsession.desktop
-Patch0:                %{name}-broken-xrandr.patch
-#Patch1:               %{name}-home_etc.patch
-Patch2:                %{name}-helpbrowser.patch
+Patch0:                %{name}-build-fixes.patch
+Patch1:                %{name}-tray_hotfixes.patch
+Patch2:                %{name}-fix_input_focus_loss_for_deiconified_frame_1.patch
+Patch3:                %{name}-ifstate-exact-check.patch
+Patch4:                %{name}-imap-unseen.patch
+Patch5:                %{name}-autohide.patch
 URL:           http://www.icewm.org/
-BuildRequires: xorg-lib-libX11-devel
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-%{?with_guievents:BuildRequires:       esound-devel}
+BuildRequires: gdk-pixbuf-devel
 BuildRequires: gettext-devel
-%{?with_imlib:BuildRequires:   imlib-devel}
+BuildRequires: gtk+2-devel
+BuildRequires: kde4-kde3support
 BuildRequires: libstdc++-devel
-#%:wq
+BuildRequires: pkgconfig
+BuildRequires: xorg-lib-libICE-devel
+BuildRequires: xorg-lib-libSM-devel
+BuildRequires: xorg-lib-libX11-devel
 %{?with_freetype:BuildRequires:        xorg-lib-libXft-devel >= 2.1}
+BuildRequires: xorg-lib-libXinerama-devel
 %{?with_guievents:BuildRequires:       yiff-devel}
 Requires(pre): fileutils
 Requires(pre): sh-utils
-Requires:      vfmg >= 0.9.95
+Requires:      shared-mime-info
 Requires:      xinitrc-ng
+Suggests:      vfmg >= 0.9.95
+Conflicts:     filesystem < 3.0-20
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _wmstyledir     /etc/sysconfig/wmstyle
-%define                _wmpropsdir     /usr/share/wm-properties
-%define                specflags_ia32   -fomit-frame-pointer
+%define                _wmpropsdir     /usr/share/gnome/wm-properties
+%define                specflags_ia32  -fomit-frame-pointer
 
 %description
 Window Manager for X Window System. Can emulate the look of
@@ -129,13 +132,13 @@ Wszystkie stworzone przez Marko Macka: gtk2, metal2, motif, nice,
 nice2, warp3, warp4, win95.
 
 %prep
-#setup -q -n %{name}-%{version}%{_pre}
 %setup -q
 %patch0 -p1
-#patch1 -p1
-#patch2 -p1
-
-mv -f po/{zh_TW.Big5,zh_TW}.po
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 cd lib/icons
 tar -xzf %{SOURCE3}
@@ -147,12 +150,9 @@ cp -f /usr/share/automake/config.sub .
 %{__autoconf}
 %{__autoheader}
 %configure \
-       %{?with_gradients:--enable-gradients} \
-       %{?with_antialiasing:--enable-antialiasing} \
+       %{!?with_gradients:--disable-gradients} \
        %{!?with_freetype:--disable-xfreetype --enable-corefonts} \
        %{?with_guievents:--enable-guievents} \
-       %{!?with_imlib:--without-imlib} \
-       --disable-menus-gnome \
        --enable-shaped-decorations \
        --with-cfgdir=%{_sysconfdir}/X11/%{name} \
        --with-docdir=%{_docdir}
@@ -160,14 +160,14 @@ cp -f /usr/share/automake/config.sub .
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir}/xsessions,%{_pixmapsdir},%{_wmstyledir}} \
+install -d $RPM_BUILD_ROOT{%{_datadir}/xsessions,%{_pixmapsdir}} \
        $RPM_BUILD_ROOT{%{_wmpropsdir},%{_sysconfdir}/X11/%{name}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
-install %{SOURCE4} $RPM_BUILD_ROOT%{_wmstyledir}/%{name}-session.sh
+install %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/icewm/startup
 install %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
 install lib/keys $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/keys
 sed 's|^# IconPath=""|IconPath="%{_datadir}/pixmaps:%{_datadir}/icons"|' < lib/preferences > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/preferences
@@ -200,13 +200,13 @@ test -h %{_pixmapsdir}/icewm || rm -rf %{_pixmapsdir}/icewm
 %{_datadir}/icewm/icons
 %{_datadir}/icewm/ledclock
 %{_datadir}/icewm/mailbox
+%attr(755,root,root) %{_datadir}/icewm/startup
 %{_datadir}/icewm/taskbar
 %dir %{_datadir}/icewm/themes
 %{_datadir}/icewm/themes/Infadel2
 %{_datadir}/icewm/themes/icedesert
 %{_datadir}/xsessions/%{name}.desktop
 %{_wmpropsdir}/*
-%attr(755,root,root) %{_wmstyledir}/%{name}-session.sh
 
 %files themes-base
 %defattr(644,root,root,755)
This page took 0.054198 seconds and 4 git commands to generate.