]> git.pld-linux.org Git - packages/handbrake.git/blame - handbrake.spec
add binutils 2.41 patch for embedded ffmpeg
[packages/handbrake.git] / handbrake.spec
CommitLineData
a84837ed
ER
1Summary: A program to transcode DVDs and other sources to MPEG-4 and MKV
2Name: handbrake
f7ea1e26 3Version: 1.4.1
9dea01db 4Release: 2
a84837ed
ER
5License: GPL v2+
6Group: Applications/Multimedia
f7ea1e26
JR
7Source0: https://github.com/HandBrake/HandBrake/releases/download/%{version}/HandBrake-%{version}-source.tar.bz2
8# Source0-md5: 73fe8df8340ac7b7c23a8c09974d6906
a84837ed
ER
9# Source1 is a tarball of the downloads/ folder that contains third party
10# libraries required and automatically downloaded by HandBrake the first
11# time 'make' is run. If you update Source0 to a newer release you must
12# recreate an updated Source1 tarball for it too!
e2719113 13Source1: HandBrake-%{version}-contrib-tarballs.tar
f7ea1e26 14# Source1-md5: 11691c785ee60b58651c5405eeeb5f22
fe2d86de 15Patch0: binutils2.41.patch
f7ea1e26 16URL: https://handbrake.fr/
d74f4456
JR
17BuildRequires: autoconf
18BuildRequires: automake
a84837ed 19BuildRequires: bzip2-devel
d74f4456 20BuildRequires: cmake
a84837ed
ER
21BuildRequires: curl-devel
22BuildRequires: dbus-glib-devel
d74f4456
JR
23BuildRequires: fontconfig-devel
24BuildRequires: freetype-devel
25BuildRequires: fribidi-devel
a84837ed
ER
26BuildRequires: glib2-devel
27BuildRequires: gstreamer-devel
28BuildRequires: gstreamer-plugins-base-devel
d74f4456
JR
29BuildRequires: gtk+3-devel
30BuildRequires: gtk-webkit3-devel
31BuildRequires: harfbuzz-devel
a84837ed 32BuildRequires: intltool
d74f4456
JR
33BuildRequires: jansson-devel
34BuildRequires: lame-libs-devel
35BuildRequires: libass-devel
a84837ed 36BuildRequires: libnotify-devel
d74f4456
JR
37BuildRequires: libogg-devel
38BuildRequires: libsamplerate-devel
a84837ed 39BuildRequires: libstdc++-devel
d74f4456 40BuildRequires: libtheora-devel
a84837ed 41BuildRequires: libtool
d74f4456
JR
42BuildRequires: libvorbis-devel
43BuildRequires: libx264-devel
44BuildRequires: libxml2-devel
a84837ed 45BuildRequires: m4
d74f4456
JR
46BuildRequires: opus-devel
47BuildRequires: pkgconfig
a84837ed
ER
48BuildRequires: python
49BuildRequires: subversion
50BuildRequires: udev-glib-devel
51BuildRequires: yasm
52BuildRequires: zlib-devel
f7ea1e26 53BuildConflicts: libudfread-devel
3e26daac 54ExclusiveArch: %{x8664}
a84837ed
ER
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
f7ea1e26
JR
57%define _debugsource_packages 0
58
a84837ed
ER
59%description
60HandBrake is an open-source, GPL-licensed, multi-platform,
61multi-threaded transcoder, available for MacOS X, Linux and Windows.
62
63%package gui
64Summary: A program to transcode DVDs and other sources to MPEG-4 and MKV
65Group: Applications/Multimedia
a84837ed
ER
66Requires: gstreamer-plugins-bad
67Requires: gstreamer-plugins-ugly
d74f4456 68Requires: gtk+3
a84837ed
ER
69Requires: libdvdcss
70Obsoletes: HandBrake
71Obsoletes: handbrake
72
73%package cli
74Summary: A program to transcode DVDs and other sources to MPEG-4 and MKV
75Group: Applications/Multimedia
76Requires: gtk-update-icon-cache
77Requires: libdvdcss
78Obsoletes: HandBrake
79Obsoletes: handbrake
80
81%description gui
82HandBrake is an open-source, GPL-licensed, multi-platform,
83multi-threaded transcoder, available for MacOS X, Linux and Windows.
84
85This is the GTK GUI version of HandBrake.
86
87%description cli
88HandBrake is an open-source, GPL-licensed, multi-platform,
89multi-threaded transcoder, available for MacOS X, Linux and Windows.
90
91This is the CLI tool version of HandBrake.
92
93%prep
94%setup -q -n HandBrake-%{version} -a1
a84837ed 95
fe2d86de
JP
96cp -p %{PATCH0} contrib/ffmpeg/A77-%{basename:%{PATCH0}}
97
a84837ed
ER
98%build
99export CFLAGS="%{rpmcflags}"
100export CXXFLAGS="%{rpmcxxflags}"
101export LDFLAGS="%{rpmldflags}"
102./configure \
f7ea1e26 103 --force \
d74f4456
JR
104 --prefix=%{_prefix} \
105 --disable-df-fetch
f7ea1e26
JR
106
107cat > build/GNUmakefile.custom.defs <<EOF
108STRIP.exe = /bin/true
109BUILD.jobs = %{__jobs}
110GCC.args.g.none = %{rpmcflags}
111GCC.args.O.speed = %{rpmcflags}
112EOF
113
a84837ed
ER
114%{__make} -C build
115
116%install
117rm -rf $RPM_BUILD_ROOT
118cat > build/GNUmakefile.custom.defs <<EOF
f7ea1e26 119STRIP.exe = /bin/true
a84837ed
ER
120CONF.args = --prefix=$RPM_BUILD_ROOT%{_prefix}
121PREFIX = $RPM_BUILD_ROOT%{_prefix}
122PREFIX/ = $RPM_BUILD_ROOT%{_prefix}/
123EOF
124%{__make} -C build install
125
126%{__rm} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
d74f4456 127
f7ea1e26
JR
128%{__mv} $RPM_BUILD_ROOT%{_localedir}/sl{_SI,}
129%{__mv} $RPM_BUILD_ROOT%{_localedir}/uk{_UA,}
d74f4456 130%{__mv} $RPM_BUILD_ROOT%{_localedir}/{no,nb}
d74f4456
JR
131
132%find_lang ghb
a84837ed
ER
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post gui
d74f4456 138%update_icon_cache hicolor
a84837ed
ER
139
140%postun gui
d74f4456 141%update_icon_cache hicolor
a84837ed 142
d74f4456 143%files gui -f ghb.lang
a84837ed 144%defattr(644,root,root,755)
d74f4456 145%doc COPYING AUTHORS.markdown NEWS.markdown README.markdown THANKS.markdown
a84837ed 146%attr(755,root,root) %{_bindir}/ghb
9cb5b6ea 147%{_desktopdir}/fr.handbrake.ghb.desktop
d74f4456 148%{_iconsdir}/hicolor/scalable/apps/hb-icon.svg
9cb5b6ea 149%{_iconsdir}/hicolor/scalable/apps/fr.handbrake.ghb.svg
f7ea1e26 150%{_datadir}/metainfo/fr.handbrake.ghb.metainfo.xml
a84837ed
ER
151
152%files cli
153%defattr(644,root,root,755)
154%attr(755,root,root) %{_bindir}/HandBrakeCLI
This page took 0.11513 seconds and 4 git commands to generate.