]> git.pld-linux.org Git - packages/gssntlmssp.git/blame - gssntlmssp.spec
- package more dirs
[packages/gssntlmssp.git] / gssntlmssp.spec
CommitLineData
631a1caa
JB
1# TODO:
2# - implement mech.d in heimdal (e.g. by cat /etc/gss/mech.d/*.conf > /etc/gss/mech in %post scripts)
3# - apidocs (doxygen config missing)
4#
5# Conditional build:
6%bcond_with apidocs # API documentation (doxygen config missing in sources)
7#
8Summary: GSSAPI NTLMSSP mechanism
9Summary(pl.UTF-8): Mechanizm GSSAPI NTLMSSP
10Name: gssntlmssp
11Version: 0.7.0
dee45474 12Release: 4
631a1caa
JB
13License: LGPL v3+
14Group: Libraries
15# also https://github.com/simo5/gss-ntlmssp but no releases there
16Source0: http://releases.pagure.org/gssntlmssp/%{name}-%{version}.tar.gz
17# Source0-md5: 5f890092ecf8a566b7556fca2b60d6cc
18Patch0: %{name}-heimdal.patch
19Patch1: %{name}-openssl1.1.patch
20URL: https://pagure.io/gssntlmssp
21BuildRequires: autoconf >= 2.59
22BuildRequires: automake >= 1:1.11
23BuildRequires: docbook-style-xsl-nons
24BuildRequires: doxygen
25BuildRequires: gettext-tools
26BuildRequires: heimdal-devel
27# pkgconfig(wbclient)
28BuildRequires: libsmbclient-devel
29BuildRequires: libtool >= 2:2
30BuildRequires: libunistring-devel
31BuildRequires: libxslt-progs
32BuildRequires: openssl-devel
33BuildRequires: pkgconfig
34BuildRequires: po4a
35BuildRequires: zlib-devel
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39A GSSAPI Mechanism that implements NTLMSSP.
40
41%description -l pl.UTF-8
42Mechanizm GSSAPI implementujący NTLMSSP.
43
44%package devel
45Summary: Header file for GSSAPI NTLMSSP extensions
46Summary(pl.UTF-8): Plik nagłówkowy rozszerzeń GSSAPI NTLMSSP
47Group: Development/Libraries
48Requires: heimdal-devel
49
50%description devel
51Header file with definition for custom GSSAPI extensions for NTLMSSP.
52
53%description devel -l pl.UTF-8
54Plik nagłówkowy z definicjami rozszerzeń GSSAPI dla NTLMSSP.
55
56%prep
57%setup -q
58%patch0 -p1
59%patch1 -p1
60
61%build
62%{__libtoolize}
63%{__aclocal} -I m4 -I .
64%{__autoconf}
65%{__autoheader}
66%{__automake}
67%configure \
68 --disable-silent-rules
69%{__make}
70
71%if %{with apidocs}
72%{__make} docs
73%endif
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78%{__make} install \
79 DESTDIR=$RPM_BUILD_ROOT
80
81# loadable module
82%{__rm} $RPM_BUILD_ROOT%{_libdir}/gssntlmssp/*.la
83
84install -d $RPM_BUILD_ROOT/etc/gss/mech.d
85cp -p examples/mech.ntlmssp $RPM_BUILD_ROOT/etc/gss/mech.d/ntlmssp.conf
86
87%find_lang %{name}
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%if 0
93# TODO: needs support in heimdal.spec
94# (/etc/gss/mech as ghost, move current content with appropriate comment to /etc/gss/mech.d/00_init.conf)
95%post
96umask 022
97cat /etc/gss/mech.d/*.conf >$RPM_BUILD_ROOT/etc/gss/mech
98
99%postun
100umask 022
101if [ "$1" = "0" ]; then
102 cat /etc/gss/mech.d/*.conf >$RPM_BUILD_ROOT/etc/gss/mech
103fi
104%endif
105
106%files -f %{name}.lang
107%defattr(644,root,root,755)
108%dir %{_libdir}/gssntlmssp
109%attr(755,root,root) %{_libdir}/gssntlmssp/gssntlmssp.so
4b347be4 110# TODO: needs to be owned by heimdal.spec?
dee45474 111%dir /etc/gss
4b347be4 112%dir /etc/gss/mech.d
631a1caa
JB
113/etc/gss/mech.d/ntlmssp.conf
114%{_mandir}/man8/gssntlmssp.8*
115
116%files devel
117%defattr(644,root,root,755)
118%{_includedir}/gssapi/gssapi_ntlmssp.h
This page took 0.094456 seconds and 4 git commands to generate.