]> git.pld-linux.org Git - packages/graphene.git/blame - graphene.spec
- updated to 1.6.0
[packages/graphene.git] / graphene.spec
CommitLineData
c61b6a12
JB
1# NOTE: despite some comments in configure, SSE2 is not selected at runtime;
2# SSE2 option seems to change the ABI of library
3#
4# Conditional build:
5%bcond_without static_libs # static library
4c5fe2b6 6%bcond_without introspection # gobject introspection
c61b6a12
JB
7%bcond_with sse2 # x86 SSE2 fast paths
8%bcond_without armneon # ARM NEON fast paths
eba3a6e7 9
c61b6a12 10%ifarch pentium4 %{x8664}
4c5fe2b6 11%define with_sse2 1
c61b6a12
JB
12%endif
13Summary: Graphene - a thin layer of types for graphic libraries
14Summary(pl.UTF-8): Graphene - cienka warstwa typów dla bibliotek graficznych
15Name: graphene
593c7563 16Version: 1.6.0
b676c95d 17Release: 1
c61b6a12
JB
18License: MIT
19Group: Libraries
593c7563
JB
20Source0: http://ftp.gnome.org/pub/GNOME/sources/graphene/1.6/%{name}-%{version}.tar.xz
21# Source0-md5: 4f823f2e6a9849ea2c85d4be52c0326f
4c5fe2b6 22Patch0: %{name}-gcc.patch
c61b6a12 23URL: https://github.com/ebassi/graphene
eba3a6e7
ER
24BuildRequires: autoconf >= 2.63
25BuildRequires: automake >= 1:1.11
c61b6a12
JB
26BuildRequires: glib2-devel >= 1:2.40.0
27%{?with_introspection:BuildRequires: gobject-introspection-devel >= 1.41.0}
28BuildRequires: gtk-doc >= 1.20
c61b6a12
JB
29BuildRequires: libtool >= 2:2.2.6
30BuildRequires: pkgconfig
4c5fe2b6
JB
31BuildRequires: tar >= 1:1.22
32BuildRequires: xz
c61b6a12
JB
33Requires: glib2 >= 1:2.40.0
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37Graphene provides a small set of mathematical types needed to
38implement graphic libraries that deal with 2D and 3D transformations
39and projections.
40
41%description -l pl.UTF-8
42Graphene udostępnia mały zestaw typów matematycznych potrzebnych przy
43implementowaniu bibliotek graficznych wykonujących przekształcenia i
44rzuty 2D oraz 3D.
45
46%package devel
47Summary: Header files for Graphene library
48Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Graphene
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: glib2-devel >= 1:2.40.0
52
53%description devel
54Header files for Graphene library.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe biblioteki Graphene.
58
59%package static
60Summary: Static Graphene library
61Summary(pl.UTF-8): Statyczna biblioteka Graphene
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66Static Graphene library.
67
68%description static -l pl.UTF-8
69Statyczna biblioteka Graphene.
70
4c5fe2b6
JB
71%package apidocs
72Summary: API documentation for Graphene library
73Summary(pl.UTF-8): Dokumentacja API biblioteki Graphene
74Group: Documentation
eba3a6e7
ER
75%if "%{_rpmversion}" >= "5"
76BuildArch: noarch
77%endif
4c5fe2b6
JB
78
79%description apidocs
80API documentation for Graphene library.
81
82%description apidocs -l pl.UTF-8
83Dokumentacja API biblioteki Graphene.
84
c61b6a12
JB
85%prep
86%setup -q
87%patch0 -p1
c61b6a12
JB
88
89%build
90%{__gtkdocize}
91%{__libtoolize}
92%{__aclocal} -I build/autotools
93%{__autoconf}
94%{__autoheader}
95%{__automake}
96%configure \
97 %{!?with_armneon:--disable-arm-neon} \
4c5fe2b6 98 %{!?with_introspection:--disable-introspection} \
c61b6a12
JB
99 --disable-silent-rules \
100 %{!?with_sse2:--disable-sse2} \
4c5fe2b6
JB
101 %{?with_static_libs:--enable-static} \
102 --with-html-dir=%{_gtkdocdir}
c61b6a12
JB
103%{__make}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108%{__make} install \
109 DESTDIR=$RPM_BUILD_ROOT
110
111# obsoleted by pkg-config
112%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgraphene-1.0.la
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post -p /sbin/ldconfig
118%postun -p /sbin/ldconfig
119
120%files
121%defattr(644,root,root,755)
c61b6a12
JB
122%attr(755,root,root) %{_libdir}/libgraphene-1.0.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libgraphene-1.0.so.0
4c5fe2b6
JB
124%if %{with introspection}
125%{_libdir}/girepository-1.0/Graphene-1.0.typelib
126%endif
c61b6a12
JB
127
128%files devel
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/libgraphene-1.0.so
131%{_includedir}/graphene-1.0
4c5fe2b6
JB
132%dir %{_libdir}/graphene-1.0
133%{_libdir}/graphene-1.0/include
134%if %{with introspection}
135%{_datadir}/gir-1.0/Graphene-1.0.gir
136%endif
c61b6a12
JB
137%{_pkgconfigdir}/graphene-1.0.pc
138%{_pkgconfigdir}/graphene-gobject-1.0.pc
139
140%if %{with static_libs}
141%files static
142%defattr(644,root,root,755)
143%{_libdir}/libgraphene-1.0.a
144%endif
4c5fe2b6
JB
145
146%files apidocs
147%defattr(644,root,root,755)
148%{_gtkdocdir}/graphene
This page took 0.077451 seconds and 4 git commands to generate.