]> git.pld-linux.org Git - packages/graphene.git/blame - graphene.spec
rebuild with separate debuginfo build-ids
[packages/graphene.git] / graphene.spec
CommitLineData
c61b6a12
JB
1# NOTE: despite some comments in configure, SSE2 is not selected at runtime;
2# SSE2 option seems to change the ABI of library
3#
4# Conditional build:
5%bcond_without static_libs # static library
4c5fe2b6 6%bcond_without introspection # gobject introspection
c61b6a12
JB
7%bcond_with sse2 # x86 SSE2 fast paths
8%bcond_without armneon # ARM NEON fast paths
eba3a6e7 9
c61b6a12 10%ifarch pentium4 %{x8664}
4c5fe2b6 11%define with_sse2 1
c61b6a12
JB
12%endif
13Summary: Graphene - a thin layer of types for graphic libraries
14Summary(pl.UTF-8): Graphene - cienka warstwa typów dla bibliotek graficznych
15Name: graphene
b213e09b 16Version: 1.10.6
93c4f9dd 17Release: 2
c61b6a12
JB
18License: MIT
19Group: Libraries
b213e09b
JB
20Source0: https://download.gnome.org/sources/graphene/1.10/%{name}-%{version}.tar.xz
21# Source0-md5: 390139e704772b915ff2b7cac56c24ae
c61b6a12 22URL: https://github.com/ebassi/graphene
66288e3f 23%if %{with sse2} || %{with armneon}
4b7a3b52 24BuildRequires: gcc >= 6:4.9
d41a2c75
JB
25%else
26BuildRequires: gcc >= 5:3.2
4b7a3b52 27%endif
c61b6a12
JB
28BuildRequires: glib2-devel >= 1:2.40.0
29%{?with_introspection:BuildRequires: gobject-introspection-devel >= 1.41.0}
30BuildRequires: gtk-doc >= 1.20
66288e3f 31BuildRequires: meson >= 0.50.1
d41a2c75 32BuildRequires: ninja >= 1.5
c61b6a12 33BuildRequires: pkgconfig
09305cc3 34BuildRequires: python3 >= 1:3
b213e09b 35BuildRequires: rpm-build >= 4.6
66288e3f 36BuildRequires: rpmbuild(macros) >= 1.736
4c5fe2b6
JB
37BuildRequires: tar >= 1:1.22
38BuildRequires: xz
c61b6a12
JB
39Requires: glib2 >= 1:2.40.0
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43Graphene provides a small set of mathematical types needed to
44implement graphic libraries that deal with 2D and 3D transformations
45and projections.
46
47%description -l pl.UTF-8
48Graphene udostępnia mały zestaw typów matematycznych potrzebnych przy
49implementowaniu bibliotek graficznych wykonujących przekształcenia i
50rzuty 2D oraz 3D.
51
52%package devel
53Summary: Header files for Graphene library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Graphene
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: glib2-devel >= 1:2.40.0
58
59%description devel
60Header files for Graphene library.
61
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki Graphene.
64
65%package static
66Summary: Static Graphene library
67Summary(pl.UTF-8): Statyczna biblioteka Graphene
68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static Graphene library.
73
74%description static -l pl.UTF-8
75Statyczna biblioteka Graphene.
76
4c5fe2b6
JB
77%package apidocs
78Summary: API documentation for Graphene library
79Summary(pl.UTF-8): Dokumentacja API biblioteki Graphene
80Group: Documentation
eba3a6e7 81BuildArch: noarch
4c5fe2b6
JB
82
83%description apidocs
84API documentation for Graphene library.
85
86%description apidocs -l pl.UTF-8
87Dokumentacja API biblioteki Graphene.
88
c61b6a12
JB
89%prep
90%setup -q
c61b6a12
JB
91
92%build
4b7a3b52
JB
93%meson build \
94 %{!?with_armneon:-Darm_neon=false} \
95 -Dgtk_doc=true \
96 %{!?with_introspection:-Dintrospection=false} \
97 %{!?with_sse2:-Dsse2=false} \
98 -Dtests=false
99
8454996d 100%ninja_build -C build
c61b6a12
JB
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
8454996d 105%ninja_install -C build
c61b6a12
JB
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(644,root,root,755)
66288e3f 115%doc LICENSE.txt README.md
c61b6a12
JB
116%attr(755,root,root) %{_libdir}/libgraphene-1.0.so.*.*.*
117%attr(755,root,root) %ghost %{_libdir}/libgraphene-1.0.so.0
4c5fe2b6
JB
118%if %{with introspection}
119%{_libdir}/girepository-1.0/Graphene-1.0.typelib
120%endif
c61b6a12
JB
121
122%files devel
123%defattr(644,root,root,755)
124%attr(755,root,root) %{_libdir}/libgraphene-1.0.so
125%{_includedir}/graphene-1.0
4c5fe2b6
JB
126%dir %{_libdir}/graphene-1.0
127%{_libdir}/graphene-1.0/include
128%if %{with introspection}
129%{_datadir}/gir-1.0/Graphene-1.0.gir
130%endif
c61b6a12
JB
131%{_pkgconfigdir}/graphene-1.0.pc
132%{_pkgconfigdir}/graphene-gobject-1.0.pc
133
134%if %{with static_libs}
135%files static
136%defattr(644,root,root,755)
137%{_libdir}/libgraphene-1.0.a
138%endif
4c5fe2b6
JB
139
140%files apidocs
141%defattr(644,root,root,755)
142%{_gtkdocdir}/graphene
This page took 0.14528 seconds and 4 git commands to generate.