]> git.pld-linux.org Git - packages/gnustep-back.git/blobdiff - gnustep-back.spec
- freetype epoch
[packages/gnustep-back.git] / gnustep-back.spec
index f44954f7d051b87b903046344e9779f379cd9d77..2f63b15e3fef549c0b2ee46369453d05ea2e31fe 100644 (file)
 Summary:       The GNUstep backend bundle
 Summary(pl.UTF-8):     Pakiet backendowy GNUstep
 Name:          gnustep-back
-Version:       0.13.0
-Release:       2
-License:       LGPL/GPL
+Version:       0.24.0
+Release:       1
+License:       LGPL v2+ (libraries), GPL v3+ (applicatinos)
 Vendor:                The GNUstep Project
 Group:         X11/Libraries
 Source0:       ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
-# Source0-md5: 998466053c8cb651eeadf6d0bf69dd94
+# Source0-md5: 0b8393832bd928b9d3ec4eb68d7f6564
+Patch0:                %{name}-format.patch
 URL:           http://www.gnustep.org/
 BuildRequires: OpenGL-GLX-devel
 %{?with_dps:BuildRequires:     X11-DPS-devel}
 %{?with_cairo:BuildRequires:   cairo-devel >= 1.0}
-%{?with_art:BuildRequires:     freetype-devel >= 2.1.8}
+%{?with_cairo:BuildRequires:   fontconfig-devel}
+%{?with_art:BuildRequires:     freetype-devel >= 1:2.1.8}
 %{?with_glitz:BuildRequires:   glitz-devel}
 BuildRequires: gnustep-gui-devel >= %{version}
 %{?with_art:BuildRequires:     libart_lgpl-devel}
+BuildRequires: libtiff-devel
 BuildRequires: pkgconfig
+BuildRequires: xorg-lib-libXcursor-devel
 BuildRequires: xorg-lib-libXext-devel
-BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXfixes-devel
 BuildRequires: xorg-lib-libXft-devel
+BuildRequires: xorg-lib-libXmu-devel
+%{?with_cairo:BuildRequires:   xorg-lib-libXrender-devel}
+%{?with_dps:BuildRequires:     xorg-lib-libXt-devel}
 Requires:      gnustep-gui >= %{version}
 Obsoletes:     gnustep-back-devel
 %{!?with_dps:Obsoletes:        gnustep-back-xdps}
@@ -36,7 +43,8 @@ Obsoletes:    gnustep-xgps
 Conflicts:     gnustep-core
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep   libGL.so.1 libGLU.so.1
+# bundles version (echo %{version} | cut -d. -f1,2 | tr -d .)
+%define                bver    024
 
 %description
 This is a backend for the GNUstep gui Library which allows you to use
@@ -59,7 +67,7 @@ Summary:      GNUstep graphics backend - art
 Summary(pl.UTF-8):     Graficzny backend GNUstep - art
 Group:         X11/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      freetype >= 2.1.8
+Requires:      freetype >= 1:2.1.8
 Conflicts:     gnustep-core
 
 %description art
@@ -97,6 +105,7 @@ Graficzny backend GNUstep - xdps.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %if %{with cairo}
 # hack cairo header - objc doesn't allow #defines in #include
@@ -123,6 +132,7 @@ ln -sf . back-xlib
 %build
 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
 export GNUSTEP_FLATTENED=yes
+export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
 
 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
 cd back-$g
@@ -132,7 +142,7 @@ else
        NAME="back-$g"
 fi
 if [ "$g" = "cairo" ]; then
-       CPPFLAGS="-I/usr/include/freetype2"
+       CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2"
 fi
 %configure \
        %{!?with_glitz:--disable-glitz} \
@@ -150,6 +160,7 @@ done
 rm -rf $RPM_BUILD_ROOT
 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
 export GNUSTEP_FLATTENED=yes
+export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
 
 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
 if [ "$g" = "xlib" ]; then
@@ -179,40 +190,47 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog
+
 %docdir %{_datadir}/GNUstep/Documentation
 %{_datadir}/GNUstep/Documentation/Developer/Back
+
+%attr(755,root,root) %{_bindir}/font_cacher
+%attr(755,root,root) %{_bindir}/gpbs
+
 %{_mandir}/man1/gpbs.1*
 
-%dir %{_libdir}/GNUstep/Bundles/libgnustep-back-013.bundle
-%{_libdir}/GNUstep/Bundles/libgnustep-back-013.bundle/Resources
-%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-013.bundle/libgnustep-back-013
+%dir %{_libdir}/GNUstep/Bundles/libgnustep-back-%{bver}.bundle
+%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-%{bver}.bundle/libgnustep-back-%{bver}
+%{_libdir}/GNUstep/Bundles/libgnustep-back-%{bver}.bundle/Resources
+%{_libdir}/GNUstep/Bundles/libgnustep-back-%{bver}.bundle/stamp.make
 
 %dir %{_libdir}/GNUstep/Fonts
 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
 %{_libdir}/GNUstep/Fonts/Helvetica.nfont
 
-%attr(755,root,root) %{_bindir}/*
-
 %if %{with art}
 %files art
 %defattr(644,root,root,755)
-%dir %{_libdir}/GNUstep/Bundles/libgnustep-back-art-013.bundle
-%{_libdir}/GNUstep/Bundles/libgnustep-back-art-013.bundle/Resources
-%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-art-013.bundle/libgnustep-back-art-013
+%dir %{_libdir}/GNUstep/Bundles/libgnustep-back-art-%{bver}.bundle
+%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-art-%{bver}.bundle/libgnustep-back-art-%{bver}
+%{_libdir}/GNUstep/Bundles/libgnustep-back-art-%{bver}.bundle/Resources
+%{_libdir}/GNUstep/Bundles/libgnustep-back-art-%{bver}.bundle/stamp.make
 %endif
 
 %if %{with cairo}
 %files cairo
 %defattr(644,root,root,755)
-%dir %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-013.bundle
-%{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-013.bundle/Resources
-%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-013.bundle/libgnustep-back-cairo-013
+%dir %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-%{bver}.bundle
+%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-%{bver}.bundle/libgnustep-back-cairo-%{bver}
+%{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-%{bver}.bundle/Resources
+%{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-%{bver}.bundle/stamp.make
 %endif
 
 %if %{with dps}
 %files xdps
 %defattr(644,root,root,755)
-%dir %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-013.bundle
-%{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-013.bundle/Resources
-%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-013.bundle/libgnustep-back-xdps-013
+%dir %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-%{bver}.bundle
+%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-%{bver}.bundle/libgnustep-back-xdps-%{bver}
+%{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-%{bver}.bundle/Resources
+%{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-%{bver}.bundle/stamp.make
 %endif
This page took 0.062595 seconds and 4 git commands to generate.