]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
Release 2 (by relup.sh)
[packages/git-core.git] / git-core.spec
index 11e56238eddd3527af1228da1fc089630286794b..b77e5de0598f2666eaf06fc95b18d5297e8fa5f5 100644 (file)
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       2.31.0
-Release:       1
+Version:       2.37.2
+Release:       2
 License:       GPL v2
 Group:         Development/Tools
 Source0:       https://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
-# Source0-md5: c7f808ab107b666af45fccb56b9d9676
+# Source0-md5: 2e4cb4fe7f778a9f621a735ba0585009
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
@@ -57,7 +57,8 @@ BuildRequires:        perl-base
 %if %{with gnome_keyring} || %{with libsecret}
 BuildRequires: pkgconfig
 %endif
-BuildRequires: python-devel
+BuildRequires: python3-devel
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.752
@@ -74,6 +75,7 @@ BuildRequires:        docbook-dtd45-xml
 BuildRequires: xmlto
 %endif
 %if %{with tests}
+BuildRequires: openssh-clients
 BuildRequires: perl-CGI
 BuildRequires: perl-Digest-MD5
 BuildRequires: perl-Encode
@@ -103,8 +105,8 @@ Suggests:   less
 Suggests:      openssh-clients
 Suggests:      perl-Git = %{version}-%{release}
 Suggests:      rsync
-Obsoletes:     git-core-gitview
-Obsoletes:     python-Git
+Obsoletes:     git-core-gitview < 2.12.1
+Obsoletes:     python-Git < 1.8.5
 Conflicts:     perl-Git < %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -172,9 +174,9 @@ Summary(pl.UTF-8):  Pliki niezbędne do uruchomienia git-daemona w trybie usługi
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      setup >= 2.4.11-1
-Provides:      git-core-daemon
-Obsoletes:     git-core-daemon
-Obsoletes:     git-core-daemon-standalone
+Provides:      git-core-daemon = %{version}-%{release}
+Obsoletes:     git-core-daemon <= %{version}-%{release}
+Obsoletes:     git-core-daemon-standalone <= %{version}-%{release}
 
 %description daemon-inetd
 Git-daemon is a really simple TCP git daemon that can serve git
@@ -191,9 +193,9 @@ Summary:    Files necessary to run git-daemon as a standalone service
 Summary(pl.UTF-8):     Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
-Provides:      git-core-daemon
-Obsoletes:     git-core-daemon
-Obsoletes:     git-core-daemon-inetd
+Provides:      git-core-daemon = %{version}-%{release}
+Obsoletes:     git-core-daemon <= %{version}-%{release}
+Obsoletes:     git-core-daemon-inetd <= %{version}-%{release}
 
 %description daemon-standalone
 Git-daemon is a really simple TCP git daemon that can serve git
@@ -361,6 +363,7 @@ Group:              Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      perl-Encode
 Requires:      perl-Term-ReadKey
+Requires:      perl-modules
 
 %description svn
 Subversion support for Git.
@@ -388,7 +391,7 @@ Summary:    bash-completion for git
 Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gita
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
-Requires:      bash-completion >= 2.0
+Requires:      bash-completion >= 1:2.0
 BuildArch:     noarch
 
 %description -n bash-completion-git
@@ -401,7 +404,8 @@ Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
 Summary:       Perl interface to the Git version control system
 Summary(pl.UTF-8):     Perlowy interfejs do systemu kontroli wersji Git
 Group:         Development/Languages/Perl
-Obsoletes:     perl-git-core
+Requires:      perl-Error
+Obsoletes:     perl-git-core < 1.4.3.5
 BuildArch:     noarch
 
 %description -n perl-Git
@@ -460,6 +464,21 @@ uwierzytelniać się przy użyciu mechanizmu GNOME libsecret.
 Moduł trzeba zarejestrować poleceniem:
 - git config --global credential.helper libsecret
 
+%package -n zsh-completion-git
+Summary:       Zsh completion for git command
+Summary(pl.UTF-8):     Dopełnianie parametrów komendy git dla powłoki zsh
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion-git = %{version}-%{release}
+Requires:      zsh
+BuildArch:     noarch
+
+%description -n zsh-completion-git
+Zsh completion for git command.
+
+%description -n zsh-completion-git -l pl.UTF-8
+Dopełnianie parametrów komendy git dla powłoki zsh.
+
 %prep
 %setup -q -n git-%{version}
 %patch0 -p0
@@ -471,15 +490,14 @@ Moduł trzeba zarejestrować poleceniem:
 # we build things in contrib but want to have it clean for doc purporses, too
 cp -a contrib contrib-doc
 
-%{__sed} -i -e '1s|#!/usr/bin/env python$|#!%{__python}|' git-p4.py
-
 %build
 %{__aclocal}
 %{__autoconf}
 %configure \
        --sysconfdir=%{_sysconfdir}/git-core \
        %{?with_pcre:--with-libpcre2} \
-       --with-openssl
+       --with-openssl \
+       --with-python="%{__python3}"
 
 echo "BLK_SHA1=1" >> config.mak
 
@@ -582,6 +600,9 @@ install -p contrib/credential/libsecret/git-credential-libsecret $RPM_BUILD_ROOT
 # bash completion
 install -d $RPM_BUILD_ROOT%{bash_compdir}
 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
+install -d $RPM_BUILD_ROOT%{zsh_compdir}
+cp -p contrib/completion/git-completion.zsh $RPM_BUILD_ROOT%{zsh_compdir}/_git
+sed -i -e "1 a zstyle ':completion:*:*:git:*' script %{bash_compdir}/git" $RPM_BUILD_ROOT%{zsh_compdir}/_git
 
 # Install git-prompt.sh
 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
@@ -631,9 +652,6 @@ ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-https
 ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftp
 ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftps
 
-# remove unneeded files
-%py_postclean
-
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
 %find_lang git
 
@@ -932,3 +950,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{gitcoredir}/git-credential-libsecret
 %endif
+
+%files -n zsh-completion-git
+%defattr(644,root,root,755)
+%{zsh_compdir}/_git
This page took 0.169176 seconds and 4 git commands to generate.