]> git.pld-linux.org Git - packages/ghc-zlib.git/blobdiff - ghc-zlib.spec
- updated to 0.5.4.1
[packages/ghc-zlib.git] / ghc-zlib.spec
index a48fb903c8e69129753a97270d1290366af5db9e..1074b2c77df82c1724c405b2f46ff5b08b8eee77 100644 (file)
@@ -1,29 +1,53 @@
-%define        pkgname zlib
+%define                pkgname zlib
 Summary:       Compression and decompression in the gzip and zlib formats
+Summary(pl.UTF-8):     Kompresja i dekompresja formatów gzip i zlib
 Name:          ghc-%{pkgname}
-Version:       0.5.2.0
+Version:       0.5.4.1
 Release:       1
 License:       BSD
 Group:         Development/Languages
-Source0:       http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
-# Source0-md5: 19859e241dc18ef1501a5d44d8523507
-URL:           http://hackage.haskell.org/package/%{pkgname}/
-BuildRequires: ghc >= 6.10
+#Source0Download: http://hackage.haskell.org/package/zlib
+Source0:       http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
+# Source0-md5: d0d10786d2bbd1d401a8b28a83e88475
+URL:           http://hackage.haskell.org/package/zlib
+BuildRequires: ghc >= 6.12.3
+BuildRequires: rpmbuild(macros) >= 1.608
 %requires_eq   ghc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                libsubdir       ghc-%(/usr/bin/ghc --numeric-version)/%{pkgname}-%{version}
+# debuginfo is not useful for ghc
+%define                _enable_debug_packages  0
 
 %description
 This package provides a pure interface for compressing and
-decompressing streams of data represented as lazy
-'ByteString's. It uses the zlib C library so it has high
-performance. It supports the "zlib", "gzip" and "raw"
-compression formats.
+decompressing streams of data represented as lazy 'ByteString's. It
+uses the zlib C library so it has high performance. It supports the
+"zlib", "gzip" and "raw" compression formats.
 
-It provides a convenient high level API suitable for most
-tasks and for the few cases where more control is needed it
-provides access to the full zlib feature set.
+It provides a convenient high level API suitable for most tasks and
+for the few cases where more control is needed it provides access to
+the full zlib feature set.
+
+%description -l pl.UTF-8
+Ten pakiet zapewnia czysty interfejs do kompresji i dekompresji
+strumieni danych reprezentowanych jako leniwe "ByteString"i.
+Wykorzystuje bibliotekę C zlib, więc ma dużą wydajność. Obsługuje
+formaty kompresji "zlib", "gzip" i "surowy".
+
+Udostępnia wygodne, wysokopoziomowe API, nadające się do większości
+zadań; dla nielicznych przypadków, gdzie potrzeba większej kontroli,
+daje dostęp do pełnych możliwości zliba.
+
+%package doc
+Summary:       HTML documentation for %{pkgname} ghc package
+Summary(pl.UTF-8):     Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
+Group:         Documentation
+
+%description doc
+HTML documentation for %{pkgname} ghc package.
+
+%description doc -l pl.UTF-8
+Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
 
 %prep
 %setup -q -n %{pkgname}-%{version}
@@ -33,35 +57,40 @@ runhaskell Setup.hs configure -v2 \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --libexecdir=%{_libexecdir} \
-       --libsubdir=%{libsubdir} \
-       --docdir=%{_defaultdocdir}/%{name}-%{version}
+       --docdir=%{_docdir}/%{name}-%{version}
 
 runhaskell Setup.hs build
 runhaskell Setup.hs haddock --executables
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
+
 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
 
 # work around automatic haddock docs installation
-rm -rf %{name}-%{version}-doc
-cp -a $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version} %{name}-%{version}-doc
+%{__rm} -rf %{name}-%{version}-doc
+cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
 runhaskell Setup.hs register \
-       --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{libsubdir}/%{pkgname}.conf
+       --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/bin/ghc-pkg update %{_libdir}/%{libsubdir}/%{pkgname}.conf
+%ghc_pkg_recache
 
 %postun
-if [ "$1" = "0" ]; then
-       /usr/bin/ghc-pkg unregister %{pkgname}-%{version}
-fi
+%ghc_pkg_recache
 
 %files
 %defattr(644,root,root,755)
-%doc %{name}-%{version}-doc/html
-%{_libdir}/%{libsubdir}
+%doc LICENSE
+%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
+
+%files doc
+%defattr(644,root,root,755)
+%doc %{name}-%{version}-doc/*
This page took 0.067319 seconds and 4 git commands to generate.