]> git.pld-linux.org Git - packages/ghc-zlib.git/blame - ghc-zlib.spec
- use %ghc_pkg_recache macro; make url copyable; %ghcdir in rpmbuild macros
[packages/ghc-zlib.git] / ghc-zlib.spec
CommitLineData
1caf459d 1%define pkgname zlib
8ff4c5a8
JR
2Summary: Compression and decompression in the gzip and zlib formats
3Name: ghc-%{pkgname}
4Version: 0.5.2.0
20e30a4b 5Release: 2
8ff4c5a8
JR
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: 19859e241dc18ef1501a5d44d8523507
1caf459d 10URL: http://hackage.haskell.org/package/zlib/
2fc7e84b 11BuildRequires: ghc >= 6.12.3
1caf459d 12BuildRequires: rpmbuild(macros) >= 1.608
2609efe3 13%requires_releq ghc
8ff4c5a8
JR
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
8ff4c5a8
JR
16%description
17This package provides a pure interface for compressing and
18decompressing streams of data represented as lazy
19'ByteString's. It uses the zlib C library so it has high
20performance. It supports the "zlib", "gzip" and "raw"
21compression formats.
22
23It provides a convenient high level API suitable for most
24tasks and for the few cases where more control is needed it
25provides access to the full zlib feature set.
26
27%prep
28%setup -q -n %{pkgname}-%{version}
29
30%build
31runhaskell Setup.hs configure -v2 \
32 --prefix=%{_prefix} \
33 --libdir=%{_libdir} \
34 --libexecdir=%{_libexecdir} \
0cfb4e7c 35 --docdir=%{_docdir}/%{name}-%{version}
8ff4c5a8
JR
36
37runhaskell Setup.hs build
38runhaskell Setup.hs haddock --executables
39
40%install
41rm -rf $RPM_BUILD_ROOT
2fc7e84b
JR
42install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
43
8ff4c5a8
JR
44runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
45
46# work around automatic haddock docs installation
47rm -rf %{name}-%{version}-doc
0cfb4e7c 48cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
8ff4c5a8
JR
49
50runhaskell Setup.hs register \
2fc7e84b 51 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
8ff4c5a8
JR
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post
1caf459d 57%ghc_pkg_recache
8ff4c5a8
JR
58
59%postun
1caf459d 60%ghc_pkg_recache
8ff4c5a8
JR
61
62%files
63%defattr(644,root,root,755)
64%doc %{name}-%{version}-doc/html
2fc7e84b
JR
65%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
66%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
This page took 1.298811 seconds and 4 git commands to generate.