]> git.pld-linux.org Git - packages/ghc-regex-pcre.git/blame - ghc-regex-pcre.spec
rebuild with ghc 8.10.7
[packages/ghc-regex-pcre.git] / ghc-regex-pcre.spec
CommitLineData
6b97c135
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
12441fb6
JR
5%define pkgname regex-pcre
6Summary: Replaces/Enhances Text.Regex
6b97c135 7Summary(pl.UTF-8): Rozszerzenie Text.Regex
12441fb6 8Name: ghc-%{pkgname}
00c990f0 9Version: 0.95.0.0
81e09426 10Release: 2
12441fb6
JR
11License: BSD
12Group: Development/Languages
6b97c135
JB
13#Source0Download: http://hackage.haskell.org/package/regex-pcre
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
00c990f0
JR
15# Source0-md5: a9dcdff506937df7fadb563a030b508b
16Patch0: ghc-8.10.patch
6b97c135 17URL: http://hackage.haskell.org/package/regex-pcre
12441fb6 18BuildRequires: ghc >= 6.12.3
6b97c135
JB
19BuildRequires: ghc-array
20BuildRequires: ghc-base >= 3.0
21BuildRequires: ghc-bytestring
22BuildRequires: ghc-containers
23BuildRequires: ghc-regex-base >= 0.93
24%if %{with prof}
25BuildRequires: ghc-prof >= 6.12.3
26BuildRequires: ghc-array-prof
27BuildRequires: ghc-base-prof >= 3.0
28BuildRequires: ghc-bytestring-prof
29BuildRequires: ghc-containers-prof
30BuildRequires: ghc-regex-base-prof >= 0.93
31%endif
12441fb6 32BuildRequires: rpmbuild(macros) >= 1.608
12441fb6 33Requires(post,postun): /usr/bin/ghc-pkg
4cbeff40 34%requires_eq ghc
6b97c135
JB
35Requires: ghc-array
36Requires: ghc-base >= 3.0
37Requires: ghc-bytestring
38Requires: ghc-containers
39Requires: ghc-regex-base >= 0.93
12441fb6
JR
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42# debuginfo is not useful for ghc
43%define _enable_debug_packages 0
44
6b97c135 45# don't compress haddock files
12441fb6
JR
46%define _noautocompressdoc *.haddock
47
48%description
6b97c135
JB
49The PCRE backend to accompany regex-base, see <http://www.pcre.org/>.
50
51%description -l pl.UTF-8
52Backend PCRE towarzyszący regex-base wykorzystujący bibliotekę PCRE
53(<http://www.pcre.org/>).
12441fb6
JR
54
55%package prof
56Summary: Profiling %{pkgname} library for GHC
57Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
6b97c135
JB
60Requires: ghc-array-prof
61Requires: ghc-base-prof >= 3.0
62Requires: ghc-bytestring-prof
63Requires: ghc-containers-prof
64Requires: ghc-regex-base-prof >= 0.93
12441fb6
JR
65
66%description prof
6b97c135 67Profiling %{pkgname} library for GHC. Should be installed when
12441fb6
JR
68GHC's profiling subsystem is needed.
69
70%description prof -l pl.UTF-8
71Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
72kiedy potrzebujemy systemu profilującego z GHC.
73
74%prep
75%setup -q -n %{pkgname}-%{version}
00c990f0 76%patch0 -p1
12441fb6
JR
77
78%build
6b97c135
JB
79runhaskell Setup.hs configure -v2 \
80 %{?with_prof:--enable-library-profiling} \
12441fb6
JR
81 --prefix=%{_prefix} \
82 --libdir=%{_libdir} \
83 --libexecdir=%{_libexecdir} \
84 --docdir=%{_docdir}/%{name}-%{version}
85
86runhaskell Setup.hs build
87runhaskell Setup.hs haddock --executables
88
89%install
90rm -rf $RPM_BUILD_ROOT
91install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
92
93runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
94
95# work around automatic haddock docs installation
96%{__rm} -rf %{name}-%{version}-doc
97cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
98%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
99
100runhaskell Setup.hs register \
6b97c135 101 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
12441fb6
JR
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post
107%ghc_pkg_recache
108
109%postun
110%ghc_pkg_recache
111
112%files
113%defattr(644,root,root,755)
114%doc %{name}-%{version}-doc/*
115%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
116%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
00c990f0
JR
117%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-pcre-%{version}-*.so
118%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-pcre-%{version}-*.a
119%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-pcre-%{version}-*_p.a
12441fb6 120
00c990f0
JR
121%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
122%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
12441fb6
JR
123%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
124%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex
12441fb6 125%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.hi
00c990f0 126%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.dyn_hi
6b97c135 127%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE
12441fb6 128%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/*.hi
00c990f0 129%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/*.dyn_hi
6b97c135 130%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/ByteString
12441fb6 131%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/ByteString/*.hi
00c990f0 132%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/ByteString/*.dyn_hi
12441fb6 133
6b97c135 134%if %{with prof}
12441fb6
JR
135%files prof
136%defattr(644,root,root,755)
00c990f0
JR
137%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-pcre-%{version}-*_p.a
138%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
12441fb6
JR
139%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.p_hi
140%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/*.p_hi
141%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/ByteString/*.p_hi
6b97c135 142%endif
This page took 0.101238 seconds and 4 git commands to generate.