]> git.pld-linux.org Git - packages/ghc-regex-base.git/blame - ghc-regex-base.spec
rebuild with ghc 8.10.7
[packages/ghc-regex-base.git] / ghc-regex-base.spec
CommitLineData
a98fc438
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname regex-base
6Summary: Interface API for regex-posix,pcre,parsec,tdfa,dfa
7Summary(pl.UTF-8): API interfejsu dla regex-posix,pcre,parsec,tdfa,dfa
8Name: ghc-%{pkgname}
60e479b9 9Version: 0.94.0.0
0b5cf807 10Release: 2
a98fc438
JB
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/regex-base
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
60e479b9
JR
15# Source0-md5: 91f7a3e19e419fb048b8babfecc1294b
16Patch0: ghc-8.10.patch
a98fc438
JB
17URL: http://hackage.haskell.org/package/regex-base
18BuildRequires: ghc >= 6.12.3
19BuildRequires: ghc-array
20BuildRequires: ghc-base >= 3.0
21BuildRequires: ghc-bytestring
22BuildRequires: ghc-containers
23BuildRequires: ghc-mtl
24%if %{with prof}
25BuildRequires: ghc-prof >= 6.12.3
26BuildRequires: ghc-array-prof
27BuildRequires: ghc-base-prof >= 3.0
28BuildRequires: ghc-bytestring-prof
29BuildRequires: ghc-containers-prof
30BuildRequires: ghc-mtl-prof
31%endif
32BuildRequires: rpmbuild(macros) >= 1.608
33Requires(post,postun): /usr/bin/ghc-pkg
67c9ce6a 34%requires_eq ghc
a98fc438
JB
35Requires: ghc-array
36Requires: ghc-base >= 3.0
37Requires: ghc-bytestring
38Requires: ghc-containers
39Requires: ghc-mtl
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42# debuginfo is not useful for ghc
43%define _enable_debug_packages 0
44
45# don't compress haddock files
46%define _noautocompressdoc *.haddock
47
48%description
49Interface API for regex-posix,pcre,parsec,tdfa,dfa.
50
51%description -l pl.UTF-8
52API interfejsu dla regex-posix,pcre,parsec,tdfa,dfa.
53
54%package prof
55Summary: Profiling %{pkgname} library for GHC
56Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: ghc-array-prof
60Requires: ghc-base-prof >= 3.0
61Requires: ghc-bytestring-prof
62Requires: ghc-containers-prof
63Requires: ghc-mtl-prof
64
65%description prof
66Profiling %{pkgname} library for GHC. Should be installed when
67GHC's profiling subsystem is needed.
68
69%description prof -l pl.UTF-8
70Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
71kiedy potrzebujemy systemu profilującego z GHC.
72
73%package doc
74Summary: HTML documentation for ghc %{pkgname} package
75Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
76Group: Documentation
77
78%description doc
79HTML documentation for ghc %{pkgname} package.
80
81%description doc -l pl.UTF-8
82Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
83
84%prep
85%setup -q -n %{pkgname}-%{version}
60e479b9 86%patch0 -p1
a98fc438
JB
87
88%build
89runhaskell Setup.hs configure -v2 \
90 %{?with_prof:--enable-library-profiling} \
91 --prefix=%{_prefix} \
92 --libdir=%{_libdir} \
93 --libexecdir=%{_libexecdir} \
94 --docdir=%{_docdir}/%{name}-%{version}
95
96runhaskell Setup.hs build
97runhaskell Setup.hs haddock --executables
98
99%install
100rm -rf $RPM_BUILD_ROOT
101install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
102
103runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
104
105# work around automatic haddock docs installation
106%{__rm} -rf %{name}-%{version}-doc
107cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
108%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
109
110runhaskell Setup.hs register \
111 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post
117%ghc_pkg_recache
118
119%postun
120%ghc_pkg_recache
121
122%files
123%defattr(644,root,root,755)
124%doc LICENSE
125%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
126%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
60e479b9
JR
127%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-base-%{version}-*.so
128%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-base-%{version}-*.a
129%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-base-%{version}-*_p.a
130%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
131%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
a98fc438
JB
132%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
133%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex
60e479b9
JR
134%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.hi
135%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.dyn_hi
a98fc438
JB
136%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Base
137%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Base/*.hi
60e479b9 138%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Base/*.dyn_hi
a98fc438
JB
139
140%files prof
141%defattr(644,root,root,755)
60e479b9
JR
142%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-base-%{version}-*_p.a
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
144%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.p_hi
a98fc438
JB
145%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Base/*.p_hi
146
147%files doc
148%defattr(644,root,root,755)
149%doc %{name}-%{version}-doc/*
This page took 0.096641 seconds and 4 git commands to generate.