]> git.pld-linux.org Git - packages/ghc-base16-bytestring.git/blame - ghc-base16-bytestring.spec
rebuild with ghc 8.10.7
[packages/ghc-base16-bytestring.git] / ghc-base16-bytestring.spec
CommitLineData
e4bf329c
JR
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname base16-bytestring
6Summary: Fast base16 (hex) encoding and decoding for ByteStrings
7Name: ghc-%{pkgname}
8Version: 0.1.1.6
085eac18 9Release: 2
e4bf329c
JR
10License: BSD
11Group: Development/Languages
12#Source0Download: http://hackage.haskell.org/package/base16-bytestring
13Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14# Source0-md5: b6aac9d679d7dd84c3cd23cbc143eb29
15URL: http://hackage.haskell.org/package/base16-bytestring
16BuildRequires: ghc >= 6.12.3
17%if %{with prof}
18BuildRequires: ghc-prof
19%endif
20BuildRequires: rpmbuild(macros) >= 1.608
21%requires_eq ghc
22Requires(post,postun): /usr/bin/ghc-pkg
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25# debuginfo is not useful for ghc
26%define _enable_debug_packages 0
27
28# don't compress haddock files
29%define _noautocompressdoc *.haddock
30
31%description
32Fast base16 (hex) encoding and decoding for ByteStrings.
33
34%package prof
35Summary: Profiling %{pkgname} library for GHC
36Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description prof
41Profiling %{pkgname} library for GHC. Should be installed when
42GHC's profiling subsystem is needed.
43
44%description prof -l pl.UTF-8
45Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
46kiedy potrzebujemy systemu profilującego z GHC.
47
48%prep
49%setup -q -n %{pkgname}-%{version}
50
51%build
52runhaskell Setup.hs configure -v2 \
53 %{?with_prof:--enable-library-profiling} \
54 --prefix=%{_prefix} \
55 --libdir=%{_libdir} \
56 --libexecdir=%{_libexecdir} \
57 --docdir=%{_docdir}/%{name}-%{version}
58
59runhaskell Setup.hs build
60runhaskell Setup.hs haddock --executables
61
62%install
63rm -rf $RPM_BUILD_ROOT
64install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
65
66runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
67
68# work around automatic haddock docs installation
69%{__rm} -rf %{name}-%{version}-doc
70cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
71%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
72
73runhaskell Setup.hs register \
74 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post
80%ghc_pkg_recache
81
82%postun
83%ghc_pkg_recache
84
85%files
86%defattr(644,root,root,755)
87%doc README.markdown %{name}-%{version}-doc/*
88%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
89%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
90%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
91%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
92%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
93
94%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
95%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ByteString
96%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ByteString/*.hi
97%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ByteString/*.dyn_hi
98%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ByteString/Base16
99%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ByteString/Base16/*.hi
100%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ByteString/Base16/*.dyn_hi
101
102%if %{with prof}
103%files prof
104%defattr(644,root,root,755)
105%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
106%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ByteString/*.p_hi
107%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ByteString/Base16/*.p_hi
108%endif
This page took 0.09964 seconds and 4 git commands to generate.