]> git.pld-linux.org Git - packages/ghc-asn1-encoding.git/blame - ghc-asn1-encoding.spec
rebuild with ghc 8.10.7
[packages/ghc-asn1-encoding.git] / ghc-asn1-encoding.spec
CommitLineData
80dfe38d
JR
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname asn1-encoding
6Summary: ASN1 data reader and writer in RAW, BER and DER forms
7Name: ghc-%{pkgname}
8Version: 0.9.6
24178869 9Release: 2
80dfe38d
JR
10License: BSD
11Group: Development/Languages
12#Source0Download: http://hackage.haskell.org/package/asn1-encoding
13Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14# Source0-md5: 98bc3d5b717eb6b5f47c2d676c9eaaf4
15URL: http://hackage.haskell.org/package/asn1-encoding
16BuildRequires: ghc >= 6.12.3
17BuildRequires: ghc-asn1-types >= 0.3.0
18BuildRequires: ghc-hourglass >= 0.2.6
19%if %{with prof}
20BuildRequires: ghc-prof
21BuildRequires: ghc-asn1-types-prof >= 0.3.0
22BuildRequires: ghc-hourglass-prof >= 0.2.6
23%endif
24BuildRequires: rpmbuild(macros) >= 1.608
25%requires_eq ghc
26Requires(post,postun): /usr/bin/ghc-pkg
27Requires: ghc-asn1-types >= 0.3.0
28Requires: ghc-hourglass >= 0.2.6
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31# debuginfo is not useful for ghc
32%define _enable_debug_packages 0
33
34# don't compress haddock files
35%define _noautocompressdoc *.haddock
36
37%description
38ASN1 data reader and writer in raw form with supports for high level
39forms of ASN1 (BER, and DER).
40
41%package prof
42Summary: Profiling %{pkgname} library for GHC
43Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: ghc-asn1-types-prof >= 0.3.0
47Requires: ghc-hourglass-prof >= 0.2.6
48
49%description prof
50Profiling %{pkgname} library for GHC. Should be installed when
51GHC's profiling subsystem is needed.
52
53%description prof -l pl.UTF-8
54Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
55kiedy potrzebujemy systemu profilującego z GHC.
56
57%prep
58%setup -q -n %{pkgname}-%{version}
59
60%build
61runhaskell Setup.hs configure -v2 \
62 %{?with_prof:--enable-library-profiling} \
63 --prefix=%{_prefix} \
64 --libdir=%{_libdir} \
65 --libexecdir=%{_libexecdir} \
66 --docdir=%{_docdir}/%{name}-%{version}
67
68runhaskell Setup.hs build
69runhaskell Setup.hs haddock --executables
70
71%install
72rm -rf $RPM_BUILD_ROOT
73install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
74
75runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
76
77# work around automatic haddock docs installation
78%{__rm} -rf %{name}-%{version}-doc
79cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
80%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
81
82runhaskell Setup.hs register \
83 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post
89%ghc_pkg_recache
90
91%postun
92%ghc_pkg_recache
93
94%files
95%defattr(644,root,root,755)
96%doc %{name}-%{version}-doc/*
97%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
98%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
99%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
100%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
101%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
102
103%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
104%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ASN1
105%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ASN1/*.hi
106%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ASN1/*.dyn_hi
107%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ASN1/BinaryEncoding
108%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ASN1/BinaryEncoding/*.hi
109%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ASN1/BinaryEncoding/*.dyn_hi
110
111%if %{with prof}
112%files prof
113%defattr(644,root,root,755)
114%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
115%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ASN1/*.p_hi
116%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/ASN1/BinaryEncoding/*.p_hi
117%endif
This page took 0.109606 seconds and 4 git commands to generate.