]> git.pld-linux.org Git - packages/geninitrd.git/blame - geninitrd.spec
- rel 3; crc32c handling from svn
[packages/geninitrd.git] / geninitrd.spec
CommitLineData
5bba2f6c 1# TODO:
8d4b3be5
PG
2# - BUG: you can't set in /etc/mdadm.conf:
3# DEVICE partitions containers
4# (which is default BTW if none set). Generation of initrd will fail
5#
70a0ef68 6Summary: Creates an initial ramdisk image for preloading modules
4bd9777f 7Summary(pl.UTF-8): Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
70a0ef68 8Name: geninitrd
8b335fe9 9Version: 12582
c20a1e23 10Release: 3
70a0ef68 11License: GPL
6e7d5844 12Group: Applications/System
3adc6ee3 13Source0: %{name}-%{version}.tar.gz
b0d4c77e 14# Source0-md5: 1761d2097523b5c248c5846ebd3685d3
929a4239 15Patch0: %{name}-romfs.patch
b05ab846 16Patch1: %{name}-gzip-compressor.patch
cd449994
ER
17# svn diff http://svn.pld-linux.org/svn/geninitrd/trunk -r 12585:HEAD > geninitrd-svn.patch
18Patch2: %{name}-svn.patch
aa605112 19URL: http://svn.pld-linux.org/trac/svn/wiki/packages/geninitrd
0dd71c4b 20BuildRequires: xmlto >= 0:0.0.18-1
fe2d4469 21Requires: /usr/bin/ldd
0e068c76 22Requires: awk
7c70c4dc 23Requires: busybox-initrd >= 1.1.0
417ef52a 24Requires: coreutils
7b29e9b5 25Requires: cpio
0e068c76 26Requires: fileutils
87c020ab 27Requires: glibc-misc
0e068c76 28Requires: gzip
16ac31fd 29Requires: mktemp >= 1.5-8
0e068c76 30Requires: mount
495990cb 31Requires: pci-database >= 0.4
e018b691 32Requires: rc-scripts >= 0.2.7
0e068c76 33Requires: tar
b7842622 34Requires: virtual(module-tools)
6f0074bc 35%if "%{pld_release}" == "ti"
36Requires: lvm2-initrd
37Requires: mdadm-initrd >= 1.12.0-1
38%else
55c24912 39# otherwise LVM subsystem is not enabled in geninitrd
f3d68afb 40Suggests: lvm2-initrd
e018b691 41# without this softraid installations of PLD fail
ac7d5e9a 42Suggests: mdadm-initrd >= 1.12.0-1
6f0074bc 43%endif
229da7eb 44Suggests: genromfs
2a458b9c 45Suggests: pciutils
55c24912
ER
46# suggest for blkid
47%if "%{pld_release}" != "ac"
244b296a 48Suggests: util-linux-initrd
55c24912 49%endif
70a0ef68 50Obsoletes: mkinitrd
fe2d4469
ER
51%if "%{pld_release}" == "ac"
52Conflicts: grubby < 5.0.4-3.1
53%else
429e8b1c 54Conflicts: grubby < 6.0.24-3
fe2d4469 55%endif
c7e102da 56Conflicts: kmod < 7-2
b7842622 57Conflicts: module-init-tools < 3.2.2-6
c5ec450e 58Conflicts: pciutils < 2.2.9
a843f5f7 59Conflicts: udev-initrd < 1:168
ba3bd13f 60Conflicts: xz < 4.999.9
cf111fa1 61BuildArch: noarch
70a0ef68
JK
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%description
570eccb2
ER
65Geninitrd creates filesystem images for use as initial ramdisk
66(initrd) images. These ramdisk images are often used to preload the
67block device modules (SCSI or RAID) needed to access the root
68filesystem.
70a0ef68
JK
69
70In other words, generic kernels can be built without drivers for any
71SCSI adapters which load the SCSI driver as a module. Since the kernel
72needs to read those modules, but in this case it isn't able to address
73the SCSI adapter, an initial ramdisk is used. The initial ramdisk is
74loaded by the operating system loader (normally LILO) and is available
75to the kernel as soon as the ramdisk is loaded. The ramdisk image
76loads the proper SCSI adapter and allows the kernel to mount the root
77filesystem. The geninitrd program creates such a ramdisk using
78information found in the /etc/modules.conf file.
79
54baa167
JR
80%description -l pl.UTF-8
81Geninitrd służy do tworzenia obrazu systemu plikowego używanego jako
82inicjalny ramdysk (initrd), z którego przy starcie systemu są ładowane
83moduły kernela z obsługą urządzeń których obsługa nie jest
84wkompilowana w kernel. Zazwyczaj modułami ładowanymi z inicjalnego
85systemu plikowego są sterowniki SCSI, IDE czy też RAID po to żeby w
86dalszej części inicjacji systemu był możliwy dostęp do głównego
70a0ef68
JK
87systemu plikowego (root fs).
88
54baa167
JR
89Dzięki initrd jest możliwe używanie dystrybucyjnego kernela w którym
90wkompilowana jest minimalna ilość obsługi różnych urządzeń, a reszta
91kodu obsługi sterowników SCSI, IDE czy RAID jest doczytywana w trakcie
70a0ef68 92startu z initrd. Skrypt geninitrd generuje obraz ramdysku na podstawie
54baa167 93bieżących informacji zawartych w /etc/modules.conf.
70a0ef68
JK
94
95%prep
96%setup -q
929a4239 97%if "%{pld_release}" == "ti"
98%patch0 -p1
b05ab846 99%patch1 -p1
929a4239 100%endif
cd449994 101%patch2 -p0
f2aef47d 102
0dd71c4b 103%build
e0c74de2 104%{__make}
0dd71c4b 105
70a0ef68
JK
106%install
107rm -rf $RPM_BUILD_ROOT
37688ad3 108%{__make} install \
e0c74de2 109 DESTDIR=$RPM_BUILD_ROOT
70a0ef68
JK
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files
115%defattr(644,root,root,755)
61d0a20b 116%doc ChangeLog
417ef52a 117%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/geninitrd
70a0ef68 118%attr(755,root,root) /sbin/geninitrd
429e8b1c 119%{_mandir}/man8/geninitrd.8*
417ef52a 120
429e8b1c
ER
121%dir /lib/geninitrd
122/lib/geninitrd/functions
123/lib/geninitrd/mod-*.sh
824e8293 124%attr(755,root,root) /lib/geninitrd/extract-ikconfig
2bc9ddcf
ER
125
126%dir /lib/geninitrd/udev-rules
127/lib/geninitrd/udev-rules/*.rules
This page took 0.100631 seconds and 4 git commands to generate.